summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-08-08 20:20:52 +0000
committerFabian Groffen <grobian@gentoo.org>2011-08-08 20:20:52 +0000
commitb06c955bdfd65c3d41f9ce872e071c568472e47e (patch)
treec738e440eb2e71a867d63ba31e047b788f2cc52b
parentMarked ~x64-macos (diff)
downloadgentoo-2-b06c955bdfd65c3d41f9ce872e071c568472e47e.tar.gz
gentoo-2-b06c955bdfd65c3d41f9ce872e071c568472e47e.tar.bz2
gentoo-2-b06c955bdfd65c3d41f9ce872e071c568472e47e.zip
Fixed for OSX Lion (10.7), marked ~x64-macos
(Portage version: 2.2.01.19011-prefix/cvs/Darwin powerpc)
-rw-r--r--app-text/vilistextum/ChangeLog6
-rw-r--r--app-text/vilistextum/files/vilistextum-2.6.9-darwin11.patch23
-rw-r--r--app-text/vilistextum/vilistextum-2.6.9.ebuild7
3 files changed, 32 insertions, 4 deletions
diff --git a/app-text/vilistextum/ChangeLog b/app-text/vilistextum/ChangeLog
index 68c60be61b9a..a11f8cda0186 100644
--- a/app-text/vilistextum/ChangeLog
+++ b/app-text/vilistextum/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/vilistextum
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/ChangeLog,v 1.36 2011/03/27 21:57:11 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/ChangeLog,v 1.37 2011/08/08 20:20:51 grobian Exp $
+
+ 08 Aug 2011; Fabian Groffen <grobian@gentoo.org> vilistextum-2.6.9.ebuild,
+ +files/vilistextum-2.6.9-darwin11.patch:
+ Fixed for OSX Lion (10.7), marked ~x64-macos
27 Mar 2011; Jeremy Olexa <darkside@gentoo.org> -vilistextum-2.6.7.ebuild,
-vilistextum-2.6.7-r1.ebuild:
diff --git a/app-text/vilistextum/files/vilistextum-2.6.9-darwin11.patch b/app-text/vilistextum/files/vilistextum-2.6.9-darwin11.patch
new file mode 100644
index 000000000000..bda9f5d39c3e
--- /dev/null
+++ b/app-text/vilistextum/files/vilistextum-2.6.9-darwin11.patch
@@ -0,0 +1,23 @@
+OSX Lion has wcscasecmp, but is not GNU
+
+--- configure.in
++++ configure.in
+@@ -67,6 +67,7 @@
+ dnl Checks for library functions.
+ AC_CHECK_FUNCS(strstr)
+ AC_CHECK_FUNCS(strcasecmp)
++AC_CHECK_FUNCS(wcscasecmp)
+
+ dnl create testsuite
+ dnl AC_CONFIG_TESTDIR([tests])
+--- src/html.c
++++ src/html.c
+@@ -40,7 +40,7 @@
+ link_inline[DEF_STR_LEN]; /* Link of a HTML-Tag */
+
+ /* ------------------------------------------------ */
+-#if defined(MULTIBYTE) && ! defined(__GNU_LIBRARY__)
++#if defined(MULTIBYTE) && ! defined(HAVE_WCSCASECMP)
+ #include <wchar.h>
+ static int wcscasecmp(const wchar_t *s1, const wchar_t *s2)
+ {
diff --git a/app-text/vilistextum/vilistextum-2.6.9.ebuild b/app-text/vilistextum/vilistextum-2.6.9.ebuild
index 522c22c3d379..c31eca77ee33 100644
--- a/app-text/vilistextum/vilistextum-2.6.9.ebuild
+++ b/app-text/vilistextum/vilistextum-2.6.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/vilistextum-2.6.9.ebuild,v 1.12 2011/02/12 18:49:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/vilistextum-2.6.9.ebuild,v 1.13 2011/08/08 20:20:51 grobian Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI="http://bhaak.dyndns.org/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
#IUSE="unicode kde"
IUSE="unicode"
@@ -24,7 +24,8 @@ RDEPEND=""
src_prepare() {
epatch \
"${FILESDIR}/${P}-gentoo.diff" \
- "${FILESDIR}/${P}-prefix.patch"
+ "${FILESDIR}/${P}-prefix.patch" \
+ "${FILESDIR}/${P}-darwin11.patch"
eautoreconf
}