summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-12 08:20:55 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-12 08:20:55 +0000
commitb04599f5479ad844c6bab0c495f0ecbb77b4766f (patch)
tree5120ff456b7568e179034f7676c276d6aea4d2a3
parentFixed digests, #345151 (diff)
downloadgentoo-2-b04599f5479ad844c6bab0c495f0ecbb77b4766f.tar.gz
gentoo-2-b04599f5479ad844c6bab0c495f0ecbb77b4766f.tar.bz2
gentoo-2-b04599f5479ad844c6bab0c495f0ecbb77b4766f.zip
Removed old
(Portage version: 2.1.9.24/cvs/Linux x86_64)
-rw-r--r--dev-cpp/muParser/ChangeLog6
-rw-r--r--dev-cpp/muParser/muParser-1.28.ebuild49
-rw-r--r--dev-cpp/muParser/muParser-1.30.ebuild50
-rw-r--r--dev-cpp/muParser/muParser-1.32.ebuild51
4 files changed, 5 insertions, 151 deletions
diff --git a/dev-cpp/muParser/ChangeLog b/dev-cpp/muParser/ChangeLog
index a0c39bb0a816..4df43e3a808c 100644
--- a/dev-cpp/muParser/ChangeLog
+++ b/dev-cpp/muParser/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/muParser
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.16 2010/11/11 17:00:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.17 2010/11/12 08:20:55 jlec Exp $
+
+ 12 Nov 2010; Justin Lecher <jlec@gentoo.org> -muParser-1.28.ebuild,
+ -muParser-1.30.ebuild, -muParser-1.32.ebuild:
+ Removed old
*muParser-1.34 (11 Nov 2010)
diff --git a/dev-cpp/muParser/muParser-1.28.ebuild b/dev-cpp/muParser/muParser-1.28.ebuild
deleted file mode 100644
index bd8a35580117..000000000000
--- a/dev-cpp/muParser/muParser-1.28.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/muParser-1.28.ebuild,v 1.4 2008/05/17 09:59:22 bicatali Exp $
-
-inherit eutils
-
-DESCRIPTION="Library for parsing mathematical expressions"
-HOMEPAGE="http://muparser.sourceforge.net/"
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc"
-MY_PN="${PN/P/p}"
-MY_PV="v${PV/./}"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}_${MY_PV}.tar.gz"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}/${MY_PN}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # fix destdir to install pkgconfig file
- epatch "${FILESDIR}"/${P}-destdir.patch
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_compile() {
- econf --disable-samples || die "econf failed"
- emake -j1 CXXFLAGS="${CXXFLAGS}"|| die "emake failed"
-}
-
-src_test() {
- econf --enable-samples || die "econf failed"
- emake || die "emake failed"
- echo "LD_LIBRARY_PATH=${PWD}/lib samples/example1/example1 << EOF" > test.sh
- echo "quit" >> test.sh
- echo "EOF" >> test.sh
- sh ./test.sh || die "test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc Changes.txt Credits.txt || die "dodoc failed"
- use doc && dohtml -r docs/html/*
-}
diff --git a/dev-cpp/muParser/muParser-1.30.ebuild b/dev-cpp/muParser/muParser-1.30.ebuild
deleted file mode 100644
index f5ba68369ebd..000000000000
--- a/dev-cpp/muParser/muParser-1.30.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/muParser-1.30.ebuild,v 1.4 2010/01/01 17:17:32 fauli Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Library for parsing mathematical expressions"
-HOMEPAGE="http://muparser.sourceforge.net/"
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-MY_PN="${PN/P/p}"
-MY_PV="v${PV/./}"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}_${MY_PV}.tar.gz"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}"
-
-src_prepare() {
- # fix destdir and respect cxxflags
- # cant really use autotools cause muparser use bakefile
- # and too lasy to make an ebuild for it.
- epatch "${FILESDIR}"/${P}-build.patch
-}
-
-src_configure() {
- econf --disable-samples
-}
-
-src_test() {
- econf --enable-samples
- emake || die "emake failed"
- echo "LD_LIBRARY_PATH=${PWD}/lib samples/example1/example1 << EOF" > test.sh
- echo "quit" >> test.sh
- echo "EOF" >> test.sh
- sh ./test.sh || die "test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc Changes.txt Credits.txt || die "dodoc failed"
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r docs/html || die
- fi
-}
diff --git a/dev-cpp/muParser/muParser-1.32.ebuild b/dev-cpp/muParser/muParser-1.32.ebuild
deleted file mode 100644
index bdf176ddec58..000000000000
--- a/dev-cpp/muParser/muParser-1.32.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/muParser-1.32.ebuild,v 1.1 2010/02/14 20:45:26 pva Exp $
-
-EAPI=2
-inherit eutils
-
-MY_PN=${PN/P/p}
-MY_P=${MY_PN}_v${PV/./}
-DESCRIPTION="Library for parsing mathematical expressions"
-HOMEPAGE="http://muparser.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # fix destdir and respect cxxflags
- # cant really use autotools cause muparser use bakefile
- # and too lasy to make an ebuild for it.
- epatch "${FILESDIR}"/${P}-build.patch
-}
-
-src_configure() {
- econf $(use_enable test samples)
-}
-
-src_test() {
- cat > test.sh <<-EOFTEST
- LD_LIBRARY_PATH=${S}/lib samples/example1/example1 << EOF
- quit
- EOF
- EOFTEST
- sh ./test.sh || die "test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc Changes.txt Credits.txt || die "dodoc failed"
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r docs/html || die
- fi
-}