summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2008-03-22 20:34:58 +0000
committerChristian Heim <phreak@gentoo.org>2008-03-22 20:34:58 +0000
commitafb1c47873e7bea37c13a12e12eb6192f514049b (patch)
tree1a3fb3e83f26782e2863138a5904084244c19564
parentia64/sparc stable wrt #214051 (diff)
downloadgentoo-2-afb1c47873e7bea37c13a12e12eb6192f514049b.tar.gz
gentoo-2-afb1c47873e7bea37c13a12e12eb6192f514049b.tar.bz2
gentoo-2-afb1c47873e7bea37c13a12e12eb6192f514049b.zip
Revision bump, thanks to Kerin Miller.
(Portage version: 2.1.4.4)
-rw-r--r--sys-kernel/hardened-sources/ChangeLog13
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.23-r9.ebuild35
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index db6e5a6137d8..dde9d7bbd715 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.210 2008/02/27 16:04:18 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.211 2008/03/22 20:34:58 phreak Exp $
+
+*hardened-sources-2.6.23-r9 (22 Mar 2008)
+
+ 22 Mar 2008; Christian Heim <phreak@gentoo.org>
+ +hardened-sources-2.6.23-r9.ebuild:
+ * Revision bump, rebasing the patchset against genpatches-2.6.23-10.
+ * Change the default GIDs for some grsecurity options
+ * Revamp the Hardened [Gentoo] security level and make it the default level
+ * Fixing compilation on ia64 with CONFIG_MODULES=y (loadable module support)
+ * Fix a recursive lock -- call to capable() within ptrace_attach()
+ * Fix bug that allows audit and iscsi operations to be controlled via netlink
*hardened-sources-2.6.23-r8 (27 Feb 2008)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.23-r9.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.23-r9.ebuild
new file mode 100644
index 000000000000..51848d0cdfeb
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.23-r9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.23-r9.ebuild,v 1.1 2008/03/22 20:34:58 phreak Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV=${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-7
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.4-2.6.23-rc7.patch 4205_uvesafb-0.1-rc3-2.6.23-rc3.patch 4405_alpha-sysctl-uac.patch"
+DESCRIPTION="Hardened kernel sources ${OKV}"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "The options selected by the \"Hardened [Gentoo]\" security level"
+ ewarn "(GRKERNSEC_HARDENED) have been revised for this release. If you intend"
+ ewarn "to import a previous kernel configuration which uses this level then"
+ ewarn "please remember to review these changes before you build the kernel. In"
+ ewarn "particular, x86 users should note that PAX_MEMORY_UDEREF is now enabled"
+ ewarn "which is known not to work well in some virtualised environments. If this"
+ ewarn "affects you then you should switch to the \"Custom\" security level and"
+ ewarn "disable the option."
+ ewarn
+}
+