summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-12-16 01:33:01 +0000
committerRick Farina <zerochaos@gentoo.org>2012-12-16 01:33:01 +0000
commitaf2234e7865a68f86ccec5fb884667ebea5e9431 (patch)
tree5091432ca8b7f4ff8ba6e7977b67a35544423ed4
parent2.2.0_alpha149 version bump. This includes all of the fixes in 2.1.11.38. (diff)
downloadgentoo-2-af2234e7865a68f86ccec5fb884667ebea5e9431.tar.gz
gentoo-2-af2234e7865a68f86ccec5fb884667ebea5e9431.tar.bz2
gentoo-2-af2234e7865a68f86ccec5fb884667ebea5e9431.zip
it suits me to have a live version of this ebuild for testing, hope others like it too
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
-rw-r--r--net-analyzer/ettercap/ChangeLog8
-rw-r--r--net-analyzer/ettercap/ettercap-9999.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/net-analyzer/ettercap/ChangeLog b/net-analyzer/ettercap/ChangeLog
index 7b4c13612882..e401a5f2ac74 100644
--- a/net-analyzer/ettercap/ChangeLog
+++ b/net-analyzer/ettercap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ettercap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.109 2012/11/03 12:58:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.110 2012/12/16 01:33:01 zerochaos Exp $
+
+*ettercap-9999 (16 Dec 2012)
+
+ 16 Dec 2012; Rick Farina <zerochaos@gentoo.org> +ettercap-9999.ebuild:
+ it suits me to have a live version of this ebuild for testing, hope others
+ like it too
*ettercap-0.7.5_p20121103 (03 Nov 2012)
diff --git a/net-analyzer/ettercap/ettercap-9999.ebuild b/net-analyzer/ettercap/ettercap-9999.ebuild
new file mode 100644
index 000000000000..60c9787e6629
--- /dev/null
+++ b/net-analyzer/ettercap/ettercap-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-9999.ebuild,v 1.1 2012/12/16 01:33:01 zerochaos Exp $
+
+EAPI=4
+
+CMAKE_MIN_VERSION=2.8
+
+inherit cmake-utils git-2
+
+DESCRIPTION="A suite for man in the middle attacks"
+HOMEPAGE="http://ettercap.sourceforge.net https://github.com/Ettercap/ettercap"
+EGIT_REPO_URI="https://github.com/Ettercap/ettercap.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="gtk ipv6 ncurses +plugins ssl"
+
+RDEPEND="dev-libs/libpcre
+ net-libs/libnet:1.1
+ >=net-libs/libpcap-0.8.1
+ sys-libs/zlib
+ gtk? (
+ >=dev-libs/atk-1.2.4
+ >=dev-libs/glib-2.2.2:2
+ media-libs/freetype
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.2.2:2
+ >=x11-libs/pango-1.2.3
+ )
+ ncurses? ( >=sys-libs/ncurses-5.3 )
+ plugins? (
+ >=net-misc/curl-7.26.0
+ sys-devel/libtool
+ )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ app-text/ghostscript-gpl
+ sys-devel/flex
+ virtual/yacc"
+
+src_prepare() {
+ #ettercap defaults to using mozilla so let's try to use xdg-open and pray it works
+ sed -i 's#mozilla -remote openurl(http://%host%url)#xdg-open 'http://%host%url'#' \
+ share/etter.conf || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable ncurses CURSES)
+ $(cmake-utils_use_enable gtk)
+ $(cmake-utils_use_enable ssl)
+ $(cmake-utils_use_enable plugins)
+ $(cmake-utils_use_enable ipv6)
+ )
+ cmake-utils_src_configure
+}