summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-16 19:19:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-16 19:19:19 +0000
commitaf0100e40c168e87aa0d839a2634119d1b44f468 (patch)
tree8d0f1eaae88f1adf5665e8a822e7b20939097dcb
parentVersion bump (diff)
downloadgentoo-2-af0100e40c168e87aa0d839a2634119d1b44f468.tar.gz
gentoo-2-af0100e40c168e87aa0d839a2634119d1b44f468.tar.bz2
gentoo-2-af0100e40c168e87aa0d839a2634119d1b44f468.zip
Improve src_test().
(Portage version: 14611-svn/cvs/Linux x86_64)
-rw-r--r--dev-python/wtforms/wtforms-0.4.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/dev-python/wtforms/wtforms-0.4.ebuild b/dev-python/wtforms/wtforms-0.4.ebuild
index 0b679b2a0b1d..b7c2d7302499 100644
--- a/dev-python/wtforms/wtforms-0.4.ebuild
+++ b/dev-python/wtforms/wtforms-0.4.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-0.4.ebuild,v 1.1 2009/10/16 10:02:48 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-0.4.ebuild,v 1.2 2009/10/16 19:19:19 arfrever Exp $
+EAPI="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -12,8 +13,8 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Flexible forms validation and rendering library for python web development"
HOMEPAGE="http://wtforms.simplecodes.com/"
SRC_URI="http://pypi.python.org/packages/source/W/${MY_PN}/${MY_P}.zip"
-LICENSE="BSD"
+LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
@@ -29,20 +30,23 @@ DOCS="AUTHORS.txt CHANGES.txt INSTALL.txt LICENSE.txt README.txt"
src_compile() {
distutils_src_compile
if use doc; then
- cd "${S}/docs"
+ cd docs
PYTHONPATH=.. emake html || die "Building of documentation failed"
fi
}
+src_test() {
+ testing() {
+ pushd tests > /dev/null
+ "$(PYTHON)" runtests.py || return 1
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install
if use doc; then
dohtml -r docs/_build/html/* || die "Installation of documentation failed"
fi
}
-
-src_test() {
- distutils_python_version
- cd tests
- "${python}" runtests.py || die "Tests failed."
-}