summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2014-09-30 05:49:59 +0000
committerBen de Groot <yngwin@gentoo.org>2014-09-30 05:49:59 +0000
commitaef614277c3f717b13d399125323d6776065d460 (patch)
treed0c8f94e76c702eb60df223d51fe14be6aee4b49
parentCleanup (diff)
downloadgentoo-2-aef614277c3f717b13d399125323d6776065d460.tar.gz
gentoo-2-aef614277c3f717b13d399125323d6776065d460.tar.bz2
gentoo-2-aef614277c3f717b13d399125323d6776065d460.zip
Add python3 support (bug #505642), update dependency requirements. Add ebuild for 7.1.0 (bug #512242), but this still needs some dependencies to be version-bumped.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x0F9C590B7FF324F6!)
-rw-r--r--www-apps/nikola/ChangeLog11
-rw-r--r--www-apps/nikola/nikola-6.4.0-r1.ebuild (renamed from www-apps/nikola/nikola-6.4.0.ebuild)10
-rw-r--r--www-apps/nikola/nikola-7.1.0.ebuild63
3 files changed, 78 insertions, 6 deletions
diff --git a/www-apps/nikola/ChangeLog b/www-apps/nikola/ChangeLog
index bb69360d4333..9630042b2234 100644
--- a/www-apps/nikola/ChangeLog
+++ b/www-apps/nikola/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-apps/nikola
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/ChangeLog,v 1.19 2014/09/29 16:17:14 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/ChangeLog,v 1.20 2014/09/30 05:49:59 yngwin Exp $
+
+*nikola-6.4.0-r1 (30 Sep 2014)
+*nikola-7.1.0 (30 Sep 2014)
+
+ 30 Sep 2014; Ben de Groot <yngwin@gentoo.org> +nikola-6.4.0-r1.ebuild,
+ +nikola-7.1.0.ebuild, -nikola-6.4.0.ebuild:
+ Add python3 support (bug #505642), update dependency requirements. Add ebuild
+ for 7.1.0 (bug #512242), but this still needs some dependencies to be version-
+ bumped.
29 Sep 2014; Tobias Klausmann <klausman@gentoo.org> nikola-6.4.0.ebuild:
Loosen overly-specific configparser dep. dev-python/configparser-3.2.0.3
diff --git a/www-apps/nikola/nikola-6.4.0.ebuild b/www-apps/nikola/nikola-6.4.0-r1.ebuild
index 71e9b5a1d14d..bf92b91360af 100644
--- a/www-apps/nikola/nikola-6.4.0.ebuild
+++ b/www-apps/nikola/nikola-6.4.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-6.4.0.ebuild,v 1.2 2014/09/29 16:17:14 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-6.4.0-r1.ebuild,v 1.1 2014/09/30 05:49:59 yngwin Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 ) # 3_3 needs PyRSS2Gen update
+PYTHON_COMPAT=( python{2_7,3_3} )
inherit distutils-r1
DESCRIPTION="A static website and blog generator"
@@ -26,7 +26,7 @@ RESTRICT="test" # needs freezegun, coveralls, and phpserialize
DEPEND="dev-python/docutils[${PYTHON_USEDEP}]" # needs rst2man to build manpage
RDEPEND="${DEPEND}
- python_targets_python2_7? ( dev-python/configparser[${PYTHON_USEDEP}] )
+ python_targets_python2_7? ( dev-python/configparser[python_targets_python2_7] )
dev-python/blinker[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/doit-0.23.0[${PYTHON_USEDEP}]
@@ -34,14 +34,14 @@ RDEPEND="${DEPEND}
dev-python/lxml[${PYTHON_USEDEP}]
>=dev-python/mako-0.6[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyRSS2Gen[${PYTHON_USEDEP}]
+ >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/pytz-2013d[${PYTHON_USEDEP}]
>=dev-python/requests-1.0[${PYTHON_USEDEP}]
dev-python/unidecode[${PYTHON_USEDEP}]
>=dev-python/yapsy-1.10.2[${PYTHON_USEDEP}]
virtual/python-imaging[${PYTHON_USEDEP}]
- assets? ( dev-python/assets[${PYTHON_USEDEP}] )
+ assets? ( dev-python/webassets[${PYTHON_USEDEP}] )
charts? ( dev-python/pygal[${PYTHON_USEDEP}] )
hyphenation? ( dev-python/pyphen[${PYTHON_USEDEP}] )
ipython? ( >=dev-python/ipython-1.0.0[${PYTHON_USEDEP}] )
diff --git a/www-apps/nikola/nikola-7.1.0.ebuild b/www-apps/nikola/nikola-7.1.0.ebuild
new file mode 100644
index 000000000000..d8df2824e8a9
--- /dev/null
+++ b/www-apps/nikola/nikola-7.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-7.1.0.ebuild,v 1.1 2014/09/30 05:49:59 yngwin Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+inherit distutils-r1
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="http://getnikola.com/"
+MY_PN="Nikola"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ralsina/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT-with-advertising Apache-2.0" # Gutenberg
+SLOT="0"
+IUSE="assets charts hyphenation ipython jinja markdown"
+RESTRICT="test" # needs freezegun, coveralls, and phpserialize
+
+DEPEND=">=dev-python/docutils-0.12[${PYTHON_USEDEP}]" # needs rst2man to build manpage
+RDEPEND="${DEPEND}
+ python_targets_python2_7? ( dev-python/configparser[python_targets_python2_7] )
+ >=dev-python/blinker-1.3[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/doit-0.23.0[${PYTHON_USEDEP}]
+ >=dev-python/logbook-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.0[${PYTHON_USEDEP}]
+ >=dev-python/natsort-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
+ >=dev-python/yapsy-1.10.423[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ assets? ( >=dev-python/webassets-0.10.1[${PYTHON_USEDEP}] )
+ charts? ( >=dev-python/pygal-1.4.6[${PYTHON_USEDEP}] )
+ hyphenation? ( >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}] )
+ ipython? ( >=dev-python/ipython-1.2.1[${PYTHON_USEDEP}] )
+ jinja? ( >=dev-python/jinja-2.7.2[${PYTHON_USEDEP}] )
+ markdown? ( >=dev-python/markdown-2.4.0[${PYTHON_USEDEP}] )"
+# more options as packages will be added:
+# livereload? ( =dev-python/livereload-2.2.1[${PYTHON_USEDEP}] )
+# micawber? ( >=dev-python/micawber-0.3.0[${PYTHON_USEDEP}] )
+# typogrify? ( >=dev-python/typogrify-2.0.4[${PYTHON_USEDEP}] )
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.txt
+ doman docs/man/*
+}