summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-24 06:05:54 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-24 06:05:54 +0000
commitae898fdf22e719ecbcd904b78358c267cff89479 (patch)
tree56f7ae1b1370843a01ee6324f2ee7fcf07d88d6f
parentVersion bump. Add ruby21. Drop sparc due to missing keyword on dependencies, ... (diff)
downloadgentoo-2-ae898fdf22e719ecbcd904b78358c267cff89479.tar.gz
gentoo-2-ae898fdf22e719ecbcd904b78358c267cff89479.tar.bz2
gentoo-2-ae898fdf22e719ecbcd904b78358c267cff89479.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/treetop/ChangeLog7
-rw-r--r--dev-ruby/treetop/treetop-1.5.3.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/treetop/ChangeLog b/dev-ruby/treetop/ChangeLog
index c7a85e0e065a..055d0c28e0d7 100644
--- a/dev-ruby/treetop/ChangeLog
+++ b/dev-ruby/treetop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/treetop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.46 2014/04/20 18:21:30 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.47 2014/05/24 06:05:54 graaff Exp $
+
+*treetop-1.5.3 (24 May 2014)
+
+ 24 May 2014; Hans de Graaff <graaff@gentoo.org> +treetop-1.5.3.ebuild:
+ Version bump.
*treetop-1.4.15-r1 (20 Apr 2014)
diff --git a/dev-ruby/treetop/treetop-1.5.3.ebuild b/dev-ruby/treetop/treetop-1.5.3.ebuild
new file mode 100644
index 000000000000..affe59ef61fb
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.5.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/treetop-1.5.3.ebuild,v 1.1 2014/05/24 06:05:54 graaff Exp $
+
+EAPI=5
+
+# jruby fails tests, not investigated yet.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages."
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.0 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1"
+
+all_ruby_prepare() {
+ # Use a ruby18 compatible regexp, already fixed upstream.
+ sed -i -e 's/\[:\^space:\]/\^[:space:]/' spec/compiler/character_class_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}