summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2010-03-26 21:10:38 +0000
committerOlivier Crête <tester@gentoo.org>2010-03-26 21:10:38 +0000
commitae78523c1eb0e06126d74419f890ef051fcab8ea (patch)
treef102c58317db25f27f7fa2b396550dfd50326b2f
parentVersion bump. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-ae78523c1eb0e06126d74419f890ef051fcab8ea.tar.gz
gentoo-2-ae78523c1eb0e06126d74419f890ef051fcab8ea.tar.bz2
gentoo-2-ae78523c1eb0e06126d74419f890ef051fcab8ea.zip
Version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
-rw-r--r--net-libs/telepathy-glib/ChangeLog8
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.10.1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index aeff2f8b2eca..8abdd8785b90 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.41 2010/01/18 00:48:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.42 2010/03/26 21:10:38 tester Exp $
+
+*telepathy-glib-0.10.1 (26 Mar 2010)
+
+ 26 Mar 2010; Olivier Crête <tester@gentoo.org>
+ +telepathy-glib-0.10.1.ebuild:
+ Version bump
18 Jan 2010; Jeroen Roovers <jer@gentoo.org> telepathy-glib-0.8.1.ebuild:
Marked ~hppa too.
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.10.1.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.10.1.ebuild
new file mode 100644
index 000000000000..7979f3c3d46a
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.10.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.10.1.ebuild,v 1.1 2010/03/26 21:10:38 tester Exp $
+
+EAPI="2"
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=dev-libs/dbus-glib-0.73
+ >=dev-lang/python-2.3"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug)
+}
+
+src_test() {
+ if ! dbus-launch emake -j1 check; then
+ die "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}