summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-22 17:10:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-22 17:10:29 +0000
commitae6726170c166b4e72252b0b80b6d3be745b3d22 (patch)
tree5b98a2ee9b51f39902af72168f3814b0dd3c78ec
parentDrop realms patch (failed to apply this time as well), add backports with fix... (diff)
downloadgentoo-2-ae6726170c166b4e72252b0b80b6d3be745b3d22.tar.gz
gentoo-2-ae6726170c166b4e72252b0b80b6d3be745b3d22.tar.bz2
gentoo-2-ae6726170c166b4e72252b0b80b6d3be745b3d22.zip
Added double precision flag
(Portage version: 2.1.9.43/cvs/Linux x86_64)
-rw-r--r--sci-physics/bullet/ChangeLog6
-rw-r--r--sci-physics/bullet/bullet-2.76-r1.ebuild51
-rw-r--r--sci-physics/bullet/bullet-2.77.ebuild6
-rw-r--r--sci-physics/bullet/metadata.xml1
4 files changed, 10 insertions, 54 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
index cac43a63a292..558784bb8e4b 100644
--- a/sci-physics/bullet/ChangeLog
+++ b/sci-physics/bullet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/bullet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.21 2011/02/25 19:12:31 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.22 2011/03/22 17:10:29 bicatali Exp $
+
+ 22 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> -bullet-2.76-r1.ebuild,
+ bullet-2.77.ebuild, metadata.xml:
+ Added double precision flag
25 Feb 2011; Fabian Groffen <grobian@gentoo.org> bullet-2.77.ebuild:
Marked ~amd64-linux, bug #356099
diff --git a/sci-physics/bullet/bullet-2.76-r1.ebuild b/sci-physics/bullet/bullet-2.76-r1.ebuild
deleted file mode 100644
index 2c240d65be6b..000000000000
--- a/sci-physics/bullet/bullet-2.76-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.76-r1.ebuild,v 1.4 2010/09/16 17:31:03 scarabeus Exp $
-
-EAPI=2
-inherit eutils cmake-utils
-
-DESCRIPTION="Continuous Collision Detection and Physics Library"
-HOMEPAGE="http://www.bulletphysics.com/"
-SRC_URI="http://bullet.googlecode.com/files/${P}.tgz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-RDEPEND="media-libs/freeglut"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- mycmakeargs="
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_DEMOS=OFF
- -DBUILD_EXTRAS=OFF
- -DINSTALL_LIBS=ON
- -DINSTALL_EXTRA_LIBS=ON"
- # -DCMAKE_INSTALL_PREFIX=/usr"
-
- cmake-utils_src_configure
- sed -e "s|@prefix@|${ROOT}usr|" \
- -e 's|@exec_prefix@|${prefix}|' \
- -e "s|@libdir@|\${exec_prefix}/$(get_libdir)|" \
- -e "s|@PACKAGE_VERSION@|${PV}|" \
- -e "s|@includedir@|\${prefix}/include|" \
- bullet.pc.in > bullet.pc || die
-}
-
-src_install() {
- cmake-utils_src_install
- insinto /usr/$(get_libdir)/pkgconfig
- doins bullet.pc || die
- dodoc README ChangeLog AUTHORS
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins *.pdf || die
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r Extras Demos || die
- fi
-}
diff --git a/sci-physics/bullet/bullet-2.77.ebuild b/sci-physics/bullet/bullet-2.77.ebuild
index 5d46480becad..0a5b1a550773 100644
--- a/sci-physics/bullet/bullet-2.77.ebuild
+++ b/sci-physics/bullet/bullet-2.77.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.77.ebuild,v 1.4 2011/02/25 19:12:31 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.77.ebuild,v 1.5 2011/03/22 17:10:29 bicatali Exp $
EAPI=2
inherit eutils cmake-utils
@@ -12,7 +12,7 @@ SRC_URI="http://bullet.googlecode.com/files/${P}.tgz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux"
-IUSE="doc examples extras"
+IUSE="doc double-precision examples extras"
RDEPEND="virtual/opengl
media-libs/freeglut"
@@ -22,10 +22,12 @@ PATCHES=( "${FILESDIR}/${P}"-{libdir,soversion}.patch )
src_configure() {
mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
+ -DBUILD_CPU_DEMOS=OFF
-DBUILD_DEMOS=OFF
-DINSTALL_LIBS=ON
-DINSTALL_EXTRA_LIBS=ON
$(cmake-utils_use_build extras EXTRAS)
+ $(cmake-utils_use_use double-precision DOUBLE_PRECISION)
)
cmake-utils_src_configure
}
diff --git a/sci-physics/bullet/metadata.xml b/sci-physics/bullet/metadata.xml
index dd4eb83e604f..99d16b07ba61 100644
--- a/sci-physics/bullet/metadata.xml
+++ b/sci-physics/bullet/metadata.xml
@@ -9,5 +9,6 @@
</longdescription>
<use>
<flag name='extras'>Build additional libraries</flag>
+ <flag name='double-precision'>Build libraries in double precision</flag>
</use>
</pkgmetadata>