summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-14 17:41:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-14 17:41:45 +0000
commitae3e7acb7d27bc718c310c61069bc55ce1e18371 (patch)
tree76b4df37a9595af22198bf981802d469d07c3240
parentDelete older ebuild. (diff)
downloadgentoo-2-ae3e7acb7d27bc718c310c61069bc55ce1e18371.tar.gz
gentoo-2-ae3e7acb7d27bc718c310c61069bc55ce1e18371.tar.bz2
gentoo-2-ae3e7acb7d27bc718c310c61069bc55ce1e18371.zip
Version bump.
(Portage version: 15827-svn/cvs/Linux x86_64)
-rw-r--r--net-zope/zope-publisher/ChangeLog8
-rw-r--r--net-zope/zope-publisher/zope-publisher-3.12.1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/net-zope/zope-publisher/ChangeLog b/net-zope/zope-publisher/ChangeLog
index ce6c146fe2d5..479305de2c8b 100644
--- a/net-zope/zope-publisher/ChangeLog
+++ b/net-zope/zope-publisher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope-publisher
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-publisher/ChangeLog,v 1.7 2010/02/14 19:17:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-publisher/ChangeLog,v 1.8 2010/03/14 17:41:45 arfrever Exp $
+
+*zope-publisher-3.12.1 (14 Mar 2010)
+
+ 14 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -zope-publisher-3.12.0.ebuild, +zope-publisher-3.12.1.ebuild:
+ Version bump.
14 Feb 2010; Raúl Porcel <armin76@gentoo.org>
zope-publisher-3.12.0.ebuild:
diff --git a/net-zope/zope-publisher/zope-publisher-3.12.1.ebuild b/net-zope/zope-publisher/zope-publisher-3.12.1.ebuild
new file mode 100644
index 000000000000..de5ddcf7cfae
--- /dev/null
+++ b/net-zope/zope-publisher/zope-publisher-3.12.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-publisher/zope-publisher-3.12.1.ebuild,v 1.1 2010/03/14 17:41:45 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Zope publisher publishes Python objects on the web."
+HOMEPAGE="http://pypi.python.org/pypi/zope.publisher"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools
+ net-zope/zope-browser
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-contenttype
+ net-zope/zope-event
+ net-zope/zope-exceptions
+ net-zope/zope-i18n
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-proxy
+ net-zope/zope-schema
+ net-zope/zope-security"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"