summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-16 19:59:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-16 19:59:01 +0000
commitad8673a0cb47c8e30da97dcf1f170a07f8210280 (patch)
tree81728b7e2b171dfda27b6925ec4ba3914cf64572
parentInitial import (diff)
downloadgentoo-2-ad8673a0cb47c8e30da97dcf1f170a07f8210280.tar.gz
gentoo-2-ad8673a0cb47c8e30da97dcf1f170a07f8210280.tar.bz2
gentoo-2-ad8673a0cb47c8e30da97dcf1f170a07f8210280.zip
Initial import
(Portage version: 2.1.10.63/cvs/Linux x86_64)
-rw-r--r--dev-perl/OpenGL/ChangeLog10
-rw-r--r--dev-perl/OpenGL/Manifest5
-rw-r--r--dev-perl/OpenGL/OpenGL-0.660.0.ebuild35
-rw-r--r--dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch50
-rw-r--r--dev-perl/OpenGL/metadata.xml16
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-perl/OpenGL/ChangeLog b/dev-perl/OpenGL/ChangeLog
new file mode 100644
index 000000000000..c2ba8dcc15a5
--- /dev/null
+++ b/dev-perl/OpenGL/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-perl/OpenGL
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/OpenGL/ChangeLog,v 1.1 2012/06/16 19:59:01 bicatali Exp $
+
+*OpenGL-0.660.0 (16 Jun 2012)
+
+ 16 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/OpenGL-0.66-no-display.patch, +OpenGL-0.660.0.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/dev-perl/OpenGL/Manifest b/dev-perl/OpenGL/Manifest
new file mode 100644
index 000000000000..dddfaf5df278
--- /dev/null
+++ b/dev-perl/OpenGL/Manifest
@@ -0,0 +1,5 @@
+AUX OpenGL-0.66-no-display.patch 1472 RMD160 e540f3c9f9c5faa1dea68d7b03f04d32c17d8ba5 SHA1 936ecba9b020e8653df9c49e518d9a032df73a56 SHA256 b7f62c20e44d885ba4abbe735adf8b42994f029db4221368f43568e9b97ccaaf
+DIST OpenGL-0.66.tar.gz 611606 RMD160 cf0d4d6b726e4e69b2f861b3a813c8e4ce5c34cf SHA1 e5245eeb00b3a96e2333a4de6c0f36898d8797c6 SHA256 8837bf244d41e415e9ef05bece8fb60861293389d96a4115f0a64929650627df
+EBUILD OpenGL-0.660.0.ebuild 652 RMD160 bf4504738137dd648f8684f4028e4d011a2c50fa SHA1 82aa8dbfd4ec2e634057164618fb2435b55c424d SHA256 4597db2d14fb331fd067efd95acebf6bee10e8cca7a978c9391c8dc5b6fa2c4e
+MISC ChangeLog 298 RMD160 762251e724b1275da90ab67ffba0352fed34fbe0 SHA1 6e6af4f1520d24fd3699878efa2d3465aef53853 SHA256 1470edcd8cdfd59543be71b6ccf31a71927aa04a314df8a02d2d3e63c94e0b5f
+MISC metadata.xml 684 RMD160 06c2e6c63192ac2ae9401eacfc83de847a0cc107 SHA1 65a9c2a713b467f82414eacc1d92393087e93f1c SHA256 76a656d28e5c55a3a4ed99407539e8efdd2b158983ab2295828f9bccdf5e8022
diff --git a/dev-perl/OpenGL/OpenGL-0.660.0.ebuild b/dev-perl/OpenGL/OpenGL-0.660.0.ebuild
new file mode 100644
index 000000000000..178b41414f21
--- /dev/null
+++ b/dev-perl/OpenGL/OpenGL-0.660.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/OpenGL/OpenGL-0.660.0.ebuild,v 1.1 2012/06/16 19:59:01 bicatali Exp $
+
+EAPI=4
+
+MODULE_AUTHOR="CHM"
+MODULE_VERSION=0.66
+
+inherit perl-module eutils
+
+DESCRIPTION="Perl interface providing graphics display using OpenGL"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/freeglut
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+mydoc="Release_Notes"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-display.patch
+}
+
+src_compile() {
+ sed -i -e 's/PERL_DL_NONLAZY=1//' Makefile || die
+ perl-module_src_compile
+}
diff --git a/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
new file mode 100644
index 000000000000..6bdc334ba0b1
--- /dev/null
+++ b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
@@ -0,0 +1,50 @@
+Don't check current display for extensions, build all.
+
+diff -up OpenGL-0.62/Makefile.PL.dist OpenGL-0.62/Makefile.PL
+--- OpenGL-0.62/Makefile.PL.dist 2009-12-11 01:10:00.000000000 +0100
++++ OpenGL-0.62/Makefile.PL 2010-01-07 13:00:26.000000000 +0100
+@@ -579,9 +579,9 @@ my $build_config =
+ {
+ FILES =>
+ "Config.pm ".
+- "utils/glversion.txt ".
+- "utils/glversion$Config{exe_ext} ".
+- "utils/glversion$Config{obj_ext}"
++ "utils/glversion.txt "
++ #"utils/glversion$Config{exe_ext} ".
++ #"utils/glversion$Config{obj_ext}"
+ }
+ };
+
+@@ -790,6 +790,7 @@ sub get_extensions
+ print "GLUT not found\n";
+ }
+
++=cut
+ # Platform-specific makefiles for glversion
+ my $make_ver;
+ if ($IS_MINGW)
+@@ -848,7 +849,9 @@ sub get_extensions
+ print "get_extensions: no extensions found in $glv_file\n" if $verbose;
+ return '';
+ }
+-
++=cut
++ use Config;
++ my $gldata = { };
+
+ # Parse glext_procs.h file
+ return '' if (!open(GLEXT,"glext_procs.h"));
+@@ -867,10 +870,12 @@ sub get_extensions
+
+ # Create gl_exclude.h
+ die "Unable to write to $exc_file\n" if (!open(GLEXC,">$exc_file"));
++=cut
+ print GLEXC "// OpenGL Extension Exclusions - may be modified before building.\n";
+ print GLEXC "//\n";
+ print GLEXC "// Generated for ".$gldata->{VENDOR}.", ".$gldata->{RENDERER}."\n";
+ print GLEXC "// OpenGL v".$gldata->{VERSION}.", using ";
++=cut
+
+ # Fix GLUT flags based on results
+ if ($gldata->{GLUT} > 0)
diff --git a/dev-perl/OpenGL/metadata.xml b/dev-perl/OpenGL/metadata.xml
new file mode 100644
index 000000000000..44f1713debed
--- /dev/null
+++ b/dev-perl/OpenGL/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<herd>perl</herd>
+<longdescription lang="en">
+ OpenGL is a Perl module that provides an interface to most of Open Graphics
+ Library, API versions 1.0, 1.1 and 1.2. There is full support for the Utility
+ Toolkit (GLUT) up to version 3 and provides some additional functionality via
+ partial support for the Utility Library (GLU). It also provides functionality
+ to use the X Window System (through X11 and GLX) as an alternative to GLUT.
+</longdescription>
+<upstream>
+ <remote-id type="cpan">OpenGL</remote-id>
+</upstream>
+</pkgmetadata>