summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-05-22 21:21:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-05-22 21:21:59 +0000
commitad1c9ab29adf4e80bac4b2355d2881bec7022e59 (patch)
tree2625b1bc13fdc91f96f9b133cf09d4025a27d3f0
parentpunt old ebuilds (diff)
downloadgentoo-2-ad1c9ab29adf4e80bac4b2355d2881bec7022e59.tar.gz
gentoo-2-ad1c9ab29adf4e80bac4b2355d2881bec7022e59.tar.bz2
gentoo-2-ad1c9ab29adf4e80bac4b2355d2881bec7022e59.zip
Clean up ebuild syntax.
(Portage version: 2.1.4.4)
-rw-r--r--sys-power/iasl/ChangeLog7
-rw-r--r--sys-power/iasl/iasl-20050309.ebuild8
-rw-r--r--sys-power/iasl/iasl-20050513.ebuild8
-rw-r--r--sys-power/iasl/iasl-20051216.ebuild6
-rw-r--r--sys-power/iasl/iasl-20060127.ebuild8
-rw-r--r--sys-power/iasl/iasl-20060512.ebuild8
-rw-r--r--sys-power/iasl/iasl-20060912.ebuild8
-rw-r--r--sys-power/iasl/iasl-20080514.ebuild4
8 files changed, 31 insertions, 26 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 9d8e1fe07ef1..0b9d6c53e489 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.15 2008/05/22 21:13:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.16 2008/05/22 21:21:59 robbat2 Exp $
+
+ 22 May 2008; Robin H. Johnson <robbat2@gentoo.org> iasl-20050309.ebuild,
+ iasl-20050513.ebuild, iasl-20051216.ebuild, iasl-20060127.ebuild,
+ iasl-20060512.ebuild, iasl-20060912.ebuild, iasl-20080514.ebuild:
+ Clean up ebuild syntax.
*iasl-20080514 (22 May 2008)
diff --git a/sys-power/iasl/iasl-20050309.ebuild b/sys-power/iasl/iasl-20050309.ebuild
index f2000bb00d37..002d42c41374 100644
--- a/sys-power/iasl/iasl-20050309.ebuild
+++ b/sys-power/iasl/iasl-20050309.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20050309.ebuild,v 1.2 2005/05/13 19:14:21 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20050309.ebuild,v 1.3 2008/05/22 21:21:59 robbat2 Exp $
MY_PN="acpica-unix"
MY_P="${MY_PN}-${PV}"
@@ -15,10 +15,10 @@ DEPEND="virtual/libc"
S="${WORKDIR}/${MY_P}"
src_compile() {
- cd ${S}/compiler && emake -j1 || die "make failed"
+ cd "${S}"/compiler && emake -j1 || die "make failed"
}
src_install() {
dobin compiler/iasl || die "iasl binary not created"
- dodoc ${S}/README || die "README not found"
+ dodoc "${S}"/README || die "README not found"
}
diff --git a/sys-power/iasl/iasl-20050513.ebuild b/sys-power/iasl/iasl-20050513.ebuild
index 418cec67f050..e6d101590075 100644
--- a/sys-power/iasl/iasl-20050513.ebuild
+++ b/sys-power/iasl/iasl-20050513.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20050513.ebuild,v 1.3 2005/11/24 15:49:01 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20050513.ebuild,v 1.4 2008/05/22 21:21:59 robbat2 Exp $
inherit toolchain-funcs
@@ -21,12 +21,12 @@ DEPEND="sys-devel/bison
RDEPEND=""
src_compile() {
- cd ${S}/compiler
+ cd "${S}"/compiler
emake -j1 CC=$(tc-getCC) || die "emake failed"
}
src_install() {
dobin compiler/iasl
- dodoc ${S}/README
+ dodoc "${S}"/README
}
diff --git a/sys-power/iasl/iasl-20051216.ebuild b/sys-power/iasl/iasl-20051216.ebuild
index fabcbf941350..1e005e162582 100644
--- a/sys-power/iasl/iasl-20051216.ebuild
+++ b/sys-power/iasl/iasl-20051216.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20051216.ebuild,v 1.1 2005/12/27 19:08:55 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20051216.ebuild,v 1.2 2008/05/22 21:21:59 robbat2 Exp $
inherit toolchain-funcs eutils
@@ -23,7 +23,7 @@ RDEPEND=""
src_unpack() {
unpack ${A}
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${MY_PN}-20051216-buildfixup.patch
+ EPATCH_OPTS="-p1 -d '${S}'" epatch "${FILESDIR}"/${MY_PN}-20051216-buildfixup.patch
}
src_compile() {
diff --git a/sys-power/iasl/iasl-20060127.ebuild b/sys-power/iasl/iasl-20060127.ebuild
index c833b101f7f7..c180fee536a7 100644
--- a/sys-power/iasl/iasl-20060127.ebuild
+++ b/sys-power/iasl/iasl-20060127.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060127.ebuild,v 1.1 2006/02/20 04:04:46 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060127.ebuild,v 1.2 2008/05/22 21:21:59 robbat2 Exp $
inherit toolchain-funcs eutils
@@ -23,14 +23,14 @@ RDEPEND=""
src_unpack() {
unpack ${A}
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${MY_PN}-20051216-buildfixup.patch
+ EPATCH_OPTS="-p1 -d '${S}'" epatch "${FILESDIR}"/${MY_PN}-20051216-buildfixup.patch
}
src_compile() {
# fix stupid flex 2.5.31 bug
emake -C compiler aslcompilerlex.c || die "emake aslcompilerlex.c failed"
sed -i.orig -e '/#define unput/s,yytext_ptr,AslCompilertext,' \
- ${S}/compiler/aslcompilerlex.c || die "sed failed"
+ "${S}"/compiler/aslcompilerlex.c || die "sed failed"
emake CC=$(tc-getCC) || die "emake failed"
}
diff --git a/sys-power/iasl/iasl-20060512.ebuild b/sys-power/iasl/iasl-20060512.ebuild
index 4ab01da5fdeb..d19ac41afc49 100644
--- a/sys-power/iasl/iasl-20060512.ebuild
+++ b/sys-power/iasl/iasl-20060512.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060512.ebuild,v 1.1 2006/05/29 23:46:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060512.ebuild,v 1.2 2008/05/22 21:21:59 robbat2 Exp $
inherit toolchain-funcs eutils
@@ -23,14 +23,14 @@ RDEPEND=""
src_unpack() {
unpack ${A}
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${MY_PN}-20060512-buildfixup.patch
+ EPATCH_OPTS="-p1 -d '${S}'" epatch "${FILESDIR}"/${MY_PN}-20060512-buildfixup.patch
}
src_compile() {
# fix stupid flex 2.5.31 bug
emake -C compiler aslcompilerlex.c || die "emake aslcompilerlex.c failed"
sed -i.orig -e '/#define unput/s,yytext_ptr,AslCompilertext,' \
- ${S}/compiler/aslcompilerlex.c || die "sed failed"
+ "${S}"/compiler/aslcompilerlex.c || die "sed failed"
emake CC="$(tc-getCC)" || die "emake failed"
}
diff --git a/sys-power/iasl/iasl-20060912.ebuild b/sys-power/iasl/iasl-20060912.ebuild
index 7aba6a096980..e6071113a09a 100644
--- a/sys-power/iasl/iasl-20060912.ebuild
+++ b/sys-power/iasl/iasl-20060912.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060912.ebuild,v 1.5 2007/05/21 10:10:56 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060912.ebuild,v 1.6 2008/05/22 21:21:59 robbat2 Exp $
inherit toolchain-funcs eutils
@@ -23,14 +23,14 @@ RDEPEND=""
src_unpack() {
unpack ${A}
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${MY_PN}-20060512-buildfixup.patch
+ EPATCH_OPTS="-p1 -d '${S}'" epatch "${FILESDIR}"/${MY_PN}-20060512-buildfixup.patch
}
src_compile() {
# fix stupid flex 2.5.31 bug
emake -C compiler aslcompilerlex.c || die "emake aslcompilerlex.c failed"
sed -i.orig -e '/#define unput/s,yytext_ptr,AslCompilertext,' \
- ${S}/compiler/aslcompilerlex.c || die "sed failed"
+ "${S}"/compiler/aslcompilerlex.c || die "sed failed"
emake CC="$(tc-getCC)" || die "emake failed"
}
diff --git a/sys-power/iasl/iasl-20080514.ebuild b/sys-power/iasl/iasl-20080514.ebuild
index de39366aee0b..5e94ab51bc8c 100644
--- a/sys-power/iasl/iasl-20080514.ebuild
+++ b/sys-power/iasl/iasl-20080514.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.1 2008/05/22 21:13:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.2 2008/05/22 21:21:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -105,7 +105,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
- cd "${S}/tools/aapits" || die "cd ${S}/tools/aapits failed"
+ cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"