summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-05-04 19:51:49 +0000
committerSamuli Suominen <drac@gentoo.org>2007-05-04 19:51:49 +0000
commitabb280ca6387329ba2fe91f3ee98b4aca94dc473 (patch)
tree2b498bb5b463ef5dd7c9f1fc1a2a87998e903284
parentUpdated because of jaxp changes (diff)
downloadgentoo-2-abb280ca6387329ba2fe91f3ee98b4aca94dc473.tar.gz
gentoo-2-abb280ca6387329ba2fe91f3ee98b4aca94dc473.tar.bz2
gentoo-2-abb280ca6387329ba2fe91f3ee98b4aca94dc473.zip
Fix CDDA build with fbsd.
(Portage version: 2.1.2.5)
-rw-r--r--media-libs/xine-lib/ChangeLog8
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.1.6-fbsd.patch33
-rw-r--r--media-libs/xine-lib/xine-lib-1.1.6.ebuild4
3 files changed, 43 insertions, 2 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index b00ca9de2b72..2ab4e76aa57c 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.470 2007/04/22 13:30:39 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.471 2007/05/04 19:51:49 drac Exp $
+
+ 04 May 2007; Samuli Suominen <drac@gentoo.org>
+ +files/xine-lib-1.1.6-fbsd.patch, xine-lib-1.1.6.ebuild:
+ Apply patch from Diego Flameeyes Pettenò to Fix build of CDDA input on
+ FreeBSD, the NetBSD patch broke it as sys/scsiio.h is not present on
+ FreeBSD.
22 Apr 2007; Tobias Scherbaum <dertobi123@gentoo.org>
xine-lib-1.1.4-r2.ebuild:
diff --git a/media-libs/xine-lib/files/xine-lib-1.1.6-fbsd.patch b/media-libs/xine-lib/files/xine-lib-1.1.6-fbsd.patch
new file mode 100644
index 000000000000..6f508c061366
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.1.6-fbsd.patch
@@ -0,0 +1,33 @@
+# HG changeset patch
+# User Diego 'Flameeyes' Pettenò <flameeyes@gmail.com>
+# Date 1178289959 -7200
+# Node ID ee3cb7841d1490bb5dfb760df2f49642da9f6837
+# Parent ce82ad163b0e36d3edefd90bfe3f2ba05ab3ace3
+Fix building of CDDA input on FreeBSD, the NetBSD patch broke it as sys/scsiio.h is not present on FreeBSD.
+
+diff -r ce82ad163b0e -r ee3cb7841d14 configure.ac
+--- a/configure.ac Wed May 02 21:51:16 2007 +0200
++++ b/configure.ac Fri May 04 16:45:59 2007 +0200
+@@ -1656,7 +1656,7 @@ dnl ------------------------------------
+ dnl ---------------------------------------------
+
+ AC_CHECK_HEADERS([linux/cdrom.h sys/dvdio.h], [break])
+-AC_CHECK_HEADERS([sys/cdio.h])
++AC_CHECK_HEADERS([sys/cdio.h sys/scsiio.h])
+ AM_CHECK_CDROM_IOCTLS(
+ [AC_DEFINE(HAVE_CDROM_IOCTLS,1,[Define this if you have CDROM ioctls])],
+ [AC_MSG_RESULT([*** (S)VCD support will be disabled ***])])
+diff -r ce82ad163b0e -r ee3cb7841d14 src/input/input_cdda.c
+--- a/src/input/input_cdda.c Wed May 02 21:51:16 2007 +0200
++++ b/src/input/input_cdda.c Fri May 04 16:45:59 2007 +0200
+@@ -617,7 +617,10 @@ static int read_cdrom_frames(cdda_input_
+ #elif defined(__FreeBSD__) || defined(__NetBSD__)
+
+ #include <sys/cdio.h>
++
++#ifdef HAVE_SYS_SCSIIO_H
+ #include <sys/scsiio.h>
++#endif
+
+ static int read_cdrom_toc(int fd, cdrom_toc *toc) {
+
diff --git a/media-libs/xine-lib/xine-lib-1.1.6.ebuild b/media-libs/xine-lib/xine-lib-1.1.6.ebuild
index e558c2253653..521c3ce81c41 100644
--- a/media-libs/xine-lib/xine-lib-1.1.6.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.6.ebuild,v 1.3 2007/04/22 01:38:26 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.6.ebuild,v 1.4 2007/05/04 19:51:49 drac Exp $
inherit eutils flag-o-matic toolchain-funcs libtool autotools
@@ -93,6 +93,8 @@ src_unpack() {
# Workaround from Flameeyes until using external
# libdts is done properly (in xine-lib-1.1.7)
echo '#include_next <dts.h>' > src/libdts/dts.h
+
+ epatch "${FILESDIR}"/${P}-fbsd.patch
}
src_compile() {