summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-12-07 11:28:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-12-07 11:28:02 +0000
commitaa684db4cde390bc068d2272bfa0df5c544036a8 (patch)
tree7da57daa3f5f183a3983e65654e9935aac44c74a
parentAdd arm/s390/sh love #224541. (diff)
downloadgentoo-2-aa684db4cde390bc068d2272bfa0df5c544036a8.tar.gz
gentoo-2-aa684db4cde390bc068d2272bfa0df5c544036a8.tar.bz2
gentoo-2-aa684db4cde390bc068d2272bfa0df5c544036a8.zip
add patch from Christian Ruppert (idl0r) to support as-needed (bug #247472)
(Portage version: 2.1.4.5)
-rw-r--r--games-sports/foobillard/ChangeLog8
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-as-needed.patch10
-rw-r--r--games-sports/foobillard/foobillard-3.0a.ebuild7
3 files changed, 20 insertions, 5 deletions
diff --git a/games-sports/foobillard/ChangeLog b/games-sports/foobillard/ChangeLog
index 3c3486b41d14..c93a56a3a5df 100644
--- a/games-sports/foobillard/ChangeLog
+++ b/games-sports/foobillard/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/foobillard
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.14 2007/02/24 01:20:00 nyhm Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.15 2008/12/07 11:28:02 mr_bones_ Exp $
+
+ 07 Dec 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/foobillard-3.0a-as-needed.patch, foobillard-3.0a.ebuild:
+ add patch from Christian Ruppert (idl0r) to support as-needed (bug #247472)
24 Feb 2007; Tristan Heaven <nyhm@gentoo.org> foobillard-3.0a.ebuild:
Fix dependencies, bug #168179
diff --git a/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch b/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch
new file mode 100644
index 000000000000..1d9ddbd8b729
--- /dev/null
+++ b/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch
@@ -0,0 +1,10 @@
+--- foobillard-3.0a.old/src/Makefile.am 2004-02-25 07:23:56.000000000 +0100
++++ foobillard-3.0a/src/Makefile.am 2008-12-06 21:57:03.000000000 +0100
+@@ -83,6 +83,5 @@ AM_CFLAGS = -Wall `freetype-config --cfl
+
+ #LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
+ #LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
+-AM_LDFLAGS = ${all_libraries} `freetype-config --libs` ${SDL_LIBS} ${GLUT_LIBS}
+ #LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz -L/home/floh/nvsdk/OpenGL/lib/ -lnvparse
+-LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
++LIBS = ${all_libraries} `freetype-config --libs` ${SDL_LIBS} ${GLUT_LIBS} ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
diff --git a/games-sports/foobillard/foobillard-3.0a.ebuild b/games-sports/foobillard/foobillard-3.0a.ebuild
index b57fa63176ee..7fac0faf09df 100644
--- a/games-sports/foobillard/foobillard-3.0a.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.11 2007/02/24 01:20:00 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.12 2008/12/07 11:28:02 mr_bones_ Exp $
inherit eutils autotools games
@@ -29,7 +29,8 @@ src_unpack() {
cd "${S}"
epatch \
"${FILESDIR}"/${P}-no_nvidia.patch \
- "${FILESDIR}"/${P}-fbsd.patch
+ "${FILESDIR}"/${P}-fbsd.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
eautoreconf
}