summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-01-25 08:01:02 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-01-25 08:01:02 +0000
commita9c95e57dff573123cc404d82a7bd2a9a69dbebe (patch)
tree117967c9de08e6eab5f3fe5a7598bcd2fc3c534c
parentstable on x86, security bug #115775 (diff)
downloadgentoo-2-a9c95e57dff573123cc404d82a7bd2a9a69dbebe.tar.gz
gentoo-2-a9c95e57dff573123cc404d82a7bd2a9a69dbebe.tar.bz2
gentoo-2-a9c95e57dff573123cc404d82a7bd2a9a69dbebe.zip
(#118800) Fix modular X deps. USE=X did nothing, so remove it. Fix USE=-gtk.
(Portage version: 2.1_pre3-r1)
-rw-r--r--x11-misc/hotkeys/ChangeLog8
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild14
2 files changed, 14 insertions, 8 deletions
diff --git a/x11-misc/hotkeys/ChangeLog b/x11-misc/hotkeys/ChangeLog
index 8eafb1d019bd..ebd01cd6df4e 100644
--- a/x11-misc/hotkeys/ChangeLog
+++ b/x11-misc/hotkeys/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/hotkeys
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.23 2005/07/11 23:05:34 swegener Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.24 2006/01/25 08:01:02 spyderous Exp $
+
+ 25 Jan 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ hotkeys-0.5.7.1-r1.ebuild:
+ (#118800) Fix modular X deps. USE=X did nothing, so remove it. Fix USE=-gtk.
11 Jul 2005; Sven Wegener <swegener@gentoo.org> hotkeys-0.5.7.1-r1.ebuild:
QA: Use use_with for econf.
diff --git a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
index 9e8ff578e27b..28bede886a4e 100644
--- a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
+++ b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.11 2005/07/11 23:05:34 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.12 2006/01/25 08:01:02 spyderous Exp $
inherit eutils
DESCRIPTION="Make use of extra buttons on newer keyboards."
SRC_URI="http://ypwong.org/hotkeys/${PV}/${PN}_${PV}.tar.gz"
HOMEPAGE="http://ypwong.org/hotkeys/"
-IUSE="X gtk xosd"
+IUSE="gtk xosd"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc amd64 ppc"
-DEPEND="X? ( virtual/x11 )
+DEPEND="|| ( x11-libs/libXmu virtual/x11 )
>=dev-libs/libxml2-2.2.8
=sys-libs/db-3.2*
xosd? ( >=x11-libs/xosd-1.0.0 )
@@ -25,11 +25,13 @@ src_unpack() {
}
src_compile() {
+ if use gtk; then
+ opts="${opts} --with-gtk"
+ fi
econf \
--disable-db3test \
- $(use_with X) \
$(use_with xosd) \
- $(use_with gtk) \
+ ${opts} \
|| die "./configure failed"
emake || die
}