summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-07 03:42:16 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-07 03:42:16 +0000
commita7404d49317397f1cef15b0191539c31b008be8c (patch)
tree6cc8b2353be2210b95ef65ee7c8a1c4fc50365a5
parentmask new kernels for testing (diff)
downloadgentoo-2-a7404d49317397f1cef15b0191539c31b008be8c.tar.gz
gentoo-2-a7404d49317397f1cef15b0191539c31b008be8c.tar.bz2
gentoo-2-a7404d49317397f1cef15b0191539c31b008be8c.zip
New kernels to play with.
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog44
-rw-r--r--sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r102
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild51
-rw-r--r--sys-kernel/xfs-sources/ChangeLog38
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.19-r22
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.19-r2.ebuild48
6 files changed, 183 insertions, 2 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index bd3a8fb082eb..1fd2d8602efe 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,48 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.5 2002/09/05 04:46:09 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.6 2002/10/07 03:42:16 lostlogic Exp $
+
+*gentoo-sources-2.4.19-r10 (06 Oct 2002)
+
+ 06 Oct 2002; Brandon Low <lostlogic@gentoo.org> gentoo-sources-2.4.19-r10.ebuild:
+
+ While testing this kerenl I ran into very bad crashing behavior with
+ the USE="acpi4linux" option enabled... just a warning. But for you
+ laptopers it is still there.
+
+ Well I dug up about 3-4 hours of time and merged xfs into this kernel
+ so everyone who has been asking for it finally gets their way because
+ I hate being unpopular. I hope you all enjoy XFS, it is enabled by a
+ hidden useflag so set USE="xfs" to turn it on for this kernel. Please
+ let me know your results.
+
+ New in this release:
+ - Dropped ext3-htree due to corruption with current e2fsprogs
+ this may bite some of you who are already using it, but
+ hopefully it will be updated before you need to fsck your
+ partitions a lot.
+ - Update EVMS
+ - Update JFS
+ - Fix for grsecurity compilation
+ - Update patches.txt documentation and kernel.eclass (makes older
+ a little funky, but is more forward working)
+ - Fix processor type options to show gcc>31 rather than gcc31
+ - Add futexes support
+ - Add imon support
+ - Optional XFS patch just set USE="xfs"
+ - Optional ACPI patch just set USE="acpi4linux"
+ - Redone ebuild setup now we have an eclass for these things
+ - Rename some patches to better names for use with KERNEL_EXCLUDE
+ - Add support for KERNEL_EXCLUDE
+ - Add and re-arrange VIA bugfixes
+ - Update grsecurity
+ - Switch to latest release IPSEC Free S/WAN
+ - Add usbdnet support for Zaurus handhelds
+ - Updated preempt
+ - Updated rmap
+ - Add xattr and acl patches and include the JFS patches for them.
+ - Add supermount patches.
+ - Incorportate the small fixes done to gentoo-sources-2.4.19-r9
*gentoo-sources-2.4.19-r9 (03 Sep 2002)
diff --git a/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r10 b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r10
new file mode 100644
index 000000000000..19d991259834
--- /dev/null
+++ b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r10
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 59ff0f443bed8cadb01addda59f51922 patches-2.4.19-gentoo-r10.tar.bz2 2665464
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild
new file mode 100644
index 000000000000..175bc73c2506
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild,v 1.1 2002/10/07 03:42:16 lostlogic Exp $
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ # This is the XFS filesystem from SGI, use at your own risk ;)
+ [ `use xfs` ] || rm *xfs*
+
+ # This is the latest release of ACPI from
+ # http://www.sourceforge.net/projects/acpi
+ [ `use acpi4linux` ] || rm 70*
+
+ kernel_src_unpack
+}
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index 45f03d510dd6..f60961ea8466 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,6 +1,42 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.5 2002/09/03 23:41:47 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.6 2002/10/07 03:42:16 lostlogic Exp $
+
+*xfs-sources-2.4.19-r2 (06 Oct 2002)
+
+ 06 Oct 2002; Brandon Low <lostlogic@gentoo.org> xfs-sources-2.4.19-r1.ebuild:
+
+ This release is a team effort of Tobias Eichert <tobias@databoogie.net>
+ and myself.
+
+ While testing this kerenl I ran into very bad crashing behavior with
+ the USE="acpi4linux" option enabled... just a warning. But for you
+ laptopers it is still there.
+
+ New from xfs-sources-2.4.19-r1:
+ - Update to latest XFS patch
+ - Dropped ext3-htree due to corruption with current e2fsprogs
+ this may bite some of you who are already using it, but
+ hopefully it will be updated before you need to fsck your
+ partitions a lot.
+ - Update EVMS
+ - Update JFS
+ - Fix for grsecurity compilation
+ - Update patches.txt documentation and kernel.eclass (makes older
+ a little funky, but is more forward working)
+ - Fix processor type options to show gcc>31 rather than gcc31
+ - Add futexes support
+ - Add imon support
+ - Optional ACPI patch just set USE="acpi4linux"
+ - Redone ebuild setup now we have an eclass for these things
+ - Rename some patches to better names for use with KERNEL_EXCLUDE
+ - Add support for KERNEL_EXCLUDE
+ - Add and re-arrange VIA bugfixes
+ - Update grsecurity
+ - Switch to latest release IPSEC Free S/WAN
+ - Add usbdnet support for Zaurus handhelds
+ - Add supermount patches.
+ - Incorportate the small fixes done to xfs-sources-2.4.19-r1
*xfs-sources-2.4.19-r1 (03 Sep 2002)
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.19-r2 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.19-r2
new file mode 100644
index 000000000000..d791ee61576a
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.19-r2
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 eb93e496ea32cc6f1a90313bfbe20e67 patches-2.4.19-xfs-r2.tar.bz2 2497829
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.19-r2.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.19-r2.ebuild
new file mode 100644
index 000000000000..5a0c4779daf8
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.19-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.19-r2.ebuild,v 1.1 2002/10/07 03:42:16 lostlogic Exp $
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ # This is the latest release of ACPI from
+ # http://www.sourceforge.net/projects/acpi
+ [ `use acpi4linux` ] || rm 70*
+
+ kernel_src_unpack
+}