summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2012-11-04 16:40:39 +0000
committerChristian Faulhammer <fauli@gentoo.org>2012-11-04 16:40:39 +0000
commita6c81e3e992b54170f6e26955217a6c5e4d7157e (patch)
treee3cd302bb4f08ea75ec8f5faacf3e5eec1075099
parentVersion bump with upstream fixes (thanks Andreas Sturmlechner, bug 440838) (diff)
downloadgentoo-2-a6c81e3e992b54170f6e26955217a6c5e4d7157e.tar.gz
gentoo-2-a6c81e3e992b54170f6e26955217a6c5e4d7157e.tar.bz2
gentoo-2-a6c81e3e992b54170f6e26955217a6c5e4d7157e.zip
add patch for bug 440898 by John Brendler, valuable input from Duncan and others
(Portage version: 2.1.11.9/cvs/Linux i686)
-rw-r--r--mail-client/claws-mail/ChangeLog9
-rw-r--r--mail-client/claws-mail/claws-mail-3.8.1-r3.ebuild141
-rw-r--r--mail-client/claws-mail/files/claws-mail-3.8.1_fix-gnutls-3.1.3.patch16
3 files changed, 165 insertions, 1 deletions
diff --git a/mail-client/claws-mail/ChangeLog b/mail-client/claws-mail/ChangeLog
index d2a460c5e385..00182e1a4ed1 100644
--- a/mail-client/claws-mail/ChangeLog
+++ b/mail-client/claws-mail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/claws-mail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.215 2012/10/31 18:30:40 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.216 2012/11/04 16:40:39 fauli Exp $
+
+*claws-mail-3.8.1-r3 (04 Nov 2012)
+
+ 04 Nov 2012; Christian Faulhammer <fauli@gentoo.org>
+ +claws-mail-3.8.1-r3.ebuild, +files/claws-mail-3.8.1_fix-gnutls-3.1.3.patch:
+ add patch for bug 440898 by John Brendler, valuable input from Duncan and
+ others
31 Oct 2012; Andreas Schuerch <nativemad@gentoo.org>
claws-mail-3.8.1-r2.ebuild:
diff --git a/mail-client/claws-mail/claws-mail-3.8.1-r3.ebuild b/mail-client/claws-mail/claws-mail-3.8.1-r3.ebuild
new file mode 100644
index 000000000000..3140ecfdc39e
--- /dev/null
+++ b/mail-client/claws-mail/claws-mail-3.8.1-r3.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-3.8.1-r3.ebuild,v 1.1 2012/11/04 16:40:39 fauli Exp $
+
+EAPI="4"
+
+inherit autotools-utils multilib gnome2-utils eutils
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="http://www.claws-mail.org/"
+
+SRC_URI="mirror://sourceforge/sylpheed-claws/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bogofilter crypt dbus dillo doc +imap ipv6 ldap nntp pda session smime spamassassin spell +ssl startup-notification xface"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.20:2
+ pda? ( >=app-pda/jpilot-0.99 )
+ ssl? ( >=net-libs/gnutls-2.2.0 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ dillo? ( www-client/dillo )
+ spell? ( >=app-text/enchant-1.0.0 )
+ imap? ( >=net-libs/libetpan-0.57 )
+ nntp? ( >=net-libs/libetpan-0.57 )
+ startup-notification? ( x11-libs/startup-notification )
+ bogofilter? ( mail-filter/bogofilter )
+ session? ( x11-libs/libSM
+ x11-libs/libICE )
+ smime? ( >=app-crypt/gpgme-0.4.5 )"
+
+DEPEND="${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+ virtual/pkgconfig"
+
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+PLUGIN_NAMES="acpi-notifier address_keeper archive att-remover attachwarner clamd fancy fetchinfo geolocation gdata gtkhtml mailmbox newmail notification perl python rssyl spam_report tnef_parse vcalendar"
+
+PATCHES=(
+ "${FILESDIR}"/claws-mail-${PV}_fix-signature.patch
+ "${FILESDIR}"/claws-mail-${PV}_procmime-vuln.patch
+ "${FILESDIR}"/claws-mail-${PV}_fix-gnutls-3.1.3.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ipv6)
+ $(use_enable ldap)
+ $(use_enable dbus)
+ $(use_enable pda jpilot)
+ $(use_enable spell enchant)
+ $(use_enable xface compface)
+ $(use_enable doc manual)
+ $(use_enable startup-notification)
+ $(use_enable session libsm)
+ $(use_enable crypt pgpmime-plugin)
+ $(use_enable crypt pgpinline-plugin)
+ $(use_enable crypt pgpcore-plugin)
+ $(use_enable dillo dillo-viewer-plugin)
+ $(use_enable spamassassin spamassassin-plugin)
+ $(use_enable bogofilter bogofilter-plugin)
+ $(use_enable smime smime-plugin)
+ --enable-trayicon-plugin
+ --disable-maemo
+ )
+
+ # libetpan is needed if user wants nntp or imap functionality
+ if use imap || use nntp; then
+ myeconfargs+=( --enable-libetpan )
+ else
+ myeconfargs+=( --disable-libetpan )
+ fi
+
+ if use ssl; then
+ myeconfargs+=( --enable-gnutls )
+ else
+ myeconfargs+=( --disable-gnutls )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog* INSTALL* NEWS README* TODO* )
+ autotools-utils_src_install
+
+ # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins ${PN}.png || die
+ local res resdir
+ for res in 64x64 128x128 ; do
+ resdir="/usr/share/icons/hicolor/${res}/apps"
+ insinto ${resdir}
+ newins ${PN}-${res}.png ${PN}.png || die
+ done
+
+ docinto tools
+ dodoc tools/README*
+
+ domenu ${PN}.desktop
+
+ einfo "Installing extra tools"
+ cd "${S}"/tools
+ exeinto /usr/$(get_libdir)/${PN}/tools
+ doexe *.pl *.py *.conf *.sh || die
+ doexe tb2claws-mail update-po uudec uuooffice || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ UPDATE_PLUGINS=""
+ for x in ${PLUGIN_NAMES}; do
+ has_version mail-client/${PN}-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+ done
+ if [ -n "${UPDATE_PLUGINS}" ]; then
+ elog
+ elog "You have to re-emerge or update the following plugins:"
+ elog
+ for x in ${UPDATE_PLUGINS}; do
+ elog " mail-client/${PN}-$x"
+ done
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/mail-client/claws-mail/files/claws-mail-3.8.1_fix-gnutls-3.1.3.patch b/mail-client/claws-mail/files/claws-mail-3.8.1_fix-gnutls-3.1.3.patch
new file mode 100644
index 000000000000..37974a6c4119
--- /dev/null
+++ b/mail-client/claws-mail/files/claws-mail-3.8.1_fix-gnutls-3.1.3.patch
@@ -0,0 +1,16 @@
+Fixes mail retrieval when being built with GnuTLS 3.1.3
+Patch taken from upstream repository http://www.claws-mail.org/tracker/getpatchset.php?ver=3.8.1cvs99
+
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=440898
+
+--- src/common/ssl_certificate.c 9 Aug 2012 11:32:26 -0000 1.4.2.44
++++ src/common/ssl_certificate.c 13 Oct 2012 09:45:58 -0000 1.4.2.45
+@@ -93,6 +93,7 @@
+ size_t size;
+ gnutls_datum tmp;
+ gnutls_x509_crt dest;
++ size = 0;
+
+ if (gnutls_x509_crt_init(&dest) != 0) {
+ g_warning("couldn't gnutls_x509_crt_init\n");
+