summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2012-12-02 20:48:02 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2012-12-02 20:48:02 +0000
commita6a5c4d77beba7ecdff8b39af8c7e23885d2f995 (patch)
tree081a6a5590d94637461c2228807e180610d30082
parentStable for ppc64, wrt bug #432400 (diff)
downloadgentoo-2-a6a5c4d77beba7ecdff8b39af8c7e23885d2f995.tar.gz
gentoo-2-a6a5c4d77beba7ecdff8b39af8c7e23885d2f995.tar.bz2
gentoo-2-a6a5c4d77beba7ecdff8b39af8c7e23885d2f995.zip
Incorporate ago's suggestions.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/pysctp/pysctp-0.6.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pysctp/pysctp-0.6.ebuild b/dev-python/pysctp/pysctp-0.6.ebuild
index 59f4b8dc9fc3..3f918a6c8b0d 100644
--- a/dev-python/pysctp/pysctp-0.6.ebuild
+++ b/dev-python/pysctp/pysctp-0.6.ebuild
@@ -1,26 +1,26 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysctp/pysctp-0.6.ebuild,v 1.3 2012/12/02 02:56:41 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysctp/pysctp-0.6.ebuild,v 1.4 2012/12/02 20:48:02 zx2c4 Exp $
EAPI=4
-inherit distutils
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+inherit distutils-r1
DESCRIPTION="PySCTP gives access to the SCTP transport protocol from Python."
HOMEPAGE="https://github.com/philpraxis/pysctp"
-SRC_URI="https://github.com/philpraxis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://github/philpraxis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-PYTHON_DEPEND="2"
DEPEND="net-misc/lksctp-tools"
RDEPEND="${DEPEND}"
src_install() {
- distutils_src_install
- rm -v "${D}/usr/_sctp.h"
+ distutils-r1_src_install
+ rm -v "${D}usr/_sctp.h"
dodoc test_local_cnx.py test_remote_cnx.py
}