summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-16 15:54:19 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-16 15:54:19 +0000
commita61c83d64182489dde7a6f62789e6b5dfb5bf360 (patch)
tree3d4c22753c3aa1fa82eca973158ca14c3b53b135
parentAdd version 0.58.5 (diff)
downloadgentoo-2-a61c83d64182489dde7a6f62789e6b5dfb5bf360.tar.gz
gentoo-2-a61c83d64182489dde7a6f62789e6b5dfb5bf360.tar.bz2
gentoo-2-a61c83d64182489dde7a6f62789e6b5dfb5bf360.zip
fix build with libpng 1.5
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
-rw-r--r--media-sound/sox/ChangeLog8
-rw-r--r--media-sound/sox/files/sox-14.3.1-libpng15.patch12
-rw-r--r--media-sound/sox/sox-14.3.1.ebuild7
3 files changed, 22 insertions, 5 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index 23fbb5a9e970..f3f48eb2a886 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/sox
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.120 2010/04/29 12:02:15 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.121 2011/02/16 15:54:18 aballier Exp $
+
+ 16 Feb 2011; Alexis Ballier <aballier@gentoo.org> sox-14.3.1.ebuild,
+ +files/sox-14.3.1-libpng15.patch:
+ fix build with libpng 1.5
29 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> sox-14.3.0.ebuild:
Fix commit that was made 29 Dec 2009 to stabilize sox-14.3.0 for sparc.
diff --git a/media-sound/sox/files/sox-14.3.1-libpng15.patch b/media-sound/sox/files/sox-14.3.1-libpng15.patch
new file mode 100644
index 000000000000..6b1b8df5eb37
--- /dev/null
+++ b/media-sound/sox/files/sox-14.3.1-libpng15.patch
@@ -0,0 +1,12 @@
+Index: sox-14.3.1/src/spectrogram.c
+===================================================================
+--- sox-14.3.1.orig/src/spectrogram.c
++++ sox-14.3.1/src/spectrogram.c
+@@ -25,6 +25,7 @@
+ #include <assert.h>
+ #include <math.h>
+ #include <png.h>
++#include <zlib.h>
+
+ #define MAX_FFT_SIZE 4096
+ #define is_p2(x) !(x & (x - 1))
diff --git a/media-sound/sox/sox-14.3.1.ebuild b/media-sound/sox/sox-14.3.1.ebuild
index a9bd8b6e26b8..d19b4cc554cd 100644
--- a/media-sound/sox/sox-14.3.1.ebuild
+++ b/media-sound/sox/sox-14.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.1.ebuild,v 1.2 2010/04/29 11:46:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.1.ebuild,v 1.3 2011/02/16 15:54:18 aballier Exp $
EAPI=2
inherit eutils flag-o-matic
@@ -28,7 +28,7 @@ RDEPEND="sys-devel/libtool
ladspa? ( media-libs/ladspa-sdk )
>=media-sound/gsm-1.0.12-r1
id3tag? ( media-libs/libid3tag )
- png? ( media-libs/libpng )
+ png? ( media-libs/libpng sys-libs/zlib )
pulseaudio? ( media-sound/pulseaudio )
wavpack? ( media-sound/wavpack )"
DEPEND="${RDEPEND}
@@ -36,6 +36,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-nomad.patch
+ epatch "${FILESDIR}"/${P}-libpng15.patch
}
src_configure() {