summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-11-08 04:24:33 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-11-08 04:24:33 +0000
commita5cd7ef558884fd8fc1d77de2dc579b2d732cc7d (patch)
tree6675e981d98d4926366536e1c9dd361b9269e23e
parentArch mask the new vim (diff)
downloadgentoo-2-a5cd7ef558884fd8fc1d77de2dc579b2d732cc7d.tar.gz
gentoo-2-a5cd7ef558884fd8fc1d77de2dc579b2d732cc7d.tar.bz2
gentoo-2-a5cd7ef558884fd8fc1d77de2dc579b2d732cc7d.zip
new package: <bigwig> is a high-level programming language for developing interactive Web
services.
-rw-r--r--dev-lang/bigwig/ChangeLog14
-rw-r--r--dev-lang/bigwig/bigwig-2.0-r7.ebuild84
-rw-r--r--dev-lang/bigwig/files/digest-bigwig-2.0-r71
3 files changed, 99 insertions, 0 deletions
diff --git a/dev-lang/bigwig/ChangeLog b/dev-lang/bigwig/ChangeLog
new file mode 100644
index 000000000000..3f719e145403
--- /dev/null
+++ b/dev-lang/bigwig/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for dev-lang/bigwig
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/bigwig/ChangeLog,v 1.1 2002/11/08 04:24:33 george Exp $
+
+*bigwig-2.0-7 (01 Jul 2002)
+
+ 07 Nov 2002; George Shapovalov <george@gentoo.org> bigwig-2.0-r7.ebuild, ChangeLog :
+ cleaned-up and committed
+
+ 06 Jul 2002; Sean Summers <ebuild@generalprotectionfault.com> bigwig-2.0-r7.ebuild :
+
+ Initial package
+ <bigwig> is a high-level programming language for developing interactive Web
+ services.
diff --git a/dev-lang/bigwig/bigwig-2.0-r7.ebuild b/dev-lang/bigwig/bigwig-2.0-r7.ebuild
new file mode 100644
index 000000000000..a6e72bd85c90
--- /dev/null
+++ b/dev-lang/bigwig/bigwig-2.0-r7.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/bigwig/bigwig-2.0-r7.ebuild,v 1.1 2002/11/08 04:24:33 george Exp $
+
+IUSE="odbc mysql libwww java ssl"
+
+DESCRIPTION="a high-level programming language for developing interactive Web services."
+HOMEPAGE="http://www.brics.dk/bigwig/"
+LICENSE="GPL-2"
+DEPEND=">=net-www/apache-1.3
+ odbc? ( dev-db/unixODBC )
+ mysql? ( dev-db/mysql )
+ libwww? ( net-libs/libwww )
+ java? ( virtual/jre )
+ ssl? ( dev-libs/openssl )
+ sys-devel/ld.so
+ sys-libs/zlib
+ virtual/glibc"
+
+SLOT="0"
+SRC_URI="http://www.brics.dk/bigwig/dist/${P}-7.tar.gz"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf
+
+ myconf="--enable-purify --enable-syslog=LOG_LOCAL5 --with-gnu-ld"
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs --with-apacheuser=apache --with-apachemodules=apache"
+
+ use odbc \
+ && myconf="${myconf} --with-odbc-inc=/usr/include/ --with-odbc-lib=/usr/lib/" \
+ || myconf="${myconf} --disable-odbc"
+
+ use libwww \
+ && myconf="${myconf} --with-libwww-config=/usr/bin/libwww-config" \
+ || myconf="${myconf} --disable-libwww"
+
+ econf ${myconf} || die "./configure failed"
+ #./configure \
+ # ${myconf} \
+ # --host=${CHOST} \
+ # --prefix=/usr \
+ # --infodir=/usr/share/info \
+ # --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ local t
+ for t in `find ${S} -type f -name Makefile`
+ do
+ cp ${t} ${t}.orig || die
+ sed "s:^\(APACHE_.\+_DIR = \)\(/\):\1${D}\2:" ${t}.orig > ${t}
+ done
+ unset t
+
+ make \
+ DESTDIR=${D} \
+ RPM_BUILD_ROOT=${D} \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ echo "make install finished"; echo
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ rm -f ${D}/etc/apache/conf/httpd.conf
+
+ # fix stupid install script...
+ local t
+ local tdst
+ for t in `find ${D}${D} -type f -o -type l`
+ do
+ tdst=`echo ${t} | sed s:^${D}::`
+ mkdir -p `dirname ${tdst}`
+ mv ${t} ${tdst}
+ done
+ rm -rf ${D}/var/tmp/
+}
diff --git a/dev-lang/bigwig/files/digest-bigwig-2.0-r7 b/dev-lang/bigwig/files/digest-bigwig-2.0-r7
new file mode 100644
index 000000000000..7ba3eb6c0d84
--- /dev/null
+++ b/dev-lang/bigwig/files/digest-bigwig-2.0-r7
@@ -0,0 +1 @@
+MD5 b58e3ced854d6f949c116e43bf18014a bigwig-2.0-7.tar.gz 1275164