summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-11-01 17:42:23 +0000
committerJeroen Roovers <jer@gentoo.org>2013-11-01 17:42:23 +0000
commita5c2f9f869380c7b88735d32163ad6905d463d54 (patch)
tree2a91e1c3f461788e67d0208623d13a5c8295a71f
parentInitial commit. (diff)
downloadgentoo-2-a5c2f9f869380c7b88735d32163ad6905d463d54.tar.gz
gentoo-2-a5c2f9f869380c7b88735d32163ad6905d463d54.tar.bz2
gentoo-2-a5c2f9f869380c7b88735d32163ad6905d463d54.zip
Version bumps.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--dev-libs/geoip/ChangeLog9
-rw-r--r--dev-libs/geoip/geoip-1.5.2.ebuild78
-rw-r--r--dev-libs/geoip/geoip-1.6.0.ebuild68
3 files changed, 154 insertions, 1 deletions
diff --git a/dev-libs/geoip/ChangeLog b/dev-libs/geoip/ChangeLog
index c43008985b16..963a38d60999 100644
--- a/dev-libs/geoip/ChangeLog
+++ b/dev-libs/geoip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/geoip
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/ChangeLog,v 1.188 2013/07/20 05:15:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/ChangeLog,v 1.189 2013/11/01 17:42:23 jer Exp $
+
+*geoip-1.5.2 (01 Nov 2013)
+*geoip-1.6.0 (01 Nov 2013)
+
+ 01 Nov 2013; Jeroen Roovers <jer@gentoo.org> +geoip-1.5.2.ebuild,
+ +geoip-1.6.0.ebuild:
+ Version bumps.
20 Jul 2013; Jeroen Roovers <jer@gentoo.org> geoip-1.5.1.ebuild:
Switch to github based releases. Clean up.
diff --git a/dev-libs/geoip/geoip-1.5.2.ebuild b/dev-libs/geoip/geoip-1.5.2.ebuild
new file mode 100644
index 000000000000..130f6e07a0c9
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.5.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.5.2.ebuild,v 1.1 2013/11/01 17:42:23 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+GEOLITE_URI="http://geolite.maxmind.com/download/geoip/database/"
+
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://dev.maxmind.com/geoip/legacy/downloadable"
+SRC_URI="
+ https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ http://geolite.maxmind.com/download/${PN}/database/GeoLiteCountry/GeoIP.dat.gz
+ ${GEOLITE_URI}asnum/GeoIPASNum.dat.gz
+ city? ( ${GEOLITE_URI}GeoLiteCity.dat.gz )
+ ipv6? (
+ ${GEOLITE_URI}GeoIPv6.dat.gz
+ city? ( ${GEOLITE_URI}GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz )
+ )
+"
+
+# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
+LICENSE="LGPL-2.1 GPL-2 MaxMind2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="city ipv6 perl-geoipupdate static-libs"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="
+ ${DEPEND}
+ perl-geoipupdate? (
+ dev-perl/PerlIO-gzip
+ dev-perl/libwww-perl
+ )
+"
+
+S="${WORKDIR}/${PN}-api-c-${PV}"
+
+src_prepare() {
+ mv "${WORKDIR}"/GeoIP.dat data || die
+
+ sed -e "s:usr local share GeoIP:usr share GeoIP:" \
+ -e "s:usr local etc:etc:" \
+ -i apps/geoipupdate-pureperl.pl || die
+
+ sed -e 's|yahoo.com|98.139.183.24|g' \
+ -i test/country_test_name.txt test/region_test.txt || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use perl-geoipupdate && dobin apps/geoipupdate-pureperl.pl
+
+ dodoc AUTHORS ChangeLog README* TODO conf/GeoIP.conf.default
+
+ rm "${ED}/etc/GeoIP.conf.default"
+
+ prune_libtool_files
+
+ insinto /usr/share/GeoIP
+ doins "${WORKDIR}/GeoIPASNum.dat"
+ use city && newins "${WORKDIR}"/GeoLiteCity.dat GeoIPCity.dat
+
+ if use ipv6; then
+ doins "${WORKDIR}/GeoIPv6.dat"
+ use city && newins "${WORKDIR}"/GeoLiteCityv6.dat GeoIPCityv6.dat
+ fi
+
+ newsbin "${FILESDIR}/geoipupdate-r2.sh" geoipupdate.sh
+}
diff --git a/dev-libs/geoip/geoip-1.6.0.ebuild b/dev-libs/geoip/geoip-1.6.0.ebuild
new file mode 100644
index 000000000000..7803348cc712
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.6.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.6.0.ebuild,v 1.1 2013/11/01 17:42:23 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+GEOLITE_URI="http://geolite.maxmind.com/download/geoip/database/"
+
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://dev.maxmind.com/geoip/legacy/downloadable"
+SRC_URI="
+ https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ http://geolite.maxmind.com/download/${PN}/database/GeoLiteCountry/GeoIP.dat.gz
+ ${GEOLITE_URI}asnum/GeoIPASNum.dat.gz
+ city? ( ${GEOLITE_URI}GeoLiteCity.dat.gz )
+ ipv6? (
+ ${GEOLITE_URI}GeoIPv6.dat.gz
+ city? ( ${GEOLITE_URI}GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz )
+ )
+"
+
+# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
+LICENSE="LGPL-2.1 GPL-2 MaxMind2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="city ipv6 static-libs"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="
+ ${DEPEND}
+ net-misc/geoipupdate
+"
+
+S="${WORKDIR}/${PN}-api-c-${PV}"
+
+src_prepare() {
+ mkdir data || die
+ mv "${WORKDIR}"/GeoIP.dat data/ || die
+
+ sed -e 's|yahoo.com|98.139.183.24|g' \
+ -i test/country_test_name.txt test/region_test.txt || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog README* TODO
+
+ prune_libtool_files
+
+ insinto /usr/share/GeoIP
+ doins "${WORKDIR}/GeoIPASNum.dat"
+ use city && newins "${WORKDIR}"/GeoLiteCity.dat GeoIPCity.dat
+
+ if use ipv6; then
+ doins "${WORKDIR}/GeoIPv6.dat"
+ use city && newins "${WORKDIR}"/GeoLiteCityv6.dat GeoIPCityv6.dat
+ fi
+
+ newsbin "${FILESDIR}/geoipupdate-r2.sh" geoipupdate.sh
+}