summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-19 14:15:49 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-19 14:15:49 +0000
commita398c649fef656573e3bacdc47848dc5ad65038c (patch)
tree831b99f5168598a1f0415a5c7bfd068b05afc44a
parentVersion bump #379857. (diff)
downloadgentoo-2-a398c649fef656573e3bacdc47848dc5ad65038c.tar.gz
gentoo-2-a398c649fef656573e3bacdc47848dc5ad65038c.tar.bz2
gentoo-2-a398c649fef656573e3bacdc47848dc5ad65038c.zip
Move from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
-rw-r--r--dev-python/pyatspi/ChangeLog10
-rw-r--r--dev-python/pyatspi/metadata.xml5
-rw-r--r--dev-python/pyatspi/pyatspi-2.0.2.ebuild77
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/pyatspi/ChangeLog b/dev-python/pyatspi/ChangeLog
new file mode 100644
index 000000000000..815ac4ad4ecd
--- /dev/null
+++ b/dev-python/pyatspi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pyatspi
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.1 2011/08/19 14:15:49 nirbheek Exp $
+
+*pyatspi-2.0.2 (19 Aug 2011)
+
+ 19 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +pyatspi-2.0.2.ebuild,
+ +metadata.xml:
+ Move from gnome overlay for GNOME 3
+
diff --git a/dev-python/pyatspi/metadata.xml b/dev-python/pyatspi/metadata.xml
new file mode 100644
index 000000000000..6949624e59d4
--- /dev/null
+++ b/dev-python/pyatspi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-accessibility</herd>
+</pkgmetadata>
diff --git a/dev-python/pyatspi/pyatspi-2.0.2.ebuild b/dev-python/pyatspi/pyatspi-2.0.2.ebuild
new file mode 100644
index 000000000000..b06a2c1eba55
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.0.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.0.2.ebuild,v 1.1 2011/08/19 14:15:49 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit gnome2 python
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="dev-python/dbus-python
+ >=dev-python/pygobject-2.26:2
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ test? (
+ >=dev-libs/atk-1.17
+ >=dev-libs/dbus-glib-0.7
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ >=x11-libs/gtk+-2.10:2 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable test tests)"
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv config/py-compile config/py-compile.orig
+ ln -s $(type -P true) config/py-compile
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -s gnome2_src_compile
+}
+
+src_test() {
+ python_execute_function -s -d
+}
+
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize pyatspi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup pyatspi
+}