summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-02-10 19:35:52 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-02-10 19:35:52 +0000
commita37ef5b8baad5ff797fd7c558c86f91f042580b8 (patch)
treedea12ca9e6d9e90d195074cdb8b5cfa7267a730c
parentCleaned up the install (removed unneccesary files) (diff)
downloadgentoo-2-a37ef5b8baad5ff797fd7c558c86f91f042580b8.tar.gz
gentoo-2-a37ef5b8baad5ff797fd7c558c86f91f042580b8.tar.bz2
gentoo-2-a37ef5b8baad5ff797fd7c558c86f91f042580b8.zip
Pruned old revisions with same keywords.
(Portage version: 2.1.2-r9)
-rw-r--r--app-emulation/emul-linux-x86-java/ChangeLog7
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.4.2.03-r1.ebuild120
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.08.ebuild141
-rw-r--r--app-emulation/emul-linux-x86-java/files/digest-emul-linux-x86-java-1.4.2.03-r13
-rw-r--r--app-emulation/emul-linux-x86-java/files/digest-emul-linux-x86-java-1.5.0.083
5 files changed, 6 insertions, 268 deletions
diff --git a/app-emulation/emul-linux-x86-java/ChangeLog b/app-emulation/emul-linux-x86-java/ChangeLog
index 5e4f275af25f..1e8dc6943f88 100644
--- a/app-emulation/emul-linux-x86-java/ChangeLog
+++ b/app-emulation/emul-linux-x86-java/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/emul-linux-x86-java
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.18 2007/02/03 05:17:53 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.19 2007/02/10 19:35:52 nichoj Exp $
+
+ 10 Feb 2007; Joshua Nichols <nichoj@gentoo.org>
+ -emul-linux-x86-java-1.4.2.03-r1.ebuild,
+ -emul-linux-x86-java-1.5.0.08.ebuild:
+ Pruned old revisions with same keywords.
03 Feb 2007; Steve Dibb <beandog@gentoo.org> metadata.xml,
emul-linux-x86-java-1.5.0.10.ebuild:
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.4.2.03-r1.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.4.2.03-r1.ebuild
deleted file mode 100644
index d896760e3268..000000000000
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.4.2.03-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.4.2.03-r1.ebuild,v 1.5 2006/03/09 01:49:19 flameeyes Exp $
-
-inherit multilib java versionator
-
-JREV="03"
-
-JV="${PV}"
-JV=$(get_version_component_range 1-3 ${JV})
-DESCRIPTION="32bit java emulation for amd64"
-J_URI="mirror://blackdown.org/JDK-${JV}"
-SRC_URI="${J_URI}/i386/${JREV}/j2re-${JV}-${JREV}-linux-i586.bin"
-
-HOMEPAGE="http://www.blackdown.org"
-
-SLOT="1.4.2"
-LICENSE="sun-bcla-java-vm"
-KEYWORDS="-* amd64"
-IUSE="nsplugin"
-DEPEND="virtual/libc
- >=sys-apps/sed-4"
-RDEPEND="virtual/libc
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-soundlibs"
-
-S="${WORKDIR}/j2re${JV}"
-
-JAVAHOME="${D}/opt/java32"
-
-# 32bit binary package
-pkg_setup() {
- ABI="x86"
-}
-
-RESTRICT="nostrip"
-
-# Extract the 'skip' value (offset of tarball) we should pass to tail
-get_offset() {
- [ ! -f "$1" ] && return
-
- local offset="`gawk '
- /^[[:space:]]*skip[[:space:]]*=/ {
-
- sub(/^[[:space:]]*skip[[:space:]]*=/, "")
- SKIP = $0
- }
-
- END { print SKIP }
- ' $1`"
-
- eval echo $offset
-}
-
-src_unpack () {
- local offset="`get_offset ${DISTDIR}/${A}`"
-
- if [ -z "${offset}" ] ; then
- eerror "Failed to get offset of tarball!"
- die "Failed to get offset of tarball!"
- fi
-
- echo ">>> Unpacking ${A}..."
- tail -n +${offset} ${DISTDIR}/${A} | tar --no-same-owner -jxpf -
-}
-
-unpack_jars() {
- # New to 1.4.2
- local PACKED_JARS="lib/tools.jar lib/rt.jar lib/jsse.jar lib/charsets.jar lib/ext/localedata.jar lib/plugin.jar javaws/javaws.jar"
- local UNPACK_CMD=""
- if [ -f "$JAVAHOME/lib/unpack" ]; then
- UNPACK_CMD="$JAVAHOME/lib/unpack"
- chmod +x "$UNPACK_CMD"
- #packerror=""
- sed -i 's#/tmp/unpack.log#/dev/null\x00\x00\x00\x00\x00\x00#g' $UNPACK_CMD
- for i in $PACKED_JARS; do
- if [ -f "$JAVAHOME/${i%.jar}.pack" ]; then
- einfo "Creating ${JAVAHOME}/${i}"
- "$UNPACK_CMD" "$JAVAHOME/${i%.jar}.pack" "$JAVAHOME/$i"
- if [ ! -f "$JAVAHOME/$i" ]; then
- die "Failed to unpack jar files ${i}." # Please refer\n"
- #ewarn "to the Troubleshooting section of the Installation\n"
- #ewarn "Instructions on the download page for more information.n"
- #packerror="1"
- fi
- rm -f "$JAVAHOME/${i%.jar}.pack"
- fi
- done
- fi
- rm -f "$UNPACK_CMD"
-}
-
-src_install() {
- typeset platform
-
- dodir /opt/java32
-
- cp -pPR ${S}/{bin,lib,man,plugin,javaws} ${JAVAHOME} || die "failed to copy"
-
- dodoc COPYRIGHT README
- dohtml README.html
-
- # Install mozilla plugin
- if use nsplugin ; then
- install_mozilla_plugin /opt/java32/plugin/i386/mozilla/libjavaplugin_oji.so
- fi
-
- sed -i "s/standard symbols l/symbol/g" ${D}/opt/java32/lib/font.properties
-
- find ${JAVAHOME} -type f -name "*.so" -exec chmod +x \{\} \;
-
- unpack_jars
-
- # Install java settings file for openoffice so that it will not try
- # to use the native 64bit jre and cause 2 minute startup...
- dodir /usr/$(get_libdir)/openoffice/share/config
- insinto /usr/$(get_libdir)/openoffice/share/config
- doins ${FILESDIR}/javasettings_Linux_x86.xml
-}
-
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.08.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.08.ebuild
deleted file mode 100644
index ed6e81d67993..000000000000
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.08.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.08.ebuild,v 1.2 2007/01/23 10:50:33 beandog Exp $
-
-inherit java-vm-2 eutils
-
-MY_PVL=${PV%.*}_${PV##*.}
-MY_PVA=${PV//./_}
-
-At="jdk-${MY_PVA}-dlj-linux-i586.bin"
-DESCRIPTION="32bit version Sun's J2SE Development Kit"
-HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
-SRC_URI="http://download.java.net/dlj/binaries/${At}"
-
-SLOT="1.5"
-LICENSE="dlj-1.1"
-KEYWORDS="-* amd64"
-RESTRICT="nostrip"
-IUSE="X alsa nsplugin"
-
-JAVA_VM_NO_GENERATION1=true
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- X? ( || ( ( x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXp
- x11-libs/libXt
- x11-libs/libXtst
- )
- virtual/x11
- )
- )"
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-PACKED_JARS="lib/rt.jar lib/jsse.jar lib/charsets.jar lib/ext/localedata.jar lib/plugin.jar lib/javaws.jar lib/deploy.jar"
-
-# this is needed for proper operating under a PaX kernel without activated grsecurity acl
-CHPAX_CONSERVATIVE_FLAGS="pemsv"
-
-QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so"
-
-src_unpack() {
- if [ ! -r ${DISTDIR}/${At} ]; then
- die "cannot read ${At}. Please check the permission and try again."
- fi
-
- mkdir bundled-jdk
- cd bundled-jdk
- sh ${DISTDIR}/${At} --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash ${FILESDIR}/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
-
- ${S}/bin/java -client -Xshare:dump
-}
-
-src_install() {
- local dirs="bin lib man javaws plugin"
- dodir /opt/${P}
-
- for i in $dirs ; do
- cp -pPR $i ${D}/opt/${P}/ || die "failed to copy"
- done
- dodoc CHANGES README THIRDPARTYLICENSEREADME.txt
- dohtml Welcome.html
- dodir /opt/${P}/share/
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
- fi
-
- # TODO Don't think we still needs these -nichoj
- # create dir for system preferences
- #dodir /opt/${P}/jre/.systemPrefs
- # Create files used as storage for system preferences.
- #touch ${D}/opt/${P}/jre/.systemPrefs/.system.lock
- #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.system.lock
- #touch ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
- #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
-
- # FIXME figure out how to handle the control pannel conflict with
- # sun-jdk-bin
-
- # install control panel for Gnome/KDE
-# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
-# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
-# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
-# ${T}/sun_java-${SLOT}.desktop
-
-# domenu ${T}/sun_java-${SLOT}.desktop
-
- set_java_env
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- # if chpax is on the target system, set the appropriate PaX flags
- # this will not hurt the binary, it modifies only unused ELF bits
- # but may confuse things like AV scanners and automatic tripwire
- if has_version sys-apps/chpax
- then
- echo
- einfo "setting up conservative PaX flags for java"
-
- for paxkills in "java"
- do
- chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/$paxkills
- done
-
- # /opt/$VM/jre/bin/java_vm
- chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/java_vm
-
- einfo "you should have seen lots of chpax output above now"
- ewarn "make sure the grsec ACL contains those entries also"
- ewarn "because enabling it will override the chpax setting"
- ewarn "on the physical files - help for PaX and grsecurity"
- ewarn "can be given by #gentoo-hardened + hardened@gentoo.org"
- fi
-
- if ! use X; then
- local xwarn="virtual/x11 and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-}
diff --git a/app-emulation/emul-linux-x86-java/files/digest-emul-linux-x86-java-1.4.2.03-r1 b/app-emulation/emul-linux-x86-java/files/digest-emul-linux-x86-java-1.4.2.03-r1
deleted file mode 100644
index 6903ab4b3355..000000000000
--- a/app-emulation/emul-linux-x86-java/files/digest-emul-linux-x86-java-1.4.2.03-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 cf4f3c8c86f64fd532f074943b432285 j2re-1.4.2-03-linux-i586.bin 13541431
-RMD160 82c707956dc65e9640fda97587ac7426e4f7be98 j2re-1.4.2-03-linux-i586.bin 13541431
-SHA256 636c414583f22d7d9f12f56855bfcb84227cec100ed0108a2b8f0e5f6b7025ef j2re-1.4.2-03-linux-i586.bin 13541431
diff --git a/app-emulation/emul-linux-x86-java/files/digest-emul-linux-x86-java-1.5.0.08 b/app-emulation/emul-linux-x86-java/files/digest-emul-linux-x86-java-1.5.0.08
deleted file mode 100644
index d00d890f6ddf..000000000000
--- a/app-emulation/emul-linux-x86-java/files/digest-emul-linux-x86-java-1.5.0.08
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3e2935cca24ceb54dd2181892a3d5456 jdk-1_5_0_08-dlj-linux-i586.bin 49498712
-RMD160 11c01f6391cec0476a3d96306a7bee7ec82d8425 jdk-1_5_0_08-dlj-linux-i586.bin 49498712
-SHA256 e96ebeefb5116182c01f6e3fb306d24f1b81ba6849b76b0d4705051b01647ce8 jdk-1_5_0_08-dlj-linux-i586.bin 49498712