summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-12-27 08:39:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-12-27 08:39:31 +0000
commita31f9a5559bfc9eb471a93963d9c49c8d8eadd9b (patch)
tree815f50f711a7fc2da0577c1c84477e5361d126a0
parentBump (diff)
downloadgentoo-2-a31f9a5559bfc9eb471a93963d9c49c8d8eadd9b.tar.gz
gentoo-2-a31f9a5559bfc9eb471a93963d9c49c8d8eadd9b.tar.bz2
gentoo-2-a31f9a5559bfc9eb471a93963d9c49c8d8eadd9b.zip
Bump
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
-rw-r--r--dev-python/shiboken/ChangeLog8
-rw-r--r--dev-python/shiboken/files/shiboken-1.0.9-fix-pkgconfig.patch19
-rw-r--r--dev-python/shiboken/shiboken-1.0.9.ebuild44
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index d6a0dc75e658..9b5293bd3696 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.12 2011/09/13 19:12:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.13 2011/12/27 08:39:31 patrick Exp $
+
+*shiboken-1.0.9 (27 Dec 2011)
+
+ 27 Dec 2011; Patrick Lauer <patrick@gentoo.org>
+ +files/shiboken-1.0.9-fix-pkgconfig.patch, +shiboken-1.0.9.ebuild:
+ Bump
13 Sep 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #278944
diff --git a/dev-python/shiboken/files/shiboken-1.0.9-fix-pkgconfig.patch b/dev-python/shiboken/files/shiboken-1.0.9-fix-pkgconfig.patch
new file mode 100644
index 000000000000..8df2c65d292e
--- /dev/null
+++ b/dev-python/shiboken/files/shiboken-1.0.9-fix-pkgconfig.patch
@@ -0,0 +1,19 @@
+diff -urN shiboken-1.0.9/data/shiboken.pc.in shiboken-1.0.9/data/shiboken.pc.in
+--- shiboken-1.0.9/data/shiboken.pc.in 2011-09-06 12:36:36.150737026 +0200
++++ shiboken-1.0.9/data/shiboken.pc.in 2011-09-06 12:38:30.780735651 +0200
+@@ -1,7 +1,8 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=@CMAKE_INSTALL_PREFIX@
+ libdir=@LIB_INSTALL_DIR@
+-includedir=@CMAKE_INSTALL_PREFIX@/include/shiboken
++shiboken_SUFFIX=@shiboken_SUFFIX@
++includedir=@CMAKE_INSTALL_PREFIX@/include/shiboken${shiboken_SUFFIX}
+ generator_location=@CMAKE_INSTALL_PREFIX@/bin/@SHIBOKEN_GENERATOR@
+ python_interpreter=@PYTHON_EXECUTABLE@
+ python_include_dir=@SBK_PYTHON_INCLUDE_DIR@
+@@ -10,5 +11,5 @@
+ Description: Support library for Python bindings created with Shiboken generator.
+ Version: @shiboken_VERSION@
+ Libs: @SBK_PYTHON_LIBRARIES@ -L${libdir} -lshiboken@shiboken_SUFFIX@@PYTHON_SUFFIX@@LIBRARY_OUTPUT_SUFFIX@
+-Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/@shiboken_SUFFIX@@SBK_PKG_CONFIG_PY_DEBUG_DEFINITION@
++Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/
diff --git a/dev-python/shiboken/shiboken-1.0.9.ebuild b/dev-python/shiboken/shiboken-1.0.9.ebuild
new file mode 100644
index 000000000000..f4c355dd72a5
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.0.9.ebuild,v 1.1 2011/12/27 08:39:31 patrick Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python versionator cmake-utils
+
+MY_PV=$(replace_version_separator '_' '~')
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+DEPEND=">=dev-python/apiextractor-0.10.8
+ >=dev-python/generatorrunner-0.6.14
+ >=x11-libs/qt-core-4.7.0"
+RDEPEND="${DEPEND}
+ !dev-python/boostpythongenerator"
+
+PATCHES=( "${FILESDIR}/${P}-fix-pkgconfig.patch" )
+
+DOCS=( ChangeLog )
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
+ cmake-utils_src_configure
+}