summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-08 10:41:55 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-08 10:41:55 +0000
commita304d75ac4bf6dd606130910e5c6744b358192f1 (patch)
tree58dc7b629f11d8cefccfd6de4041bf47c76ec5f7
parentamd64 stable wrt #385767 (diff)
downloadgentoo-2-a304d75ac4bf6dd606130910e5c6744b358192f1.tar.gz
gentoo-2-a304d75ac4bf6dd606130910e5c6744b358192f1.tar.bz2
gentoo-2-a304d75ac4bf6dd606130910e5c6744b358192f1.zip
Version bump
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.0.5.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 10e40d703dc3..6f9e98f10fa7 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.35 2011/09/21 15:24:17 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.36 2011/10/08 10:41:55 hwoarang Exp $
+
+*pf-sources-3.0.5 (08 Oct 2011)
+
+ 08 Oct 2011; Markos Chandras <hwoarang@gentoo.org> +pf-sources-3.0.5.ebuild:
+ Version bump
*pf-sources-3.0.4 (21 Sep 2011)
diff --git a/sys-kernel/pf-sources/pf-sources-3.0.5.ebuild b/sys-kernel/pf-sources/pf-sources-3.0.5.ebuild
new file mode 100644
index 000000000000..2e14124bae89
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.0.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.0.5.ebuild,v 1.1 2011/10/08 10:41:55 hwoarang Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="" # experimental
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+ #if use experimental; then
+ #for patch in ${EXPERIMENTAL_PATCHES[@]}; do
+ #epatch "${DISTDIR}"/"${patch/*\/}"
+ #done
+ #fi
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."