summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-11-21 14:22:30 +0000
committerBen de Groot <yngwin@gentoo.org>2008-11-21 14:22:30 +0000
commita266bde1d6ac67962c14f39ee9cbf6debcc097cb (patch)
tree4f7f0bdf6502bab04eac9e58b42fec74ca9b361c
parentVersion bump, with updated deps. Drop older hardmasked version. Drop x86-fbsd... (diff)
downloadgentoo-2-a266bde1d6ac67962c14f39ee9cbf6debcc097cb.tar.gz
gentoo-2-a266bde1d6ac67962c14f39ee9cbf6debcc097cb.tar.bz2
gentoo-2-a266bde1d6ac67962c14f39ee9cbf6debcc097cb.zip
Version bump, with added es and tr linguas. Patch needed to not let install be interactive, due to minor problem with pyxml.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-hh5 i686)
-rw-r--r--dev-util/eric/ChangeLog9
-rw-r--r--dev-util/eric/eric-4.2.3.ebuild83
-rw-r--r--dev-util/eric/files/4.2.3-no-interactive.patch24
3 files changed, 115 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index ad72b4bb77ea..e51fda2fa1fc 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/eric
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.66 2008/10/23 20:41:17 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.67 2008/11/21 14:22:30 yngwin Exp $
+
+*eric-4.2.3 (21 Nov 2008)
+
+ 21 Nov 2008; Ben de Groot <yngwin@gentoo.org>
+ +files/4.2.3-no-interactive.patch, +eric-4.2.3.ebuild:
+ Version bump, with added es and tr linguas. Patch needed to not let
+ install be interactive, due to minor problem with pyxml.
23 Oct 2008; Peter Alfredsen <loki_val@gentoo.org> eric-3.7.2-r1.ebuild:
Fix problem where installation would fail but src_install would succeed
diff --git a/dev-util/eric/eric-4.2.3.ebuild b/dev-util/eric/eric-4.2.3.ebuild
new file mode 100644
index 000000000000..55d05e93d155
--- /dev/null
+++ b/dev-util/eric/eric-4.2.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.2.3.ebuild,v 1.1 2008/11/21 14:22:30 yngwin Exp $
+
+NEED_PYTHON=2.4
+
+inherit python eutils
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A full featured Python IDE that is written in PyQt4 using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/eric/index.html"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
+ linguas_cs? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-cs-${PV}.tar.gz )
+ linguas_de? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-de-${PV}.tar.gz )
+ linguas_es? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-es-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-ru-${PV}.tar.gz )
+ linguas_tr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-tr-${PV}.tar.gz )"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
+
+DEPEND="dev-python/PyQt4
+ >=dev-python/qscintilla-python-2.2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de es fr ru tr"
+
+python_version
+
+pkg_setup() {
+ if ! built_with_use 'dev-python/qscintilla-python' 'qt4'; then
+ eerror "Please build qscintilla-python with qt4 useflag."
+ die "qscintilla-python built without qt4."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/4.1.4-paths.patch
+ epatch "${FILESDIR}"/4.2.3-no-interactive.patch
+}
+
+src_install() {
+ # Change qt dir to be located in ${D}
+ dodir /usr/share/qt4/
+ ${python} install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c || die "python install.py failed"
+
+ make_desktop_entry "eric4 --nosplash" \
+ eric4 \
+ "/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ elog "If you want to use eric4 with mod_python, have a look at"
+ elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give eric extended functionality."
+ elog
+ elog "dev-python/pylint"
+ elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog
+ elog "This version has a new plugin interface with plugin-autofetch from"
+ elog "the App itself. You may want to check those as well"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/dev-util/eric/files/4.2.3-no-interactive.patch b/dev-util/eric/files/4.2.3-no-interactive.patch
new file mode 100644
index 000000000000..ad61594c5d62
--- /dev/null
+++ b/dev-util/eric/files/4.2.3-no-interactive.patch
@@ -0,0 +1,24 @@
+--- eric/install.py.orig 2008-11-21 14:32:48.000000000 +0100
++++ eric/install.py 2008-11-21 14:34:34.000000000 +0100
+@@ -662,9 +662,6 @@
+ (v[0], v[1], v[2])
+ print " with foreign characters. Please see 'README-PyXML.txt' for"
+ print " details."
+- res = raw_input(" Shall pyXML be patched now (y/n)? ")
+- if res in ["Y", "y"]:
+- patchPyXML()
+ except:
+ pass
+
+--- install.py.orig 2008-11-21 14:43:06.000000000 +0100
++++ install.py 2008-11-21 14:43:24.000000000 +0100
+@@ -665,9 +665,6 @@
+ (v[0], v[1], v[2])
+ print " with foreign characters. Please see 'README-PyXML.txt' for"
+ print " details."
+- res = raw_input(" Shall pyXML be patched now (y/n)? ")
+- if res in ["Y", "y"]:
+- patchPyXML()
+ except:
+ pass
+