summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-09-23 22:55:22 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-09-23 22:55:22 +0000
commita265043295330f99a0aa929310d8d6d3e3259ebb (patch)
tree356b73680b7c8e172556abc3aac354847db15db1
parentVersion bump. (diff)
downloadgentoo-2-a265043295330f99a0aa929310d8d6d3e3259ebb.tar.gz
gentoo-2-a265043295330f99a0aa929310d8d6d3e3259ebb.tar.bz2
gentoo-2-a265043295330f99a0aa929310d8d6d3e3259ebb.zip
version bump
(Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
-rw-r--r--media-sound/pnmixer/ChangeLog8
-rw-r--r--media-sound/pnmixer/pnmixer-0.6_pre20140924.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/media-sound/pnmixer/ChangeLog b/media-sound/pnmixer/ChangeLog
index b4d13cac3ae9..db560565c73b 100644
--- a/media-sound/pnmixer/ChangeLog
+++ b/media-sound/pnmixer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/pnmixer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pnmixer/ChangeLog,v 1.10 2014/07/26 16:40:29 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pnmixer/ChangeLog,v 1.11 2014/09/23 22:55:22 hasufell Exp $
+
+*pnmixer-0.6_pre20140924 (23 Sep 2014)
+
+ 23 Sep 2014; Julian Ospald <hasufell@gentoo.org>
+ +pnmixer-0.6_pre20140924.ebuild:
+ version bump
*pnmixer-9999 (26 Jul 2014)
diff --git a/media-sound/pnmixer/pnmixer-0.6_pre20140924.ebuild b/media-sound/pnmixer/pnmixer-0.6_pre20140924.ebuild
new file mode 100644
index 000000000000..3ab7240c7152
--- /dev/null
+++ b/media-sound/pnmixer/pnmixer-0.6_pre20140924.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pnmixer/pnmixer-0.6_pre20140924.ebuild,v 1.1 2014/09/23 22:55:22 hasufell Exp $
+
+EAPI=5
+
+inherit eutils gnome2-utils
+
+DESCRIPTION="Volume mixer for the system tray"
+HOMEPAGE="https://github.com/nicklan/pnmixer"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug libnotify"
+
+RDEPEND="dev-libs/glib:2
+ media-libs/alsa-lib
+ >=x11-libs/gtk+-3.6:3
+ x11-libs/libX11
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_enable debug) \
+ --enable-minimal-flags \
+ --with-gtk3
+}
+
+src_install() {
+ default
+ newicon -s 128 pixmaps/${PN}-about.png ${PN}.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}