summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-06-03 22:00:22 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-06-03 22:00:22 +0000
commita1555edf3621c108bf8b480731750139c0720694 (patch)
tree5bb0bb28a4f410bf26fcc0ba3218bbd8c9f394b6
parentAdd pypi to remote-id in metadata.xml (diff)
downloadgentoo-2-a1555edf3621c108bf8b480731750139c0720694.tar.gz
gentoo-2-a1555edf3621c108bf8b480731750139c0720694.tar.bz2
gentoo-2-a1555edf3621c108bf8b480731750139c0720694.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--dev-ruby/rb-readline/ChangeLog7
-rw-r--r--dev-ruby/rb-readline/rb-readline-0.5.3.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-ruby/rb-readline/ChangeLog b/dev-ruby/rb-readline/ChangeLog
index 422c38e2b8ce..cab2bcd46206 100644
--- a/dev-ruby/rb-readline/ChangeLog
+++ b/dev-ruby/rb-readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rb-readline
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-readline/ChangeLog,v 1.4 2015/05/04 01:59:02 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-readline/ChangeLog,v 1.5 2015/06/03 22:00:22 mrueg Exp $
+
+*rb-readline-0.5.3 (03 Jun 2015)
+
+ 03 Jun 2015; Manuel Rüger <mrueg@gentoo.org> +rb-readline-0.5.3.ebuild:
+ Version bump.
04 May 2015; Rick Farina <zerochaos@gentoo.org> rb-readline-0.5.1.ebuild,
rb-readline-0.5.2.ebuild:
diff --git a/dev-ruby/rb-readline/rb-readline-0.5.3.ebuild b/dev-ruby/rb-readline/rb-readline-0.5.3.ebuild
new file mode 100644
index 000000000000..27119c6d3cbd
--- /dev/null
+++ b/dev-ruby/rb-readline/rb-readline-0.5.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-readline/rb-readline-0.5.3.ebuild,v 1.1 2015/06/03 22:00:22 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby implementation of the GNU readline C library"
+HOMEPAGE="http://rubygems.org/gems/rb-readline"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake
+ >=dev-ruby/minitest-5.2"
+
+all_ruby_prepare() {
+ # Skip a test that fails when run in the ebuild environment.
+ sed -i -e '/test_readline_with_default_parameters_does_not_error/,/end/ s:^:#:' test/test_readline.rb || die
+}