summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-10-24 22:27:56 +0000
committerNaohiro Aota <naota@gentoo.org>2012-10-24 22:27:56 +0000
commita0a9481027dd0b306172e8b9f10887dea16b2494 (patch)
treeb4f299b0306db3dfb0002664c6ab486d21f2d92e
parent(re-)masked pf-sources-3.6.{3,4} due to ext4 data loss regression, bug #439502 (diff)
downloadgentoo-2-a0a9481027dd0b306172e8b9f10887dea16b2494.tar.gz
gentoo-2-a0a9481027dd0b306172e8b9f10887dea16b2494.tar.bz2
gentoo-2-a0a9481027dd0b306172e8b9f10887dea16b2494.zip
Add patch to replace install usage. Add ~x86-fbsd. #303909
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
-rw-r--r--sci-libs/qrupdate/ChangeLog7
-rw-r--r--sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch23
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.2.ebuild7
3 files changed, 32 insertions, 5 deletions
diff --git a/sci-libs/qrupdate/ChangeLog b/sci-libs/qrupdate/ChangeLog
index 53bc740b2974..9aa0e8d83ea3 100644
--- a/sci-libs/qrupdate/ChangeLog
+++ b/sci-libs/qrupdate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/qrupdate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.26 2012/10/16 20:02:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.27 2012/10/24 22:27:56 naota Exp $
+
+ 24 Oct 2012; <naota@gentoo.org> +files/qrupdate-1.1.2-install.patch,
+ qrupdate-1.1.2.ebuild:
+ Add patch to replace install usage. Add ~x86-fbsd. #303909
16 Oct 2012; Justin Lecher <jlec@gentoo.org> qrupdate-1.1.0.ebuild,
qrupdate-1.1.1.ebuild, qrupdate-1.1.2.ebuild:
@@ -107,4 +111,3 @@
11 Sep 2009; Markus Dittrich <markusle@gentoo.org> +qrupdate-1.0.1.ebuild,
+files/qrupdate-1.0.1-makefile.patch, +metadata.xml:
Initial import into portage tree (fixes bug #282203).
-
diff --git a/sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch b/sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch
new file mode 100644
index 000000000000..0eee49ae68f4
--- /dev/null
+++ b/sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch
@@ -0,0 +1,23 @@
+--- src/Makefile.orig 2010-02-07 15:58:01 +0100
++++ src/Makefile 2010-02-07 16:02:18 +0100
+@@ -65,14 +65,17 @@
+ install-shlib: ../libqrupdate$(SOEXT) install-lib$(SOEXT)
+
+ install-lib.so:
+- install -D -m644 ../libqrupdate.so $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.so.$(VERSION)
++ install -d $(DESTDIR)$(PREFIX)/$(LIBDIR)/
++ install -m644 ../libqrupdate.so $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.so.$(VERSION)
+ ln -s libqrupdate.so.$(VERSION) $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.so.$(MAJOR)
+ ln -s libqrupdate.so.$(VERSION) $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.so
+
+ install-lib.dylib:
+- install -D -m644 ../libqrupdate.dylib $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.$(VERSION).dylib
++ install -d $(DESTDIR)$(PREFIX)/$(LIBDIR)/
++ install -m644 ../libqrupdate.dylib $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.$(VERSION).dylib
+ ln -s libqrupdate.$(VERSION).dylib $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.$(MAJOR).dylib
+ ln -s libqrupdate.$(VERSION).dylib $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.dylib
+
+ install-staticlib: ../libqrupdate.a
+- install -D -m644 ../libqrupdate.a $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.a
++ install -d $(DESTDIR)$(PREFIX)/$(LIBDIR)/
++ install -m644 ../libqrupdate.a $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.a
diff --git a/sci-libs/qrupdate/qrupdate-1.1.2.ebuild b/sci-libs/qrupdate/qrupdate-1.1.2.ebuild
index f51d5dc854e0..9c088b79b11b 100644
--- a/sci-libs/qrupdate/qrupdate-1.1.2.ebuild
+++ b/sci-libs/qrupdate/qrupdate-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.2.ebuild,v 1.3 2012/10/16 20:02:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.2.ebuild,v 1.4 2012/10/24 22:27:55 naota Exp $
EAPI=4
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~amd64-linux"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos"
IUSE="static-libs"
RDEPEND="virtual/lapack"
@@ -20,7 +20,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.1.1-Makefiles.patch
+ epatch "${FILESDIR}"/${PN}-1.1.1-Makefiles.patch \
+ "${FILESDIR}"/${PN}-1.1.2-install.patch
sed -i Makeconf \
-e "s:gfortran:$(tc-getFC):g" \
-e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \