summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-09-01 00:08:16 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-09-01 00:08:16 +0000
commita033ade39af93cd5002696d7e854f2c9b37672a7 (patch)
tree76edc5227aa47e53a9691a251adc2151b4411db3
parentRemove old (diff)
downloadgentoo-2-a033ade39af93cd5002696d7e854f2c9b37672a7.tar.gz
gentoo-2-a033ade39af93cd5002696d7e854f2c9b37672a7.tar.bz2
gentoo-2-a033ade39af93cd5002696d7e854f2c9b37672a7.zip
fix as-needed
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
-rw-r--r--games-strategy/megaglest/ChangeLog6
-rw-r--r--games-strategy/megaglest/files/megaglest-3.6.0.3-as-needed.patch30
-rw-r--r--games-strategy/megaglest/megaglest-3.6.0.3.ebuild7
3 files changed, 37 insertions, 6 deletions
diff --git a/games-strategy/megaglest/ChangeLog b/games-strategy/megaglest/ChangeLog
index 7828b8223a88..266c817c3896 100644
--- a/games-strategy/megaglest/ChangeLog
+++ b/games-strategy/megaglest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/megaglest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest/ChangeLog,v 1.1 2012/08/19 21:15:08 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest/ChangeLog,v 1.2 2012/09/01 00:08:16 hasufell Exp $
+
+ 01 Sep 2012; Julian Ospald <hasufell@gentoo.org> megaglest-3.6.0.3.ebuild,
+ +files/megaglest-3.6.0.3-as-needed.patch:
+ fix as-needed
*megaglest-3.6.0.3 (19 Aug 2012)
diff --git a/games-strategy/megaglest/files/megaglest-3.6.0.3-as-needed.patch b/games-strategy/megaglest/files/megaglest-3.6.0.3-as-needed.patch
new file mode 100644
index 000000000000..4dc5fd10b3fd
--- /dev/null
+++ b/games-strategy/megaglest/files/megaglest-3.6.0.3-as-needed.patch
@@ -0,0 +1,30 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Aug 31 23:45:34 UTC 2012
+Subject: fix as-needed
+
+reorder linker line (curl after libircclient)
+
+--- source/shared_lib/CMakeLists.txt
++++ source/shared_lib/CMakeLists.txt
+@@ -47,9 +47,6 @@
+
+ FIND_PACKAGE(CURL REQUIRED)
+ INCLUDE_DIRECTORIES(${CURL_INCLUDE_DIRS})
+- IF(UNIX)
+- SET(EXTERNAL_LIBS ${EXTERNAL_LIBS} ${CURL_LIBRARIES})
+- ENDIF()
+ # check libcurl version #
+ IF(WIN32)
+ file (READ ${PROJECT_SOURCE_DIR}${CURL_INCLUDE_DIR}/curl/curlver.h CURL_VERSION_H_CONTENTS)
+@@ -293,6 +290,11 @@
+ SET(EXTERNAL_LIBS ${EXTERNAL_LIBS} ${IRCCLIENT_LIBRARY})
+ endif()
+
++ # fix linking order, curl after libircclient
++ IF(UNIX)
++ SET(EXTERNAL_LIBS ${EXTERNAL_LIBS} ${CURL_LIBRARIES})
++ ENDIF()
++
+ set(CMAKE_REQUIRED_INCLUDES "${IRCCLIENT_INCLUDE_DIR}")
+ set(CMAKE_REQUIRED_LIBRARIES "${IRCCLIENT_LIBRARY}")
+ check_cxx_source_runs("
diff --git a/games-strategy/megaglest/megaglest-3.6.0.3.ebuild b/games-strategy/megaglest/megaglest-3.6.0.3.ebuild
index 3bf56bfe5de8..4fe885edb2d2 100644
--- a/games-strategy/megaglest/megaglest-3.6.0.3.ebuild
+++ b/games-strategy/megaglest/megaglest-3.6.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest/megaglest-3.6.0.3.ebuild,v 1.1 2012/08/19 21:15:08 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest/megaglest-3.6.0.3.ebuild,v 1.2 2012/09/01 00:08:16 hasufell Exp $
EAPI=4
inherit eutils flag-o-matic cmake-utils wxwidgets gnome2-utils games
@@ -63,7 +63,7 @@ src_prepare() {
need-wxwidgets unicode
fi
- epatch "${FILESDIR}"/${P}-{static-build,build}.patch
+ epatch "${FILESDIR}"/${P}-{static-build,build,as-needed}.patch
}
src_configure() {
@@ -102,9 +102,6 @@ src_configure() {
# support CMAKE_BUILD_TYPE=Gentoo
append-cppflags '-DCUSTOM_DATA_INSTALL_PATH=\\\"'${GAMES_DATADIR}/${PN}/'\\\"'
- # as-needed is broken for ld.bfd here
- # ld.gold works either way
- append-ldflags $(no-as-needed)
cmake-utils_src_configure
}