summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-01 04:22:55 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-01 04:22:55 +0000
commit9e7baf00f31bd32620b4fcae0a9fe5bdc2e03b99 (patch)
tree5ce59ad2470a4184c8a78d9df73c1584fc8cfee5
parentVersion bump. (diff)
downloadgentoo-2-9e7baf00f31bd32620b4fcae0a9fe5bdc2e03b99.tar.gz
gentoo-2-9e7baf00f31bd32620b4fcae0a9fe5bdc2e03b99.tar.bz2
gentoo-2-9e7baf00f31bd32620b4fcae0a9fe5bdc2e03b99.zip
Do not install nscd config files when USE=-nscd #463786 by Harris Landgarten.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/files/eblits/src_install.eblit20
2 files changed, 18 insertions, 8 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 60b39bcfa1d2..ab6e3cfbe6ec 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,5 +1,9 @@
# ChangeLog for sys-libs/glibc
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.927 2013/03/28 05:03:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.928 2013/04/01 04:22:55 vapier Exp $
+
+ 01 Apr 2013; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_install.eblit:
+ Do not install nscd config files when USE=-nscd #463786 by Harris Landgarten.
28 Mar 2013; Mike Frysinger <vapier@gentoo.org> glibc-2.17.ebuild:
Move to ~arch.
diff --git a/sys-libs/glibc/files/eblits/src_install.eblit b/sys-libs/glibc/files/eblits/src_install.eblit
index ed6d84c1fc45..a65489b0191f 100644
--- a/sys-libs/glibc/files/eblits/src_install.eblit
+++ b/sys-libs/glibc/files/eblits/src_install.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install.eblit,v 1.26 2013/03/28 05:03:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install.eblit,v 1.27 2013/04/01 04:22:55 vapier Exp $
toolchain-glibc_src_install() {
local GBUILDDIR
@@ -171,13 +171,19 @@ toolchain-glibc_src_install() {
insinto /etc
doins nscd/nscd.conf posix/gai.conf nss/nsswitch.conf || die
doins "${WORKDIR}"/extra/etc/*.conf || die
- doinitd "${WORKDIR}"/extra/etc/nscd || die
- local nscd_args=(
- -e "s:@PIDFILE@:$(strings "${D}"/usr/sbin/nscd | grep nscd.pid):"
- )
- version_is_at_least 2.16 || nscd_args+=( -e 's: --foreground : :' )
- sed -i "${nscd_args[@]}" "${D}"/etc/init.d/nscd
+ if ! in_iuse nscd || use nscd ; then
+ doinitd "${WORKDIR}"/extra/etc/nscd || die
+
+ local nscd_args=(
+ -e "s:@PIDFILE@:$(strings "${D}"/usr/sbin/nscd | grep nscd.pid):"
+ )
+ version_is_at_least 2.16 || nscd_args+=( -e 's: --foreground : :' )
+ sed -i "${nscd_args[@]}" "${D}"/etc/init.d/nscd
+ else
+ # Do this since extra/etc/*.conf above might have nscd.conf.
+ rm -f "${D}"/etc/nscd.conf
+ fi
echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00glibc
doenvd "${T}"/00glibc || die