summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-12 18:59:03 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-12 18:59:03 +0000
commit9dc7a70233bbcc9cfb67626354102aae4006a17b (patch)
tree5108b92cc86940a78e9ec9b261351b97d43f1aff
parentadded two patches that came from redhat, one adds the uclibc tuple for config... (diff)
downloadgentoo-2-9dc7a70233bbcc9cfb67626354102aae4006a17b.tar.gz
gentoo-2-9dc7a70233bbcc9cfb67626354102aae4006a17b.tar.bz2
gentoo-2-9dc7a70233bbcc9cfb67626354102aae4006a17b.zip
Added gcc-3.4 fixes to close bug #53655
-rw-r--r--app-pda/gnome-pilot/ChangeLog6
-rw-r--r--app-pda/gnome-pilot/files/gnome-pilot-2.0.10-gcc34.patch93
-rw-r--r--app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild7
3 files changed, 103 insertions, 3 deletions
diff --git a/app-pda/gnome-pilot/ChangeLog b/app-pda/gnome-pilot/ChangeLog
index 6ecbaa2945ae..94191623d13d 100644
--- a/app-pda/gnome-pilot/ChangeLog
+++ b/app-pda/gnome-pilot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/gnome-pilot
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.12 2004/06/27 02:13:33 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.13 2004/07/12 18:59:03 eradicator Exp $
+
+ 12 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/gnome-pilot-2.0.10-gcc34.patch:
+ Added gcc-3.4 fixes to close bug #53655
27 Jun 2004; Alastair Tse <liquidx@gentoo.org>
+files/gnome-pilot-2.0.10-clie.patch:
diff --git a/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-gcc34.patch b/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-gcc34.patch
new file mode 100644
index 000000000000..dd9c6809befe
--- /dev/null
+++ b/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-gcc34.patch
@@ -0,0 +1,93 @@
+diff -Naur gnome-pilot-2.0.10.orig/capplet/gnome-pilot-capplet.c gnome-pilot-2.0.10/capplet/gnome-pilot-capplet.c
+--- gnome-pilot-2.0.10.orig/capplet/gnome-pilot-capplet.c 2003-05-02 06:55:39.000000000 -0700
++++ gnome-pilot-2.0.10/capplet/gnome-pilot-capplet.c 2004-06-11 09:15:37.394071424 -0700
+@@ -171,18 +171,16 @@
+ priv->xml = glade_xml_new (GLADEDATADIR "/gpilotd-capplet.glade", "CappletMain", NULL);
+ if (!priv->xml) {
+ g_message ("gnome-pilot-capplet init(): Could not load the Glade XML file!");
+- goto error;
++ return;
+ }
+
+ if (!get_widgets (gpcap)) {
+ g_message ("gnome-pilot-capplet init(): Could not find all widgets in the XML file!");
+- goto error;
++ return;
+ }
+
+ fill_widgets (gpcap);
+ init_widgets (gpcap);
+-
+- error:
+ }
+
+ GnomePilotCapplet *
+diff -Naur gnome-pilot-2.0.10.orig/capplet/gnome-pilot-cdialog.c gnome-pilot-2.0.10/capplet/gnome-pilot-cdialog.c
+--- gnome-pilot-2.0.10.orig/capplet/gnome-pilot-cdialog.c 2003-04-22 13:51:06.000000000 -0700
++++ gnome-pilot-2.0.10/capplet/gnome-pilot-cdialog.c 2004-06-11 09:15:37.413068536 -0700
+@@ -112,17 +112,16 @@
+ priv->xml = glade_xml_new (GLADEDATADIR "/gpilotd-capplet.glade", "ConduitSettings", NULL);
+ if (!priv->xml) {
+ g_message ("gnome-pilot-cdialog init(): Could not load the Glade XML file!");
+- goto error;
++ return;
+ }
+
+ if (!get_widgets (gpcd)) {
+ g_message ("gnome-pilot-cdialog init(): Could not find all widgets in the XML file!");
+- goto error;
++ return;
+ }
+
+ gnome_dialog_close_hides (GNOME_DIALOG (priv->dialog), TRUE);
+
+- error:
+ }
+
+
+diff -Naur gnome-pilot-2.0.10.orig/capplet/gnome-pilot-ddialog.c gnome-pilot-2.0.10/capplet/gnome-pilot-ddialog.c
+--- gnome-pilot-2.0.10.orig/capplet/gnome-pilot-ddialog.c 2003-04-22 14:12:36.000000000 -0700
++++ gnome-pilot-2.0.10/capplet/gnome-pilot-ddialog.c 2004-06-11 09:15:37.413068536 -0700
+@@ -114,15 +114,14 @@
+ priv->xml = glade_xml_new (GLADEDATADIR "/gpilotd-capplet.glade", "DeviceSettings", NULL);
+ if (!priv->xml) {
+ g_message ("gnome-pilot-ddialog init(): Could not load the Glade XML file!");
+- goto error;
++ return;
+ }
+
+ if (!get_widgets (gpdd)) {
+ g_message ("gnome-pilot-ddialog init(): Could not find all widgets in the XML file!");
+- goto error;
++ return;
+ }
+
+- error:
+ }
+
+
+diff -Naur gnome-pilot-2.0.10.orig/capplet/gnome-pilot-druid.c gnome-pilot-2.0.10/capplet/gnome-pilot-druid.c
+--- gnome-pilot-2.0.10.orig/capplet/gnome-pilot-druid.c 2003-05-13 10:29:59.000000000 -0700
++++ gnome-pilot-2.0.10/capplet/gnome-pilot-druid.c 2004-06-11 09:15:37.414068384 -0700
+@@ -168,19 +168,17 @@
+ priv->xml = glade_xml_new (GLADEDATADIR "/gpilotd-capplet.glade", NULL, NULL);
+ if (!priv->xml) {
+ g_message ("gnome-pilot-druid init(): Could not load the Glade XML file!");
+- goto error;
++ return;
+ }
+
+ if (!get_widgets (gpd)) {
+ g_message ("gnome-pilot-druid init(): Could not find all widgets in the XML file!");
+- goto error;
++ return;
+ }
+
+ map_widgets (gpd);
+ fill_widgets (gpd);
+ init_widgets (gpd);
+-
+- error:
+ }
+
+
diff --git a/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild b/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
index 6f63bfd2ffae..4d2e4c458e6b 100644
--- a/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
+++ b/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild,v 1.9 2004/06/27 02:13:33 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild,v 1.10 2004/07/12 18:59:03 eradicator Exp $
inherit gnome2 eutils
@@ -45,4 +45,7 @@ src_unpack() {
# http://bugs.gentoo.org/show_bug.cgi?id=52550 -- add new clie model
epatch ${FILESDIR}/${P}-clie.patch
-} \ No newline at end of file
+
+ # gcc-3.4 patches
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}