summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-03 14:54:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-03 14:54:56 +0000
commit9dbcd39b50e861922b0eecb8874b358fadf534dd (patch)
tree82cc7830c5e32fa759bee2da3d70cc13d11472eb
parentMarking xorg-server-1.5.3-r5 ppc64 stable for bug 251832 (diff)
downloadgentoo-2-9dbcd39b50e861922b0eecb8874b358fadf534dd.tar.gz
gentoo-2-9dbcd39b50e861922b0eecb8874b358fadf534dd.tar.bz2
gentoo-2-9dbcd39b50e861922b0eecb8874b358fadf534dd.zip
Gcc 4.3.3 compile fix, thanks to Magnus Granberg. Closes #259699
(Portage version: 2.2_rc28/cvs/Linux x86_64)
-rw-r--r--net-misc/pavuk/ChangeLog10
-rw-r--r--net-misc/pavuk/files/pavuk-0.9.34-gcc43.patch11
-rw-r--r--net-misc/pavuk/pavuk-0.9.34-r2.ebuild49
3 files changed, 68 insertions, 2 deletions
diff --git a/net-misc/pavuk/ChangeLog b/net-misc/pavuk/ChangeLog
index dc30518a7f67..acdcc70056bc 100644
--- a/net-misc/pavuk/ChangeLog
+++ b/net-misc/pavuk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/pavuk
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.32 2007/01/27 12:48:53 armin76 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.33 2009/04/03 14:54:56 patrick Exp $
+
+*pavuk-0.9.34-r2 (03 Apr 2009)
+
+ 03 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/pavuk-0.9.34-gcc43.patch, +pavuk-0.9.34-r2.ebuild:
+ Gcc 4.3.3 compile fix, thanks to Magnus Granberg. Closes #259699
27 Jan 2007; Raúl Porcel <armin76@gentoo.org> -pavuk-0.9.32.ebuild:
remove mozilla depending version
diff --git a/net-misc/pavuk/files/pavuk-0.9.34-gcc43.patch b/net-misc/pavuk/files/pavuk-0.9.34-gcc43.patch
new file mode 100644
index 000000000000..8f990ca1d2c6
--- /dev/null
+++ b/net-misc/pavuk/files/pavuk-0.9.34-gcc43.patch
@@ -0,0 +1,11 @@
+--- src/tools.c 2005-10-26 07:02:34.000000000 +0000
++++ src/tools.c 2009-03-05 01:57:03.000000000 +0000
+@@ -1723,7 +1723,7 @@
+ if(length < 0)
+ length = strlen(content);
+
+- if((fd = open(filename, O_WRONLY | O_BINARY | O_CREAT | O_TRUNC), 0644) < 0)
++ if((fd = open(filename, O_WRONLY | O_BINARY | O_CREAT | O_TRUNC, 0644), 0644) < 0)
+ {
+ xperror(filename);
+ return -1;
diff --git a/net-misc/pavuk/pavuk-0.9.34-r2.ebuild b/net-misc/pavuk/pavuk-0.9.34-r2.ebuild
new file mode 100644
index 000000000000..a8ad5e1af913
--- /dev/null
+++ b/net-misc/pavuk/pavuk-0.9.34-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.34-r2.ebuild,v 1.1 2009/04/03 14:54:56 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Web spider and website mirroring tool"
+HOMEPAGE="http://www.pavuk.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls ssl"
+
+DEPEND=">=sys-apps/sed-4
+ sys-devel/gettext
+ ssl? ( dev-libs/openssl )"
+
+RDEPEND="virtual/libintl
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-0.9.34-nls.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.9.34-gcc43.patch
+}
+
+src_compile() {
+ econf \
+ --enable-threads \
+ --with-regex=auto \
+ --disable-socks \
+ --disable-gtk \
+ $(use_enable ssl) \
+ $(use_enable nls) \
+ || die "econf failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README CREDITS NEWS AUTHORS BUGS \
+ TODO MAILINGLIST ChangeLog wget-pavuk.HOWTO jsbind.txt \
+ pavuk_authinfo.sample pavukrc.sample
+}