summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-03-24 10:29:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-03-24 10:29:49 +0000
commit9ceb9ecb66b6df147e2f53c72f253081566011d6 (patch)
tree97fc90be488df8a7fd840e2b3fc82d73bb53d441
parentVersion bump. As this is newer than 1.6.2.1, it fixes the H323 observed by Ne... (diff)
downloadgentoo-2-9ceb9ecb66b6df147e2f53c72f253081566011d6.tar.gz
gentoo-2-9ceb9ecb66b6df147e2f53c72f253081566011d6.tar.bz2
gentoo-2-9ceb9ecb66b6df147e2f53c72f253081566011d6.zip
Use correct version on ebuild. Add patch for implicit pointer conversion. Bug #358797
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--dev-perl/Gtk2-Unique/ChangeLog7
-rw-r--r--dev-perl/Gtk2-Unique/Gtk2-Unique-0.05.ebuild (renamed from dev-perl/Gtk2-Unique/Gtk2-Unique-0.50.0.ebuild)8
-rw-r--r--dev-perl/Gtk2-Unique/files/Gtk2-Unique-0.05-implicit-pointer.patch13
3 files changed, 25 insertions, 3 deletions
diff --git a/dev-perl/Gtk2-Unique/ChangeLog b/dev-perl/Gtk2-Unique/ChangeLog
index adbe86ec0953..1d0d8733a032 100644
--- a/dev-perl/Gtk2-Unique/ChangeLog
+++ b/dev-perl/Gtk2-Unique/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Gtk2-Unique
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Unique/ChangeLog,v 1.3 2011/03/21 21:56:14 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Unique/ChangeLog,v 1.4 2011/03/24 10:29:49 hwoarang Exp $
+
+ 24 Mar 2011; Markos Chandras <hwoarang@gentoo.org> +Gtk2-Unique-0.05.ebuild,
+ +files/Gtk2-Unique-0.05-implicit-pointer.patch, -Gtk2-Unique-0.50.0.ebuild:
+ Use correct version on ebuild. Add patch for implicit pointer conversion. Bug
+ #358797
21 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
Gtk2-Unique-0.50.0.ebuild:
diff --git a/dev-perl/Gtk2-Unique/Gtk2-Unique-0.50.0.ebuild b/dev-perl/Gtk2-Unique/Gtk2-Unique-0.05.ebuild
index 79575f1fd242..f1bdca8a5253 100644
--- a/dev-perl/Gtk2-Unique/Gtk2-Unique-0.50.0.ebuild
+++ b/dev-perl/Gtk2-Unique/Gtk2-Unique-0.05.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Unique/Gtk2-Unique-0.50.0.ebuild,v 1.2 2011/03/21 21:56:14 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Unique/Gtk2-Unique-0.05.ebuild,v 1.3 2011/03/24 10:29:49 hwoarang Exp $
EAPI=3
MODULE_AUTHOR="POTYL"
MODULE_VERSION=0.05
-inherit perl-module
+inherit eutils perl-module
DESCRIPTION="Perl binding for C libunique library"
@@ -23,3 +23,7 @@ DEPEND="${RDEPEND}
dev-perl/extutils-depends
dev-perl/extutils-pkgconfig
"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-implicit-pointer.patch
+}
diff --git a/dev-perl/Gtk2-Unique/files/Gtk2-Unique-0.05-implicit-pointer.patch b/dev-perl/Gtk2-Unique/files/Gtk2-Unique-0.05-implicit-pointer.patch
new file mode 100644
index 000000000000..1df58449b8b4
--- /dev/null
+++ b/dev-perl/Gtk2-Unique/files/Gtk2-Unique-0.05-implicit-pointer.patch
@@ -0,0 +1,13 @@
+Index: Gtk2-Unique-0.05/xs/UniqueApp.xs
+===================================================================
+--- Gtk2-Unique-0.05.orig/xs/UniqueApp.xs
++++ Gtk2-Unique-0.05/xs/UniqueApp.xs
+@@ -1,6 +1,8 @@
+ #include "unique-perl.h"
+ #include <gperl_marshal.h>
+
++G_CONST_RETURN gchar * unique_command_to_string (UniqueApp *app, gint command);
++
+ static void
+ perl_unique_app_marshall_message_received (
+ GClosure *closure,