summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-12 16:22:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-12 16:22:01 +0000
commit9bee3662ae4eace6cb69f940e7a81416d00793b9 (patch)
treeaf1a5c18f6c2a7de6d1f398f0a832eca5f4009ab
parentFix documentation location (Bug #297969) (diff)
downloadgentoo-2-9bee3662ae4eace6cb69f940e7a81416d00793b9.tar.gz
gentoo-2-9bee3662ae4eace6cb69f940e7a81416d00793b9.tar.bz2
gentoo-2-9bee3662ae4eace6cb69f940e7a81416d00793b9.zip
Version bump and move to ruby-fakegem. Tests cannot be executed though.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
-rw-r--r--dev-ruby/rspec-rails/ChangeLog10
-rw-r--r--dev-ruby/rspec-rails/rspec-rails-1.3.0.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-ruby/rspec-rails/ChangeLog b/dev-ruby/rspec-rails/ChangeLog
index a5f1d2d3a8a2..e45e09dd5662 100644
--- a/dev-ruby/rspec-rails/ChangeLog
+++ b/dev-ruby/rspec-rails/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-rails
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/ChangeLog,v 1.20 2009/12/09 20:59:47 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/ChangeLog,v 1.21 2010/01/12 16:22:01 flameeyes Exp $
+
+*rspec-rails-1.3.0 (12 Jan 2010)
+
+ 12 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +rspec-rails-1.3.0.ebuild:
+ Version bump and move to ruby-fakegem. Tests cannot be executed though.
09 Dec 2009; Hans de Graaff <graaff@gentoo.org>
-rspec-rails-1.2.7.1.ebuild:
diff --git a/dev-ruby/rspec-rails/rspec-rails-1.3.0.ebuild b/dev-ruby/rspec-rails/rspec-rails-1.3.0.ebuild
new file mode 100644
index 000000000000..78a8655ea504
--- /dev/null
+++ b/dev-ruby/rspec-rails/rspec-rails-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/rspec-rails-1.3.0.ebuild,v 1.1 2010/01/12 16:22:01 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+# would be spec, but it needs to be in the same filesystem tree as
+# rspec (and cannot use the install-reduced code), so we cannot run
+# them for now.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Contribute.rdoc History.rdoc README.rdoc Upgrade.rdoc TODO.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec's official Ruby on Rails plugin"
+HOMEPAGE="http://rspec.info/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-1.3.0 >=dev-ruby/rack-1.0.0"
+
+# Without this the whole Rakefile fails, so it's a general dependency
+# and not just a test dependency.
+ruby_add_bdepend doc dev-util/cucumber