summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-30 06:47:29 +0000
committerMark Wright <gienah@gentoo.org>2014-03-30 06:47:29 +0000
commit9b780432ce975153f2e443629edb97673918b466 (patch)
tree41b93a1ad2f763909c0344fe3014d8a08bf7309e
parentBump iwl3160-ucode to 22.24.8.0 - untested as I do not have access to this ha... (diff)
downloadgentoo-2-9b780432ce975153f2e443629edb97673918b466.tar.gz
gentoo-2-9b780432ce975153f2e443629edb97673918b466.tar.bz2
gentoo-2-9b780432ce975153f2e443629edb97673918b466.zip
Bump iwl7260-ucode to 22.24.8.0 - untested as I do not have access to this hardware.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--sys-firmware/iwl7260-ucode/ChangeLog8
-rw-r--r--sys-firmware/iwl7260-ucode/iwl7260-ucode-22.24.8.0.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-firmware/iwl7260-ucode/ChangeLog b/sys-firmware/iwl7260-ucode/ChangeLog
index a6742b9c6b03..fe51786de9bf 100644
--- a/sys-firmware/iwl7260-ucode/ChangeLog
+++ b/sys-firmware/iwl7260-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-firmware/iwl7260-ucode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/ChangeLog,v 1.4 2014/01/25 04:48:53 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/ChangeLog,v 1.5 2014/03/30 06:47:29 gienah Exp $
+
+*iwl7260-ucode-22.24.8.0 (30 Mar 2014)
+
+ 30 Mar 2014; Mark Wright <gienah@gentoo.org> +iwl7260-ucode-22.24.8.0.ebuild:
+ Bump iwl7260-ucode to 22.24.8.0 - untested as I do not have access to this
+ hardware.
*iwl7260-ucode-22.15.8.0-r1 (25 Jan 2014)
*iwl7260-ucode-22.1.7.0-r1 (25 Jan 2014)
diff --git a/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.24.8.0.ebuild b/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.24.8.0.ebuild
new file mode 100644
index 000000000000..f5e3782b4699
--- /dev/null
+++ b/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.24.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.24.8.0.ebuild,v 1.1 2014/03/30 06:47:29 gienah Exp $
+
+EAPI=5
+inherit linux-info
+
+DEV_N="${PN:3:4}"
+MY_PN="iwlwifi-${DEV_N}-ucode"
+
+DESCRIPTION="Firmware for Intel (R) Dual Band Wireless-AC ${DEV_N}"
+HOMEPAGE="http://wireless.kernel.org/en/users/Drivers/iwlwifi"
+SRC_URI="http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=${MY_PN}-${PV}.tgz -> ${P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=""
+RDEPEND="bluetooth? ( sys-firmware/iwl3160-7260-bt-ucode )
+ !sys-kernel/linux-firmware[-savedconfig]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+CONFIG_CHECK="IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
+
+pkg_pretend() {
+ if kernel_is lt 3 13 0; then
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ ewarn "This microcode image requires a kernel >= 3.13.0."
+ ewarn "For kernel versions < 3.10.13, you may install older SLOTS"
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/iwlwifi-${DEV_N}-8.ucode"
+ dodoc README*
+}