summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-03-06 16:55:36 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-03-06 16:55:36 +0000
commit9aeca20e84617de4be62deb08adf36080598ba19 (patch)
tree5089a35a780ff99471b59f84f4deb79cd7ef6b76
parentalpha/arm/ia64/s390/sh/x86 stable wrt #258049 (diff)
downloadgentoo-2-9aeca20e84617de4be62deb08adf36080598ba19.tar.gz
gentoo-2-9aeca20e84617de4be62deb08adf36080598ba19.tar.bz2
gentoo-2-9aeca20e84617de4be62deb08adf36080598ba19.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux ia64)
-rw-r--r--www-client/seamonkey-bin/ChangeLog8
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-2.0_alpha3.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 3f8a415eeb44..304348433219 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.59 2009/02/04 11:00:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.60 2009/03/06 16:55:36 armin76 Exp $
+
+*seamonkey-bin-2.0_alpha3 (06 Mar 2009)
+
+ 06 Mar 2009; Raúl Porcel <armin76@gentoo.org>
+ +seamonkey-bin-2.0_alpha3.ebuild:
+ Version bump
*seamonkey-bin-2.0_alpha2 (04 Feb 2009)
diff --git a/www-client/seamonkey-bin/seamonkey-bin-2.0_alpha3.ebuild b/www-client/seamonkey-bin/seamonkey-bin-2.0_alpha3.ebuild
new file mode 100644
index 000000000000..281083a10ab3
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-2.0_alpha3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.0_alpha3.ebuild,v 1.1 2009/03/06 16:55:36 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+MY_PV="${PV/_alpha/a}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${MY_PV}/seamonkey-${MY_PV}.en-US.linux-i686.tar.bz2"
+HOMEPAGE="http://www.seamonkey-project.org/"
+RESTRICT="strip"
+QA_EXECSTACK="opt/seamonkey/*"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/dbus-glib
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ >=media-libs/alsa-lib-1.0.16
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ >=app-emulation/emul-linux-x86-soundlibs-20080418
+ app-emulation/emul-linux-x86-compat
+ )"
+
+S="${WORKDIR}/seamonkey"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
+
+ # Create /usr/bin/seamonkey-bin
+ dodir /usr/bin/
+ cat <<EOF >"${D}"/usr/bin/seamonkey-bin
+#!/bin/sh
+unset LD_PRELOAD
+exec /opt/seamonkey/seamonkey "\$@"
+EOF
+ fperms 0755 /usr/bin/seamonkey-bin
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}/icon/${PN}.png"
+ domenu "${FILESDIR}/icon/${PN}.desktop"
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}