summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-08-21 10:27:33 +0000
committerUlrich Müller <ulm@gentoo.org>2011-08-21 10:27:33 +0000
commit9aa377bb72b0fd25d8c30d05c0e7718f282424f5 (patch)
tree26f241c05b46fd522e0a03d8279a656ddaaf24b2
parentStarting with version 4.2, net-libs/libfwbuilder is integrated (diff)
downloadgentoo-2-9aa377bb72b0fd25d8c30d05c0e7718f282424f5.tar.gz
gentoo-2-9aa377bb72b0fd25d8c30d05c0e7718f282424f5.tar.bz2
gentoo-2-9aa377bb72b0fd25d8c30d05c0e7718f282424f5.zip
Version bump. Snapshot of version maintained in Linux git tree.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--app-editors/uemacs-pk/ChangeLog11
-rw-r--r--app-editors/uemacs-pk/files/uemacs-pk-4.0.15_p20101216-gentoo.patch26
-rw-r--r--app-editors/uemacs-pk/uemacs-pk-4.0.15_p20101216.ebuild39
3 files changed, 74 insertions, 2 deletions
diff --git a/app-editors/uemacs-pk/ChangeLog b/app-editors/uemacs-pk/ChangeLog
index 25fca4225790..1ea33d21b1f4 100644
--- a/app-editors/uemacs-pk/ChangeLog
+++ b/app-editors/uemacs-pk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/uemacs-pk
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/uemacs-pk/ChangeLog,v 1.6 2010/09/02 14:44:07 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/uemacs-pk/ChangeLog,v 1.7 2011/08/21 10:27:33 ulm Exp $
+
+*uemacs-pk-4.0.15_p20101216 (21 Aug 2011)
+
+ 21 Aug 2011; Ulrich Mueller <ulm@gentoo.org>
+ +uemacs-pk-4.0.15_p20101216.ebuild,
+ +files/uemacs-pk-4.0.15_p20101216-gentoo.patch:
+ Version bump. Snapshot of version maintained in Linux git tree.
02 Sep 2010; Christian Faulhammer <fauli@gentoo.org>
uemacs-pk-4.0.18.ebuild:
diff --git a/app-editors/uemacs-pk/files/uemacs-pk-4.0.15_p20101216-gentoo.patch b/app-editors/uemacs-pk/files/uemacs-pk-4.0.15_p20101216-gentoo.patch
new file mode 100644
index 000000000000..35f3c98febd6
--- /dev/null
+++ b/app-editors/uemacs-pk/files/uemacs-pk-4.0.15_p20101216-gentoo.patch
@@ -0,0 +1,26 @@
+--- uemacs-orig/Makefile
++++ uemacs/Makefile
+@@ -56,7 +56,7 @@
+
+ $(PROGRAM): $(OBJ)
+ $(E) " LINK " $@
+- $(Q) $(CC) $(DEFINES) -o $@ $(OBJ) $(LIBS)
++ $(Q) $(CC) $(LDFLAGS) $(DEFINES) -o $@ $(OBJ) $(LIBS)
+
+ SPARSE=sparse
+ SPARSE_FLAGS=-D__LITTLE_ENDIAN__ -D__x86_64__ -D__linux__ -D__unix__
+--- uemacs-orig/epath.h
++++ uemacs/epath.h
+@@ -25,10 +25,8 @@
+ #if V7 | BSD | USG
+ {
+ ".emacsrc", "emacs.hlp",
+-#if PKCODE
+- "/usr/global/lib/", "/usr/local/bin/", "/usr/local/lib/",
+-#endif
+-"/usr/local/", "/usr/lib/", ""};
++ "/etc/uemacs-pk/", "/usr/share/uemacs-pk/", ""
++};
+ #endif
+
+ #if VMS
diff --git a/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20101216.ebuild b/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20101216.ebuild
new file mode 100644
index 000000000000..b8b4913d5a14
--- /dev/null
+++ b/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20101216.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20101216.ebuild,v 1.1 2011/08/21 10:27:33 ulm Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="uEmacs/PK is an enhanced version of MicroEMACS"
+HOMEPAGE="http://git.kernel.org/?p=editors/uemacs/uemacs.git;a=summary
+ ftp://ftp.cs.helsinki.fi/pub/Software/Local/uEmacs-PK"
+# snapshot from git repo
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/uemacs-${PV}.tar.bz2"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/uemacs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin em
+ insinto /usr/share/${PN}
+ doins emacs.hlp
+ newins emacs.rc .emacsrc
+ dodoc README readme.39e emacs.ps UTF-8-demo.txt
+}