summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-03 07:57:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-03 07:57:56 +0000
commit9a9b48196ff49deccf415a339d27db1ac94f0d43 (patch)
treebf1e44e29f7f2d541a2870eea60600dc1d1f6018
parentBump (diff)
downloadgentoo-2-9a9b48196ff49deccf415a339d27db1ac94f0d43.tar.gz
gentoo-2-9a9b48196ff49deccf415a339d27db1ac94f0d43.tar.bz2
gentoo-2-9a9b48196ff49deccf415a339d27db1ac94f0d43.zip
Bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/envisage/ChangeLog9
-rw-r--r--dev-python/envisage/envisage-4.3.0.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-python/envisage/ChangeLog b/dev-python/envisage/ChangeLog
index d59b1778e8cc..784daa0705e9 100644
--- a/dev-python/envisage/ChangeLog
+++ b/dev-python/envisage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/envisage
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/envisage/ChangeLog,v 1.7 2012/12/06 17:32:37 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisage/ChangeLog,v 1.8 2013/04/03 07:57:56 patrick Exp $
+
+*envisage-4.3.0 (03 Apr 2013)
+
+ 03 Apr 2013; Patrick Lauer <patrick@gentoo.org> +envisage-4.3.0.ebuild:
+ Bump
06 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> envisage-4.2.0.ebuild:
Keyword amd64-linux and x86-linux
diff --git a/dev-python/envisage/envisage-4.3.0.ebuild b/dev-python/envisage/envisage-4.3.0.ebuild
new file mode 100644
index 000000000000..55bf19d3e2a0
--- /dev/null
+++ b/dev-python/envisage/envisage-4.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisage/envisage-4.3.0.ebuild,v 1.1 2013/04/03 07:57:56 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Extensible application framework"
+HOMEPAGE="http://code.enthought.com/projects/envisage/ http://pypi.python.org/pypi/envisage"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/traits-4"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ >=dev-python/traits-4
+ dev-python/apptools
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake || die
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}