summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-01-31 07:04:07 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-01-31 07:04:07 +0000
commit99573aec7519844ca1882e97f109d22f6e0753d8 (patch)
treece4d8050a29e501a2a25de89c89f9bd0a332556e
parentClean up. (diff)
downloadgentoo-2-99573aec7519844ca1882e97f109d22f6e0753d8.tar.gz
gentoo-2-99573aec7519844ca1882e97f109d22f6e0753d8.tar.bz2
gentoo-2-99573aec7519844ca1882e97f109d22f6e0753d8.zip
Clean up.
(Portage version: 2.1.4)
-rw-r--r--sys-fs/unionfs/ChangeLog13
-rw-r--r--sys-fs/unionfs/files/1.3-64bit_compile_fix.diff48
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.0.143
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.1.4-r23
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.1.53
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.23
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.33
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.43
-rw-r--r--sys-fs/unionfs/files/unionfs-1.0.13-amd64.patch21
-rw-r--r--sys-fs/unionfs/files/unionfs-1.0.14-remove_call_to_ctags.patch11
-rw-r--r--sys-fs/unionfs/files/unionfs-1.1.3-15-kernel_mutex.patch318
-rw-r--r--sys-fs/unionfs/unionfs-1.0.14.ebuild48
-rw-r--r--sys-fs/unionfs/unionfs-1.1.4-r2.ebuild56
-rw-r--r--sys-fs/unionfs/unionfs-1.1.5.ebuild69
-rw-r--r--sys-fs/unionfs/unionfs-1.2.ebuild69
-rw-r--r--sys-fs/unionfs/unionfs-1.3.ebuild76
-rw-r--r--sys-fs/unionfs/unionfs-1.4.ebuild75
17 files changed, 11 insertions, 811 deletions
diff --git a/sys-fs/unionfs/ChangeLog b/sys-fs/unionfs/ChangeLog
index 35f91c2279b1..9f144a02c5f0 100644
--- a/sys-fs/unionfs/ChangeLog
+++ b/sys-fs/unionfs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-fs/unionfs
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.32 2007/05/12 02:22:44 dsd Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.33 2008/01/31 07:04:07 dberkholz Exp $
+
+ 31 Jan 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ -files/unionfs-1.0.13-amd64.patch,
+ -files/unionfs-1.0.14-remove_call_to_ctags.patch,
+ -files/unionfs-1.1.3-15-kernel_mutex.patch,
+ -files/1.3-64bit_compile_fix.diff, -unionfs-1.0.14.ebuild,
+ -unionfs-1.1.4-r2.ebuild, -unionfs-1.1.5.ebuild, -unionfs-1.2.ebuild,
+ -unionfs-1.3.ebuild, -unionfs-1.4.ebuild:
+ Clean up.
12 May 2007; Daniel Drake <dsd@gentoo.org> metadata.xml:
Move from kernel to kernel-misc herd
diff --git a/sys-fs/unionfs/files/1.3-64bit_compile_fix.diff b/sys-fs/unionfs/files/1.3-64bit_compile_fix.diff
deleted file mode 100644
index 8f8870ab0ba2..000000000000
--- a/sys-fs/unionfs/files/1.3-64bit_compile_fix.diff
+++ /dev/null
@@ -1,48 +0,0 @@
-Index: super.c
-===================================================================
-RCS file: /home/cvs/unionfs/unionfs/super.c,v
-retrieving revision 1.98
-diff -u -p -r1.98 super.c
---- super.c 5 Aug 2006 01:28:46 -0000 1.98
-+++ super.c 10 Aug 2006 01:01:10 -0000
-@@ -684,18 +684,22 @@ enum {
- static void do_decode(__u32 * fh, struct dentry **hidden_root,
- ino_t * hidden_ino, ino_t * hidden_parent_ino)
- {
-- *hidden_root = (void *)fh[FhHRoot2];
-+ unsigned long root;
-+
-+ root = fh[FhHRoot2];
- *hidden_ino = fh[FhHIno2];
- *hidden_parent_ino = fh[FhHPIno2];
- #if BITS_PER_LONG == 64
-- *hidden_root |= fh[FhHRoot1] << 32;
-- *hidden_ino |= fh[FhHIno1] << 32;
-- *hidden_parent_ino |= fh[FhHPIno1] << 32;
-+ root |= ((unsigned long)fh[FhHRoot1]) << 32;
-+ *hidden_ino |= ((unsigned long) fh[FhHIno1]) << 32;
-+ *hidden_parent_ino |= ((unsigned long) fh[FhHPIno1]) << 32;
- #elif BITS_PER_LONG == 32
- /* ok */
- #else
- #error unknown size
- #endif
-+
-+ *hidden_root = (struct dentry*) root;
- }
-
- static int unionfs_encode_fh(struct dentry *dentry, __u32 * fh, int *max_len,
-@@ -739,11 +743,11 @@ static int unionfs_encode_fh(struct dent
- unlock_dentry(sb->s_root);
- h_ino = itohi_index(dentry->d_inode, bindex)->i_ino;
- hp_ino = parent_ino(dtohd(dentry));
-- fh[FhHRoot2] = (__u32) h_root;
-+ fh[FhHRoot2] = (unsigned long) h_root;
- fh[FhHIno2] = h_ino;
- fh[FhHPIno2] = hp_ino;
- #if BITS_PER_LONG == 64
-- fh[FhHRoot1] = h_root >> 32;
-+ fh[FhHRoot1] = ((unsigned long) h_root) >> 32;
- fh[FhHIno1] = h_ino >> 32;
- fh[FhHPIno1] = hp_ino >> 32;
- #endif
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.0.14 b/sys-fs/unionfs/files/digest-unionfs-1.0.14
deleted file mode 100644
index 95b602f75a29..000000000000
--- a/sys-fs/unionfs/files/digest-unionfs-1.0.14
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6b6e1a8b13b9e605462035fa6621ed3b unionfs-1.0.14.tar.gz 142322
-RMD160 2d033d4508fb690b97113b1acf6c56ccef5c1014 unionfs-1.0.14.tar.gz 142322
-SHA256 bca0936bbd0ed4c28047289bff745cefc5babc54f209bed0fe0a211c7eda468d unionfs-1.0.14.tar.gz 142322
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.1.4-r2 b/sys-fs/unionfs/files/digest-unionfs-1.1.4-r2
deleted file mode 100644
index 52a7af20ae76..000000000000
--- a/sys-fs/unionfs/files/digest-unionfs-1.1.4-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4b0a5393f6a41a24555c2cd30a689b2c unionfs-1.1.4.tar.gz 152081
-RMD160 cb1e94ee12839fed619c33253c1b24d0da5c7fbb unionfs-1.1.4.tar.gz 152081
-SHA256 bd6111ff6757cf53860f09ddbce7a87dd7f495541e4e1aada4576970687e0af9 unionfs-1.1.4.tar.gz 152081
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.1.5 b/sys-fs/unionfs/files/digest-unionfs-1.1.5
deleted file mode 100644
index 563992a60696..000000000000
--- a/sys-fs/unionfs/files/digest-unionfs-1.1.5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 8f3bc81887ec6c9b4e103f320c7c42b3 unionfs-1.1.5.tar.gz 153220
-RMD160 892147d454685e0a1a625a6c127d195e3b71c2fd unionfs-1.1.5.tar.gz 153220
-SHA256 3b0afcf17a99f0a2e8ee0cb2a27c3f9f2a9f6cedf359965c186e91ca4d04c28a unionfs-1.1.5.tar.gz 153220
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.2 b/sys-fs/unionfs/files/digest-unionfs-1.2
deleted file mode 100644
index b7ed2372ba60..000000000000
--- a/sys-fs/unionfs/files/digest-unionfs-1.2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2a8c6ef320efc43af91074ab47046f09 unionfs-1.2.tar.gz 160392
-RMD160 610dd05ab56720ecb3a670a06a82935e489775b4 unionfs-1.2.tar.gz 160392
-SHA256 0b69c4dcd623cbd7416121da04c966395f2f4e24a0e2dd0cc841c2850ad63eb3 unionfs-1.2.tar.gz 160392
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.3 b/sys-fs/unionfs/files/digest-unionfs-1.3
deleted file mode 100644
index baf23836c47e..000000000000
--- a/sys-fs/unionfs/files/digest-unionfs-1.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 af5106f29fb0ddb12b028f522fa0463c unionfs-1.3.tar.gz 162909
-RMD160 40e437d626890e5ec2bcbe1a5caf35e3c4038805 unionfs-1.3.tar.gz 162909
-SHA256 1bf09c400fd7b3061eee0096ee0222434927d621b3bd35b01913f3e7d8079917 unionfs-1.3.tar.gz 162909
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.4 b/sys-fs/unionfs/files/digest-unionfs-1.4
deleted file mode 100644
index a63fd7848468..000000000000
--- a/sys-fs/unionfs/files/digest-unionfs-1.4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 38ed4d9e41c20cf398018928d2c62700 unionfs-1.4.tar.gz 164696
-RMD160 5a19ccfd6edf25f55c48ba1b820347572353c7ba unionfs-1.4.tar.gz 164696
-SHA256 3ff105782aba722b1f263e408fac638245d302a9c8d0f37ac09e5a80caf0126b unionfs-1.4.tar.gz 164696
diff --git a/sys-fs/unionfs/files/unionfs-1.0.13-amd64.patch b/sys-fs/unionfs/files/unionfs-1.0.13-amd64.patch
deleted file mode 100644
index f88b76e03164..000000000000
--- a/sys-fs/unionfs/files/unionfs-1.0.13-amd64.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur unionfs-1.0.13_orig/unionimap.c unionfs-1.0.13/unionimap.c
---- unionfs-1.0.13_orig/unionimap.c 2005-07-22 18:16:48.000000000 +0100
-+++ unionfs-1.0.13/unionimap.c 2005-08-17 18:01:10.000000000 +0100
-@@ -244,7 +244,7 @@
- "Lower-Level");
- while (read(file, (void *)&entry, sizeof(struct fmapent))) {
- fprintf(stdout, "%-11lu %-8d %-22llu\n", inode++,
-- entry.fsnum, entry.inode);
-+ entry.fsnum, (long long unsigned int) entry.inode);
- }
- }
- out:
-@@ -293,7 +293,7 @@
- unsigned long lowerlevel = 0;
- if (inode) {
- fprintf(stdout, "%-11lu %-22llu\n",
-- lowerlevel++, inode);
-+ lowerlevel++, (long long unsigned int) inode);
- }
- }
- }
diff --git a/sys-fs/unionfs/files/unionfs-1.0.14-remove_call_to_ctags.patch b/sys-fs/unionfs/files/unionfs-1.0.14-remove_call_to_ctags.patch
deleted file mode 100644
index ec2c28133152..000000000000
--- a/sys-fs/unionfs/files/unionfs-1.0.14-remove_call_to_ctags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- unionfs-1.0.14/Makefile.with-unneccessary-call-to-ctags 2005-09-27 20:04:53.975345632 +0200
-+++ unionfs-1.0.14/Makefile 2005-09-27 20:05:04.155797968 +0200
-@@ -48,7 +48,7 @@
-
- BINS := unionctl uniondbg unionimap
-
--all: readthereadme tags unionfs$(KERNELVERSION) ${BINS}
-+all: readthereadme unionfs$(KERNELVERSION) ${BINS}
-
- readthereadme:
- @echo "******************************************************************************"
diff --git a/sys-fs/unionfs/files/unionfs-1.1.3-15-kernel_mutex.patch b/sys-fs/unionfs/files/unionfs-1.1.3-15-kernel_mutex.patch
deleted file mode 100644
index dfcb0ce79fa1..000000000000
--- a/sys-fs/unionfs/files/unionfs-1.1.3-15-kernel_mutex.patch
+++ /dev/null
@@ -1,318 +0,0 @@
-diff -urN unionfs-1.1.3.old/copyup.c unionfs-1.1.3.new/copyup.c
---- unionfs-1.1.3.old/copyup.c 2006-02-20 19:47:06.000000000 -0300
-+++ unionfs-1.1.3.new/copyup.c 2006-04-03 22:35:26.413786991 -0300
-@@ -64,7 +64,11 @@
- name_list_orig = name_list;
- while (*name_list) {
- ssize_t size;
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&old_hidden_dentry->d_inode->i_mutex);
-+#else
- down(&old_hidden_dentry->d_inode->i_sem);
-+#endif
- err = security_inode_getxattr(old_hidden_dentry, name_list);
- if (err)
- size = err;
-@@ -73,7 +77,11 @@
- old_hidden_dentry->d_inode->i_op->
- getxattr(old_hidden_dentry, name_list, attr_value,
- XATTR_SIZE_MAX);
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&old_hidden_dentry->d_inode->i_mutex);
-+#else
- up(&old_hidden_dentry->d_inode->i_sem);
-+#endif
- if (size < 0) {
- err = size;
- goto out;
-@@ -84,7 +92,11 @@
- goto out;
- }
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&new_hidden_dentry->d_inode->i_mutex);
-+#else
- down(&new_hidden_dentry->d_inode->i_sem);
-+#endif
-
- err =
- security_inode_setxattr(old_hidden_dentry, name_list,
-@@ -101,7 +113,11 @@
- attr_value, size,
- 0);
- }
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&new_hidden_dentry->d_inode->i_mutex);
-+#else
- up(&new_hidden_dentry->d_inode->i_sem);
-+#endif
-
- if (err < 0)
- goto out;
-diff -urN unionfs-1.1.3.old/dentry.c unionfs-1.1.3.new/dentry.c
---- unionfs-1.1.3.old/dentry.c 2006-02-20 19:47:06.000000000 -0300
-+++ unionfs-1.1.3.new/dentry.c 2006-04-03 22:35:36.633885836 -0300
-@@ -108,7 +108,12 @@
- interpose_flag = INTERPOSE_REVAL_NEG;
- if (positive) {
- interpose_flag = INTERPOSE_REVAL;
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&dentry->d_inode->i_mutex);
-+#else
- down(&dentry->d_inode->i_sem);
-+#endif
-+
- bstart = ibstart(dentry->d_inode);
- bend = ibend(dentry->d_inode);
- if (bstart >= 0) {
-@@ -126,7 +131,11 @@
- itohi_ptr(dentry->d_inode) = NULL;
- ibstart(dentry->d_inode) = -1;
- ibend(dentry->d_inode) = -1;
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&dentry->d_inode->i_mutex);
-+#else
- up(&dentry->d_inode->i_sem);
-+#endif
- }
-
- result = unionfs_lookup_backend(dentry, interpose_flag);
-diff -urN unionfs-1.1.3.old/dirhelper.c unionfs-1.1.3.new/dirhelper.c
---- unionfs-1.1.3.old/dirhelper.c 2006-02-20 19:47:06.000000000 -0300
-+++ unionfs-1.1.3.new/dirhelper.c 2006-04-03 22:35:45.579217856 -0300
-@@ -78,11 +78,19 @@
- continue;
- }
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&hidden_dir_dentry->d_inode->i_mutex);
-+#else
- down(&hidden_dir_dentry->d_inode->i_sem);
-+#endif
- err =
- vfs_unlink(hidden_dir_dentry->d_inode,
- hidden_dentry);
-- up(&hidden_dir_dentry->d_inode->i_sem);
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&hidden_dir_dentry->d_inode->i_mutex);
-+#else
-+ down(&hidden_dir_dentry->d_inode->i_sem);
-+#endif
- DPUT(hidden_dentry);
-
- if (err && !IS_COPYUP_ERR(err))
-diff -urN unionfs-1.1.3.old/file.c unionfs-1.1.3.new/file.c
---- unionfs-1.1.3.old/file.c 2006-02-20 19:47:06.000000000 -0300
-+++ unionfs-1.1.3.new/file.c 2006-04-03 22:42:17.319560146 -0300
-@@ -264,10 +264,18 @@
- if (!hidden_file->f_op || !hidden_file->f_op->fsync)
- goto out;
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&hidden_file->f_dentry->d_inode->i_mutex);
-+#else
- down(&hidden_file->f_dentry->d_inode->i_sem);
-+#endif
- err = hidden_file->f_op->fsync(hidden_file, hidden_file->f_dentry,
- datasync);
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&hidden_file->f_dentry->d_inode->i_mutex);
-+#else
- up(&hidden_file->f_dentry->d_inode->i_sem);
-+#endif
-
- out:
- print_exit_status(err);
-diff -urN unionfs-1.1.3.old/inode.c unionfs-1.1.3.new/inode.c
---- unionfs-1.1.3.old/inode.c 2006-02-20 19:47:06.000000000 -0300
-+++ unionfs-1.1.3.new/inode.c 2006-04-03 22:42:17.346555567 -0300
-@@ -81,7 +81,11 @@
- struct dentry *hidden_dir_dentry;
- struct iattr newattrs;
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&whiteout_dentry->d_inode->i_mutex);
-+#else
- down(&whiteout_dentry->d_inode->i_sem);
-+#endif
- newattrs.ia_valid = ATTR_CTIME | ATTR_MODE | ATTR_ATIME
- | ATTR_MTIME | ATTR_UID | ATTR_GID | ATTR_FORCE
- | ATTR_KILL_SUID | ATTR_KILL_SGID;
-@@ -97,7 +101,11 @@
-
- err = notify_change(whiteout_dentry, &newattrs);
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&whiteout_dentry->d_inode->i_mutex);
-+#else
- up(&whiteout_dentry->d_inode->i_sem);
-+#endif
-
- if (err)
- printk(KERN_WARNING
-@@ -594,10 +602,20 @@
- err = PTR_ERR(whiteout_dentry);
- goto out;
- }
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&hidden_dentry->d_inode->i_mutex);
-+#else
- down(&hidden_dentry->d_inode->i_sem);
-+#endif
-+
- err = vfs_create(hidden_dentry->d_inode,
- whiteout_dentry, 0600, NULL);
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&hidden_dentry->d_inode->i_mutex);
-+#else
- up(&hidden_dentry->d_inode->i_sem);
-+#endif
-+
- DPUT(whiteout_dentry);
-
- if (err) {
-diff -urN unionfs-1.1.3.old/main.c unionfs-1.1.3.new/main.c
---- unionfs-1.1.3.old/main.c 2006-02-20 19:47:06.000000000 -0300
-+++ unionfs-1.1.3.new/main.c 2006-04-03 22:42:17.365552345 -0300
-@@ -103,7 +103,12 @@
- }
- }
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&inode->i_mutex);
-+#else
- down(&inode->i_sem);
-+#endif
-+
- if (atomic_read(&inode->i_count) > 1)
- goto skip;
-
-@@ -172,7 +177,11 @@
-
- fist_print_dentry("Leaving unionfs_interpose", dentry);
- fist_print_inode("Leaving unionfs_interpose", inode);
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&inode->i_mutex);
-+#else
- up(&inode->i_sem);
-+#endif
-
- out:
- print_exit_status(err);
-diff -urN unionfs-1.1.3.old/unionfs.h unionfs-1.1.3.new/unionfs.h
---- unionfs-1.1.3.old/unionfs.h 2006-02-20 19:47:06.000000000 -0300
-+++ unionfs-1.1.3.new/unionfs.h 2006-04-03 22:42:17.385548953 -0300
-@@ -776,13 +776,22 @@
- {
- struct dentry *dir = DGET(dentry->d_parent);
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&dir->d_inode->i_mutex);
-+#else
- down(&dir->d_inode->i_sem);
-+#endif
-+
- return dir;
- }
-
- static inline void unlock_dir(struct dentry *dir)
- {
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&dir->d_inode->i_mutex);
-+#else
- up(&dir->d_inode->i_sem);
-+#endif
- DPUT(dir);
- }
-
-diff -urN unionfs-1.1.3.old/xattr.c unionfs-1.1.3.new/xattr.c
---- unionfs-1.1.3.old/xattr.c 2006-02-20 19:47:06.000000000 -0300
-+++ unionfs-1.1.3.new/xattr.c 2006-04-03 22:42:17.394547426 -0300
-@@ -77,14 +77,22 @@
-
- encoded_value = (char *)value;
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&hidden_dentry->d_inode->i_mutex);
-+#else
- down(&hidden_dentry->d_inode->i_sem);
-+#endif
- /* lock_kernel() already done by caller. */
- err =
- hidden_dentry->d_inode->i_op->getxattr(hidden_dentry,
- encoded_name,
- encoded_value, size);
- /* unlock_kernel() will be done by caller. */
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&hidden_dentry->d_inode->i_mutex);
-+#else
- up(&hidden_dentry->d_inode->i_sem);
-+#endif
-
- }
-
-@@ -112,12 +120,20 @@
- name, (unsigned long)size, flags);
-
- if (hidden_dentry->d_inode->i_op->setxattr) {
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&hidden_dentry->d_inode->i_mutex);
-+#else
- down(&hidden_dentry->d_inode->i_sem);
-+#endif
- /* lock_kernel() already done by caller. */
- err = hidden_dentry->d_inode->i_op->
- setxattr(hidden_dentry, name, value, size, flags);
- /* unlock_kernel() will be done by caller. */
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&hidden_dentry->d_inode->i_mutex);
-+#else
- up(&hidden_dentry->d_inode->i_sem);
-+#endif
- }
-
- unlock_dentry(dentry);
-@@ -143,13 +159,21 @@
- if (hidden_dentry->d_inode->i_op->removexattr) {
- encoded_name = (char *)name;
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&hidden_dentry->d_inode->i_mutex);
-+#else
- down(&hidden_dentry->d_inode->i_sem);
-+#endif
- /* lock_kernel() already done by caller. */
- err =
- hidden_dentry->d_inode->i_op->removexattr(hidden_dentry,
- encoded_name);
- /* unlock_kernel() will be done by caller. */
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&hidden_dentry->d_inode->i_mutex);
-+#else
- up(&hidden_dentry->d_inode->i_sem);
-+#endif
- }
-
- unlock_dentry(dentry);
-@@ -173,13 +197,21 @@
-
- if (hidden_dentry->d_inode->i_op->listxattr) {
- encoded_list = list;
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_lock(&hidden_dentry->d_inode->i_mutex);
-+#else
- down(&hidden_dentry->d_inode->i_sem);
-+#endif
- /* lock_kernel() already done by caller. */
- err =
- hidden_dentry->d_inode->i_op->listxattr(hidden_dentry,
- encoded_list, size);
- /* unlock_kernel() will be done by caller. */
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,15)
-+ mutex_unlock(&hidden_dentry->d_inode->i_mutex);
-+#else
- up(&hidden_dentry->d_inode->i_sem);
-+#endif
- }
-
- unlock_dentry(dentry);
diff --git a/sys-fs/unionfs/unionfs-1.0.14.ebuild b/sys-fs/unionfs/unionfs-1.0.14.ebuild
deleted file mode 100644
index adfccc67f16d..000000000000
--- a/sys-fs/unionfs/unionfs-1.0.14.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.14.ebuild,v 1.2 2007/07/13 05:15:33 mr_bones_ Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
-HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
-SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="acl debug"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- MODULE_NAMES="unionfs(fs:)"
- BUILD_TARGETS="all"
- BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
-}
-
-src_unpack() {
- local user_Makefile=fistdev.mk EXTRACFLAGS=""
-
- unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/unionfs-1.0.13-amd64.patch
- epatch ${FILESDIR}/unionfs-1.0.14-remove_call_to_ctags.patch
-
- if ! use debug; then
- echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
- fi
-
- use acl && EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
-
- echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
-}
-
-src_install() {
- dosbin unionctl uniondbg unionimap snapmerge
- doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
-
- linux-mod_src_install
-
- dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
-}
diff --git a/sys-fs/unionfs/unionfs-1.1.4-r2.ebuild b/sys-fs/unionfs/unionfs-1.1.4-r2.ebuild
deleted file mode 100644
index 740f929d447e..000000000000
--- a/sys-fs/unionfs/unionfs-1.1.4-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.1.4-r2.ebuild,v 1.3 2007/07/13 05:15:33 mr_bones_ Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
-HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
-SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="acl debug nfs"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- MODULE_NAMES="unionfs(kernel/fs/${PN}:)"
- BUILD_TARGETS="all"
- BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
-}
-
-src_unpack() {
- local user_Makefile=fistdev.mk EXTRACFLAGS=""
-
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/unionfs-1.1.3-15-kernel_mutex.patch
-
- if ! use debug; then
- echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
- fi
-
- if use acl; then
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
- elif use nfs; then
- EXTRACFLAGS="${EXTRACFLAGS} -DNFS_SECURITY_HOLE"
- fi
-
- [[ ${KV_MAJOR} -ge 2 && ${KV_MINOR} -ge 6 && ${KV_PATCH} -ge 16 ]] && \
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_UNSUPPORTED"
-
- echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
- einfo EXTRACFLAGS: ${EXTRACFLAGS}
-}
-
-src_install() {
- doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
-
- linux-mod_src_install
-
- dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
-
- into / # ${D}/sbin: usr could be unionfs mounted: bug #129960
- dosbin unionctl uniondbg unionimap snapmerge
-}
diff --git a/sys-fs/unionfs/unionfs-1.1.5.ebuild b/sys-fs/unionfs/unionfs-1.1.5.ebuild
deleted file mode 100644
index 2d3365c3cc90..000000000000
--- a/sys-fs/unionfs/unionfs-1.1.5.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.1.5.ebuild,v 1.2 2007/07/13 05:15:33 mr_bones_ Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
-HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
-SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="acl debug nfs"
-
-local_version_info() {
- ewarn
- ewarn "you need the proper kernel version!"
- ewarn
- einfo "kernel: 2.4.x (x>19) Version: 1.0.14"
- einfo "kernel: 2.6.x (x<9) Version: Not Supported"
- einfo "kernel: 2.6.9 - 2.6.15 Version: 1.1.5"
- einfo "kernel: 2.6.16 Version: 1.2"
- einfo "kernel: 2.6.17 Version: 1.3"
-}
-
-pkg_setup() {
- # kernel version check
- if kernel_is lt 2 6 9 || kernel_is gt 2 6 15; then
- local_version_info
- die
- fi
-
- linux-mod_pkg_setup
-
- MODULE_NAMES="unionfs(kernel/fs/${PN}:)"
- BUILD_TARGETS="all"
- BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
-}
-
-src_unpack() {
- local user_Makefile=fistdev.mk EXTRACFLAGS=""
-
- unpack ${A}
- cd ${S}
-
- if ! use debug; then
- echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
- fi
-
- if use acl; then
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
- elif use nfs; then
- EXTRACFLAGS="${EXTRACFLAGS} -DNFS_SECURITY_HOLE"
- fi
-
- echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
- einfo EXTRACFLAGS: ${EXTRACFLAGS}
-}
-
-src_install() {
- linux-mod_src_install
-
- dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
-
- emake PREFIX="${D}" install-utils
- doman man/unionimap.8
- into / # ${D}/sbin: usr could be unionfs mounted: bug #129960
- dosbin snapmerge
-}
diff --git a/sys-fs/unionfs/unionfs-1.2.ebuild b/sys-fs/unionfs/unionfs-1.2.ebuild
deleted file mode 100644
index 7049aa3c9515..000000000000
--- a/sys-fs/unionfs/unionfs-1.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.2.ebuild,v 1.2 2007/07/13 05:15:33 mr_bones_ Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
-HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
-SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="acl debug nfs"
-
-local_version_info() {
- ewarn
- ewarn "you need the proper kernel version!"
- ewarn
- einfo "kernel: 2.4.x (x>19) Version: 1.0.14"
- einfo "kernel: 2.6.x (x<9) Version: Not Supported"
- einfo "kernel: 2.6.9 - 2.6.15 Version: 1.1.5"
- einfo "kernel: 2.6.16 Version: 1.2"
- einfo "kernel: 2.6.17 Version: 1.3"
-}
-
-pkg_setup() {
- # kernel version check
- if ! kernel_is eq 2 6 16; then
- local_version_info
- die
- fi
-
- linux-mod_pkg_setup
-
- MODULE_NAMES="unionfs(kernel/fs/${PN}:)"
- BUILD_TARGETS="all"
- BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
-}
-
-src_unpack() {
- local user_Makefile=fistdev.mk EXTRACFLAGS=""
-
- unpack ${A}
- cd ${S}
-
- if ! use debug; then
- echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
- fi
-
- if use acl; then
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
- elif use nfs; then
- EXTRACFLAGS="${EXTRACFLAGS} -DNFS_SECURITY_HOLE"
- fi
-
- echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
- einfo EXTRACFLAGS: ${EXTRACFLAGS}
-}
-
-src_install() {
- linux-mod_src_install
-
- dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
-
- #emake PREFIX="${D}" install-utils # Makefile is bugged
- doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
- into / # ${D}/sbin: usr could be unionfs mounted: bug #129960
- dosbin utils/unionctl utils/uniondbg utils/unionimap
-}
diff --git a/sys-fs/unionfs/unionfs-1.3.ebuild b/sys-fs/unionfs/unionfs-1.3.ebuild
deleted file mode 100644
index ec5da99f5942..000000000000
--- a/sys-fs/unionfs/unionfs-1.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.3.ebuild,v 1.4 2007/07/13 05:15:33 mr_bones_ Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
-HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
-SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="acl debug nfs"
-
-local_version_info() {
- ewarn
- ewarn "you need the proper kernel version!"
- ewarn
- einfo "kernel: 2.4.x (x>19) Version: 1.0.14"
- einfo "kernel: 2.6.x (x<9) Version: Not Supported"
- einfo "kernel: 2.6.9 - 2.6.15 Version: 1.1.5"
- einfo "kernel: 2.6.16 Version: 1.2"
- einfo "kernel: 2.6.17 Version: 1.3"
-}
-
-pkg_setup() {
- # kernel version check
- if ! kernel_is eq 2 6 17; then
- local_version_info
- die
- fi
-
- linux-mod_pkg_setup
-
- MODULE_NAMES="unionfs(kernel/fs/${PN}:)"
- BUILD_TARGETS="all"
- BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
-}
-
-src_unpack() {
- local user_Makefile=fistdev.mk EXTRACFLAGS=""
-
- unpack ${A}
- cd ${S}
-
- if ! use debug; then
- echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
- fi
-
- if use acl; then
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
- elif use nfs; then
- EXTRACFLAGS="${EXTRACFLAGS} -DNFS_SECURITY_HOLE"
- fi
-
- echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
- einfo EXTRACFLAGS: ${EXTRACFLAGS}
-
- echo "UNIONFS_OPT_CFLAG=${CFLAGS}" >> ${user_Makefile}
-
- epatch "${FILESDIR}"/${PV}-64bit_compile_fix.diff
-}
-
-src_install() {
- linux-mod_src_install
-
- dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
-
- emake \
- PREFIX="${D}" \
- MANDIR="${D}/usr/share/man" \
- install-utils # Makefile is bugged
- #doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
- #into / # ${D}/sbin: usr could be unionfs mounted: bug #129960
- #dosbin utils/unionctl utils/uniondbg utils/unionimap
-}
diff --git a/sys-fs/unionfs/unionfs-1.4.ebuild b/sys-fs/unionfs/unionfs-1.4.ebuild
deleted file mode 100644
index 3fe35435bc22..000000000000
--- a/sys-fs/unionfs/unionfs-1.4.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.4.ebuild,v 1.2 2007/07/13 05:15:33 mr_bones_ Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
-HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
-SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="acl debug nfs"
-
-local_version_info() {
- ewarn
- ewarn "you need the proper kernel version!"
- ewarn
- einfo "kernel: 2.4.x (x>19) Version: 1.0.14"
- einfo "kernel: 2.6.x (x<9) Version: Not Supported"
- einfo "kernel: 2.6.9 - 2.6.15 Version: 1.1.5"
- einfo "kernel: 2.6.16 Version: 1.2"
- einfo "kernel: 2.6.17 Version: 1.3"
- einfo "kernel: 2.6.18 Version: 1.4"
-}
-
-pkg_setup() {
- # kernel version check
- if ! kernel_is eq 2 6 18; then
- local_version_info
- die
- fi
-
- linux-mod_pkg_setup
-
- MODULE_NAMES="unionfs(kernel/fs/${PN}:)"
- BUILD_TARGETS="all"
- BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
-}
-
-src_unpack() {
- local user_Makefile=fistdev.mk EXTRACFLAGS=""
-
- unpack ${A}
- cd ${S}
-
- if ! use debug; then
- echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
- fi
-
- if use acl; then
- EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
- elif use nfs; then
- EXTRACFLAGS="${EXTRACFLAGS} -DNFS_SECURITY_HOLE"
- fi
-
- echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
- einfo EXTRACFLAGS: ${EXTRACFLAGS}
-
- echo "UNIONFS_OPT_CFLAG=${CFLAGS}" >> ${user_Makefile}
-}
-
-src_install() {
- linux-mod_src_install
-
- dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
-
- emake \
- PREFIX="${D}" \
- MANDIR="${D}/usr/share/man" \
- install-utils # Makefile is bugged
- #doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
- #into / # ${D}/sbin: usr could be unionfs mounted: bug #129960
- #dosbin utils/unionctl utils/uniondbg utils/unionimap
-}