summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-18 18:36:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-18 18:36:51 +0000
commit98778d14c41f796379af5294faf903ebed81810f (patch)
tree5f42eb82c1d34c1b1f22b373658ce2ec856aae23
parentAdd pkill-darwin to the system set for darwin hosts (diff)
downloadgentoo-2-98778d14c41f796379af5294faf903ebed81810f.tar.gz
gentoo-2-98778d14c41f796379af5294faf903ebed81810f.tar.bz2
gentoo-2-98778d14c41f796379af5294faf903ebed81810f.zip
Version bump.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
-rw-r--r--dev-libs/icu/ChangeLog8
-rw-r--r--dev-libs/icu/icu-4.8_rc1.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 85a846f9af53..2381acb73d6a 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.148 2011/05/07 16:54:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.149 2011/05/18 18:36:51 arfrever Exp $
+
+*icu-4.8_rc1 (18 May 2011)
+
+ 18 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +icu-4.8_rc1.ebuild:
+ Version bump.
07 May 2011; Raúl Porcel <armin76@gentoo.org> icu-4.6.1.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #364409
diff --git a/dev-libs/icu/icu-4.8_rc1.ebuild b/dev-libs/icu/icu-4.8_rc1.ebuild
new file mode 100644
index 000000000000..cc42cd8f9739
--- /dev/null
+++ b/dev-libs/icu/icu-4.8_rc1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.8_rc1.ebuild,v 1.1 2011/05/18 18:36:51 arfrever Exp $
+
+EAPI="3"
+
+inherit versionator
+
+MAJOR_VERSION="$(get_version_component_range 1)"
+MINOR_VERSION="$(get_version_component_range 2)"
+if [[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+(_rc[[:digit:]]*)?$ ]]; then
+ MICRO_VERSION="0"
+else
+ MICRO_VERSION="$(get_version_component_range 3)"
+fi
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+
+BASE_URI="http://download.icu-project.org/files/icu4c/${PV/_/}"
+SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
+DOCS_ARCHIVE="icu4c-${PV//./_}-docs.zip"
+
+SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
+ doc? ( ${BASE_URI}/${DOCS_ARCHIVE} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+QA_DT_NEEDED="/usr/lib.*/libicudata\.so\.${MAJOR_VERSION}${MINOR_VERSION}\.${MICRO_VERSION}"
+
+src_unpack() {
+ unpack "${SRC_ARCHIVE}"
+ if use doc; then
+ mkdir docs
+ pushd docs > /dev/null
+ unpack "${DOCS_ARCHIVE}"
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode flags into icu-config.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ local variable
+ for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
+ done
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/api
+ doins -r "${WORKDIR}/docs/"* || die "doins failed"
+ fi
+}