summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-21 08:09:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-21 08:09:43 +0000
commit9805852d694065ddbad6de59cceabdb87751da9e (patch)
tree28bd9318e8f2cb0b686786bf4b695e7d43fbc8c4
parentBump (diff)
downloadgentoo-2-9805852d694065ddbad6de59cceabdb87751da9e.tar.gz
gentoo-2-9805852d694065ddbad6de59cceabdb87751da9e.tar.bz2
gentoo-2-9805852d694065ddbad6de59cceabdb87751da9e.zip
Add more linker flags #461976
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sci-mathematics/yafu/ChangeLog6
-rw-r--r--sci-mathematics/yafu/files/fix-Makefile.patch11
-rw-r--r--sci-mathematics/yafu/yafu-1.34.3.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/sci-mathematics/yafu/ChangeLog b/sci-mathematics/yafu/ChangeLog
index 01528742c75e..70e854536153 100644
--- a/sci-mathematics/yafu/ChangeLog
+++ b/sci-mathematics/yafu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/yafu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/ChangeLog,v 1.10 2013/03/08 03:05:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/ChangeLog,v 1.11 2013/03/21 08:09:43 patrick Exp $
+
+ 21 Mar 2013; Patrick Lauer <patrick@gentoo.org> +files/fix-Makefile.patch,
+ yafu-1.34.3.ebuild:
+ Add more linker flags #461976
08 Mar 2013; Patrick Lauer <patrick@gentoo.org> yafu-1.34.3.ebuild:
Fixing SRC_URI to make sense
diff --git a/sci-mathematics/yafu/files/fix-Makefile.patch b/sci-mathematics/yafu/files/fix-Makefile.patch
new file mode 100644
index 000000000000..82b8e0d7d2ff
--- /dev/null
+++ b/sci-mathematics/yafu/files/fix-Makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2013-03-17 11:20:40.248683894 +0400
++++ Makefile 2013-03-17 11:20:47.352683657 +0400
+@@ -87,7 +87,7 @@ ifeq ($(CC),icc)
+ CFLAGS += -mtune=core2 -march=core2
+ endif
+
+-LIBS += -lecm -lgmp
++LIBS += -lecm -lgmp -lgomp
+
+ CFLAGS += $(OPT_FLAGS) $(WARN_FLAGS) $(INC)
+
diff --git a/sci-mathematics/yafu/yafu-1.34.3.ebuild b/sci-mathematics/yafu/yafu-1.34.3.ebuild
index 12573055e1c7..4af8ab80ddfc 100644
--- a/sci-mathematics/yafu/yafu-1.34.3.ebuild
+++ b/sci-mathematics/yafu/yafu-1.34.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-1.34.3.ebuild,v 1.3 2013/03/08 03:05:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-1.34.3.ebuild,v 1.4 2013/03/21 08:09:43 patrick Exp $
EAPI=5
@@ -27,6 +27,7 @@ DEPEND="
RDEPEND="${DEPEND}"
src_prepare() {
+ epatch "${FILESDIR}/fix-Makefile.patch"
# This is not nice. But then the Makefile is quite special :)
sed -i -e 's:../gmp/include:gmp:' Makefile || die "Failed to rectify things"
sed -i -e 's:../gmp-ecm/include:gmp-ecm:' Makefile || die "Failed to rectify things"