summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-17 05:37:36 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-17 05:37:36 +0000
commit97e7673e68bcf1650844089d742320df21442cf9 (patch)
tree402608bd6c5c89d35289f5c99972dccc8b61ad1f
parentCleanup. (diff)
downloadgentoo-2-97e7673e68bcf1650844089d742320df21442cf9.tar.gz
gentoo-2-97e7673e68bcf1650844089d742320df21442cf9.tar.bz2
gentoo-2-97e7673e68bcf1650844089d742320df21442cf9.zip
bump; update and tidy up, fixes Bug #507636
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/reportlab/ChangeLog7
-rw-r--r--dev-python/reportlab/reportlab-3.0.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-python/reportlab/ChangeLog b/dev-python/reportlab/ChangeLog
index 3711acb28708..18a71e849bf2 100644
--- a/dev-python/reportlab/ChangeLog
+++ b/dev-python/reportlab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/reportlab
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v 1.102 2014/01/30 15:13:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v 1.103 2014/04/17 05:37:36 idella4 Exp $
+
+*reportlab-3.0 (17 Apr 2014)
+
+ 17 Apr 2014; Ian Delaney <idella4@gentoo.org> +reportlab-3.0.ebuild:
+ bump; update and tidy up, fixes Bug #507636
30 Jan 2014; Justin Lecher <jlec@gentoo.org> reportlab-2.7.ebuild:
Drop Python 3 support
diff --git a/dev-python/reportlab/reportlab-3.0.ebuild b/dev-python/reportlab/reportlab-3.0.ebuild
new file mode 100644
index 000000000000..9b612d4748f6
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-3.0.ebuild,v 1.1 2014/04/17 05:37:36 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+# Tests crash with pypy
+
+inherit distutils-r1 flag-o-matic prefix
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source."
+HOMEPAGE="http://www.reportlab.com/"
+SRC_URI="http://www.reportlab.com/ftp/${P}.tar.gz
+ http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ media-fonts/ttf-bitstream-vera
+ media-libs/libart_lgpl
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ sed -i \
+ -e "s|/usr/lib/X11/fonts/TrueType/|${EPREFIX}/usr/share/fonts/ttf-bitstream-vera/|" \
+ -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
+ -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
+ src/reportlab/rl_config.py || die
+
+ eprefixify setup.py
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+src_compile() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_src_compile
+}
+
+python_test() {
+ pushd tests > /dev/null || die
+ "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( demos/. tools/pythonpoint/demos )
+
+ distutils-r1_python_install_all
+}