summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-31 07:09:02 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-31 07:09:02 +0000
commit96b9ee2ea44a2439e7743db12f0f1e6914859e7a (patch)
tree8b604d7b838d0cd03443139a63a9f48c986c5f45
parentAdd missing deps for USE=static-analyzer. (diff)
downloadgentoo-2-96b9ee2ea44a2439e7743db12f0f1e6914859e7a.tar.gz
gentoo-2-96b9ee2ea44a2439e7743db12f0f1e6914859e7a.tar.bz2
gentoo-2-96b9ee2ea44a2439e7743db12f0f1e6914859e7a.zip
Finally drop compatibility symlinks. This time for real.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
-rw-r--r--sys-apps/systemd/ChangeLog5
-rw-r--r--sys-apps/systemd/systemd-9999-r1.ebuild39
2 files changed, 5 insertions, 39 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 55b662830985..cdfc7106b7b6 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.152 2013/07/30 08:48:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.153 2013/07/31 07:09:02 mgorny Exp $
+
+ 31 Jul 2013; Michał Górny <mgorny@gentoo.org> systemd-9999-r1.ebuild:
+ Finally drop compatibility symlinks. This time for real.
30 Jul 2013; Michał Górny <mgorny@gentoo.org> systemd-206.ebuild,
systemd-9999-r1.ebuild:
diff --git a/sys-apps/systemd/systemd-9999-r1.ebuild b/sys-apps/systemd/systemd-9999-r1.ebuild
index cd6f8570bb29..bd327da8eed6 100644
--- a/sys-apps/systemd/systemd-9999-r1.ebuild
+++ b/sys-apps/systemd/systemd-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999-r1.ebuild,v 1.2 2013/07/30 08:48:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999-r1.ebuild,v 1.3 2013/07/31 07:09:02 mgorny Exp $
EAPI=5
@@ -99,22 +99,6 @@ pkg_pretend() {
~SYSFS ~!IDE ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2"
# ~!FW_LOADER_USER_HELPER"
- # read null-terminated argv[0] from PID 1
- # and see which path to systemd was used (if any)
- local init_path
- IFS= read -r -d '' init_path < /proc/1/cmdline
- if [[ ${init_path} == */bin/systemd ]]; then
- eerror "You are using a compatibility symlink to run systemd. The symlink"
- eerror "has been removed. Please update your bootloader to use:"
- eerror
- eerror " init=/usr/lib/systemd/systemd"
- eerror
- eerror "and reboot your system. We are sorry for the inconvenience."
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- die "Compatibility symlink used to boot systemd."
- fi
- fi
-
if [[ ${MERGE_TYPE} != binary ]]; then
if [[ $(gcc-major-version) -lt 4
|| ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ) ]]
@@ -212,23 +196,10 @@ src_install() {
udevlibexecdir="${MY_UDEVDIR}" \
dist_udevhwdb_DATA=
- # keep udev working without initramfs, for openrc compat
- dodir /bin /sbin
- mv "${D}"/usr/lib/systemd/systemd-udevd "${D}"/sbin/udevd || die
- mv "${D}"/usr/bin/udevadm "${D}"/bin/udevadm || die
- dosym ../../../sbin/udevd /usr/lib/systemd/systemd-udevd
- dosym ../../bin/udevadm /usr/bin/udevadm
-
# zsh completion
insinto /usr/share/zsh/site-functions
newins shell-completion/systemd-zsh-completion.zsh "_${PN}"
- # compat for init= use
- dosym ../usr/lib/systemd/systemd /bin/systemd
- dosym ../lib/systemd/systemd /usr/bin/systemd
- # rsyslog.service depends on it...
- dosym ../usr/bin/systemctl /bin/systemctl
-
# we just keep sysvinit tools, so no need for the mans
rm "${D}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
|| die
@@ -240,14 +211,6 @@ src_install() {
# Preserve empty dirs in /etc & /var, bug #437008
keepdir /etc/binfmt.d /etc/modules-load.d /etc/tmpfiles.d \
/etc/systemd/ntp-units.d /etc/systemd/user /var/lib/systemd
-
- # Check whether we won't break user's system.
- local x
- for x in /bin/systemd /usr/bin/systemd \
- /usr/bin/udevadm /usr/lib/systemd/systemd-udevd
- do
- [[ -x ${D}${x} ]] || die "${x} symlink broken, aborting."
- done
}
optfeature() {