summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-02-24 18:11:16 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-02-24 18:11:16 +0000
commit95d5b5f7a4cb133eb487aba875e815830272dd15 (patch)
treed670376e2145f3d1917664c339ff45f9b2aaa417
parentStable on x86. (diff)
downloadgentoo-2-95d5b5f7a4cb133eb487aba875e815830272dd15.tar.gz
gentoo-2-95d5b5f7a4cb133eb487aba875e815830272dd15.tar.bz2
gentoo-2-95d5b5f7a4cb133eb487aba875e815830272dd15.zip
Patched configure conditionally to allow compilation without arts, closes bug 80980.
(Portage version: 2.0.51-r15)
-rw-r--r--sci-mathematics/koctave/ChangeLog7
-rw-r--r--sci-mathematics/koctave/files/koctave-0.65-arts-configure.patch142
-rw-r--r--sci-mathematics/koctave/koctave-0.65.ebuild8
3 files changed, 155 insertions, 2 deletions
diff --git a/sci-mathematics/koctave/ChangeLog b/sci-mathematics/koctave/ChangeLog
index cbeb8af09d36..2752857925db 100644
--- a/sci-mathematics/koctave/ChangeLog
+++ b/sci-mathematics/koctave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/koctave
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/koctave/ChangeLog,v 1.3 2005/01/15 00:16:08 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/koctave/ChangeLog,v 1.4 2005/02/24 18:11:16 cryos Exp $
+
+ 24 Feb 2005; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/koctave-0.65-arts-configure.patch, koctave-0.65.ebuild:
+ Patched configure conditionally to allow compilation without arts. Fixes bug
+ 80980.
15 Jan 2005; Dan Armak <danarmak@gentoo.org> koctave-0.65.ebuild:
Changed dep on a kde-base monolithic package to accept the equivalent split
diff --git a/sci-mathematics/koctave/files/koctave-0.65-arts-configure.patch b/sci-mathematics/koctave/files/koctave-0.65-arts-configure.patch
new file mode 100644
index 000000000000..33a84e88f104
--- /dev/null
+++ b/sci-mathematics/koctave/files/koctave-0.65-arts-configure.patch
@@ -0,0 +1,142 @@
+--- configure.orig 2005-02-24 17:56:43.875227288 +0000
++++ configure 2005-02-24 17:58:06.613649136 +0000
+@@ -23541,139 +23541,6 @@
+
+ fi
+
+-
+- echo "$as_me:$LINENO: checking for mcopidl" >&5
+-echo $ECHO_N "checking for mcopidl... $ECHO_C" >&6
+- if test -n "$MCOPIDL"; then
+- kde_cv_path="$MCOPIDL";
+- else
+- kde_cache=`echo mcopidl | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/mcopidl"; then
+- if test -n ""
+- then
+- evalstr="$dir/mcopidl 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- else
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- MCOPIDL=$kde_cv_path
+-
+- fi
+-
+-
+- echo "$as_me:$LINENO: checking for artsc-config" >&5
+-echo $ECHO_N "checking for artsc-config... $ECHO_C" >&6
+- if test -n "$ARTSCCONFIG"; then
+- kde_cv_path="$ARTSCCONFIG";
+- else
+- kde_cache=`echo artsc-config | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/artsc-config"; then
+- if test -n ""
+- then
+- evalstr="$dir/artsc-config 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- else
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- ARTSCCONFIG=$kde_cv_path
+-
+- fi
+-
+-
+ echo "$as_me:$LINENO: checking for kde-config" >&5
+ echo $ECHO_N "checking for kde-config... $ECHO_C" >&6
+ if test -n "$KDECONFIG"; then
diff --git a/sci-mathematics/koctave/koctave-0.65.ebuild b/sci-mathematics/koctave/koctave-0.65.ebuild
index 364d65e2d455..a81ce994efbf 100644
--- a/sci-mathematics/koctave/koctave-0.65.ebuild
+++ b/sci-mathematics/koctave/koctave-0.65.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/koctave/koctave-0.65.ebuild,v 1.3 2005/01/15 00:16:08 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/koctave/koctave-0.65.ebuild,v 1.4 2005/02/24 18:11:16 cryos Exp $
inherit kde
@@ -17,4 +17,10 @@ IUSE=""
DEPEND="virtual/libc
sci-mathematics/octave
|| ( kde-base/kdebase-meta kde-base/kdebase )"
+
need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+ use arts || epatch ${FILESDIR}/${P}-arts-configure.patch
+}