summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-24 14:31:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-24 14:31:26 +0000
commit95613a8dda3add89ebdb3ac40b5f7bd2ab445a4a (patch)
tree8e9a1e59e9eba11326bfe10b939b6ddf04d45618
parentRe-add ~ia64 wrt #283953 (diff)
downloadgentoo-2-95613a8dda3add89ebdb3ac40b5f7bd2ab445a4a.tar.gz
gentoo-2-95613a8dda3add89ebdb3ac40b5f7bd2ab445a4a.tar.bz2
gentoo-2-95613a8dda3add89ebdb3ac40b5f7bd2ab445a4a.zip
Update dependencies.
(Portage version: 14402-svn/cvs/Linux x86_64)
-rw-r--r--dev-lang/python/python-2.6.2-r2.ebuild10
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/dev-lang/python/python-2.6.2-r2.ebuild b/dev-lang/python/python-2.6.2-r2.ebuild
index 6e58d4692ec8..d76deb11bf7b 100644
--- a/dev-lang/python/python-2.6.2-r2.ebuild
+++ b/dev-lang/python/python-2.6.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r2.ebuild,v 1.3 2009/09/23 15:29:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r2.ebuild,v 1.4 2009/09/24 14:31:26 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -56,11 +56,11 @@ RDEPEND=">=app-admin/eselect-python-20080925
tk? ( >=dev-lang/tk-8.0 )
xml? ( >=dev-libs/expat-2 )
)
- !m68k? ( !mips? ( !sparc-fbsd? ( !x86-fbsd? ( virtual/libffi ) ) ) )"
+ !m68k? ( !mips? ( !sparc-fbsd? ( virtual/libffi ) ) )"
DEPEND="${RDEPEND}
- !m68k? ( !mips? ( !sparc-fbsd? ( !x86-fbsd? ( dev-util/pkgconfig ) ) ) )"
+ !m68k? ( !mips? ( !sparc-fbsd? ( dev-util/pkgconfig ) ) )"
PDEPEND="${RDEPEND} app-admin/python-updater"
-RDEPEND+=" app-misc/mime-types"
+RDEPEND+=" !build? ( app-misc/mime-types )"
PROVIDE="virtual/python"
@@ -185,7 +185,7 @@ src_configure() {
# Please query BSD team before removing this!
append-ldflags "-L."
- if ! use m68k && ! use mips && ! use sparc-fbsd && ! use x86-fbsd; then
+ if ! use m68k && ! use mips && ! use sparc-fbsd; then
myconf+=" --with-system-ffi"
fi
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 72ba77b51fa4..e1765c753d6e 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.2 2009/09/23 13:42:36 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.3 2009/09/24 14:31:26 arfrever Exp $
EAPI="2"
@@ -38,11 +38,11 @@ RDEPEND=">=app-admin/eselect-python-20080925
doc? ( dev-python/python-docs:${SLOT} )
xml? ( >=dev-libs/expat-2 )
)
- !m68k? ( !mips? ( !sparc-fbsd? ( !x86-fbsd? ( virtual/libffi ) ) ) )"
+ !m68k? ( !mips? ( !sparc-fbsd? ( virtual/libffi ) ) )"
DEPEND="${RDEPEND}
- !m68k? ( !mips? ( !sparc-fbsd? ( !x86-fbsd? ( dev-util/pkgconfig ) ) ) )"
+ !m68k? ( !mips? ( !sparc-fbsd? ( dev-util/pkgconfig ) ) )"
PDEPEND="${RDEPEND} app-admin/python-updater"
-RDEPEND+=" app-misc/mime-types"
+RDEPEND+=" !build? ( app-misc/mime-types )"
PROVIDE="virtual/python"
@@ -149,7 +149,7 @@ src_configure() {
fi
dbmliborder="${dbmliborder#:}"
- if ! use m68k && ! use mips && ! use sparc-fbsd && ! use x86-fbsd; then
+ if ! use m68k && ! use mips && ! use sparc-fbsd; then
myconf+=" --with-system-ffi"
fi