summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-09-25 14:31:30 +0000
committerJim Ramsay <lack@gentoo.org>2009-09-25 14:31:30 +0000
commit93cc80138e2a3345d3475c7c484ef7b556c28caf (patch)
tree5d4822577ef5344d554692701c82dc9c5d55c7c5
parentversion bumps (diff)
downloadgentoo-2-93cc80138e2a3345d3475c7c484ef7b556c28caf.tar.gz
gentoo-2-93cc80138e2a3345d3475c7c484ef7b556c28caf.tar.bz2
gentoo-2-93cc80138e2a3345d3475c7c484ef7b556c28caf.zip
Fix .desktop file and dependency list for bug #249366 and #285106, respectively
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--app-editors/gvim/ChangeLog7
-rw-r--r--app-editors/gvim/files/gvim.desktop-r29
-rw-r--r--app-editors/gvim/gvim-7.2.238.ebuild13
3 files changed, 24 insertions, 5 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index c490011e48b8..a1ba6db1b3da 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gvim
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.295 2009/07/26 12:33:28 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.296 2009/09/25 14:31:30 lack Exp $
+
+ 24 Sep 2009; Jim Ramsay <lack@gentoo.org> gvim-7.2.238.ebuild,
+ +files/gvim.desktop-r2:
+ Fix .desktop file and dependency list for bug #249366 and #285106,
+ respectively
26 Jul 2009; Brent Baude <ranger@gentoo.org> gvim-7.2.182.ebuild:
Marking gvim-7.2.182 ppc64 for bug 257007
diff --git a/app-editors/gvim/files/gvim.desktop-r2 b/app-editors/gvim/files/gvim.desktop-r2
new file mode 100644
index 000000000000..45b55d036929
--- /dev/null
+++ b/app-editors/gvim/files/gvim.desktop-r2
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=gVim
+Comment=A highly configurable text editor
+Exec=gvim -f %F
+Icon=gvim
+Terminal=false
+Type=Application
+MimeType=text/plain;
+Categories=Development;
diff --git a/app-editors/gvim/gvim-7.2.238.ebuild b/app-editors/gvim/gvim-7.2.238.ebuild
index d80fc3a17b11..addb0c9f497b 100644
--- a/app-editors/gvim/gvim-7.2.238.ebuild
+++ b/app-editors/gvim/gvim-7.2.238.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.2.238.ebuild,v 1.1 2009/07/22 14:13:15 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.2.238.ebuild,v 1.2 2009/09/25 14:31:30 lack Exp $
inherit vim
@@ -8,7 +8,7 @@ VIM_VERSION="7.2"
VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
GVIMRC_FILE_SUFFIX="-r1"
-GVIM_DESKTOP_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r2"
SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
@@ -20,7 +20,7 @@ S="${WORKDIR}/vim${VIM_VERSION/.}"
DESCRIPTION="GUI version of the Vim text editor"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="aqua gnome gtk motif nextaw"
-DEPEND="${DEPEND}
+RDEPEND="${DEPEND}
~app-editors/vim-core-${PV}
x11-libs/libXext
!aqua? (
@@ -41,4 +41,9 @@ DEPEND="${DEPEND}
)
)
)"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ !aqua? (
+ gtk? (
+ dev-util/pkgconfig
+ )
+ )"