summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-06-20 17:28:43 +0000
committerChristoph Mende <angelos@gentoo.org>2008-06-20 17:28:43 +0000
commit931600bdc072d5bfc43f4ac65814800251a6aa73 (patch)
treede5b927d000caf2c329c2a1514552715f71dd4f1
parentVersion bumped. (diff)
downloadgentoo-2-931600bdc072d5bfc43f4ac65814800251a6aa73.tar.gz
gentoo-2-931600bdc072d5bfc43f4ac65814800251a6aa73.tar.bz2
gentoo-2-931600bdc072d5bfc43f4ac65814800251a6aa73.zip
Version bump, bug 214491
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 x86_64)
-rw-r--r--net-p2p/btg/ChangeLog8
-rw-r--r--net-p2p/btg/btg-0.9.7.ebuild81
-rw-r--r--net-p2p/btg/files/btg-0.9.7-broken_bundled_plotmm_sigc.patch100
3 files changed, 188 insertions, 1 deletions
diff --git a/net-p2p/btg/ChangeLog b/net-p2p/btg/ChangeLog
index 3472c05ed5df..d618351d185f 100644
--- a/net-p2p/btg/ChangeLog
+++ b/net-p2p/btg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/btg
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/ChangeLog,v 1.7 2008/06/20 10:09:57 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/ChangeLog,v 1.8 2008/06/20 17:28:42 angelos Exp $
+
+*btg-0.9.7 (20 Jun 2008)
+
+ 20 Jun 2008; Christoph Mende <angelos@gentoo.org>
+ +files/btg-0.9.7-broken_bundled_plotmm_sigc.patch, +btg-0.9.7.ebuild:
+ Version bump, bug 214491
20 Jun 2008; Christoph Mende <angelos@gentoo.org> btg-0.9.6-r1.ebuild:
Changed rb_libtorrent dependency to =0.12*
diff --git a/net-p2p/btg/btg-0.9.7.ebuild b/net-p2p/btg/btg-0.9.7.ebuild
new file mode 100644
index 000000000000..790b4b37ab5a
--- /dev/null
+++ b/net-p2p/btg/btg-0.9.7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/btg-0.9.7.ebuild,v 1.1 2008/06/20 17:28:42 angelos Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="bittorrent client using rb_libtorrent"
+HOMEPAGE="http://btg.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc event-callback gtk minimal ncurses session test webinterface"
+
+RDEPEND=">=dev-libs/boost-1.34.1
+ dev-libs/expat
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error
+ dev-libs/libtasn1
+ dev-util/dialog
+ net-libs/gnutls
+ >=net-libs/rb_libtorrent-0.13_rc1
+ gtk? ( dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ x11-libs/pango )
+ test? ( dev-util/cppunit )
+ webinterface? ( =dev-lang/php-5* virtual/httpd-cgi )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.21
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-broken_bundled_plotmm_sigc.patch
+}
+
+src_compile() {
+ filter-ldflags -Wl,--as-needed --as-needed
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable gtk gui) \
+ $(use_enable ncurses cli) \
+ $(use_enable event-callback) \
+ $(use_enable session session-saving) \
+ $(use_enable test unittest) \
+ $(use_enable webinterface www) \
+ $(use_enable !minimal command-list) \
+ --enable-btg-config \
+ --disable-upnp \
+ --disable-dependency-tracking \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ newinitd "${FILESDIR}/btgd-init" ${PN}
+ newconfd "${FILESDIR}/btgd-confd" ${PN}
+
+ use gtk && make_desktop_entry btgui "BTG GUI Client" btg "Network;P2P"
+}
+
+pkg_postinst() {
+ enewgroup p2p
+ enewuser p2p -1 -1 /home/p2p p2p
+
+ echo
+ elog "BTG needs a daemon.ini and client.ini, to create them run btg-config"
+ elog "and put them in the home of the user running btg (/home/p2p/.btg by default)"
+ echo
+}
diff --git a/net-p2p/btg/files/btg-0.9.7-broken_bundled_plotmm_sigc.patch b/net-p2p/btg/files/btg-0.9.7-broken_bundled_plotmm_sigc.patch
new file mode 100644
index 000000000000..2522484c0e55
--- /dev/null
+++ b/net-p2p/btg/files/btg-0.9.7-broken_bundled_plotmm_sigc.patch
@@ -0,0 +1,100 @@
+diff -Naur btg-0.9.7.orig/external/plotmm/compat.h btg-0.9.7/external/plotmm/compat.h
+--- btg-0.9.7.orig/external/plotmm/compat.h 2008-03-25 13:49:08.000000000 +0100
++++ btg-0.9.7/external/plotmm/compat.h 2008-03-25 14:21:18.000000000 +0100
+@@ -59,7 +59,7 @@
+ #else
+
+ namespace PlotMM {
+- typedef SigC::ObjectBase ObjectBase;
++ typedef sigc::ObjectBase ObjectBase;
+ }
+
+ #endif
+diff -Naur btg-0.9.7.orig/external/plotmm/curve.h btg-0.9.7/external/plotmm/curve.h
+--- btg-0.9.7.orig/external/plotmm/curve.h 2008-03-25 13:49:08.000000000 +0100
++++ btg-0.9.7/external/plotmm/curve.h 2008-03-25 14:21:18.000000000 +0100
+@@ -140,7 +140,7 @@
+ int from = 0, int to = -1);
+
+ //! Signals that this curve has changed in some way or the other
+- SigC::Signal0<void> signal_curve_changed;
++ sigc::signal0<void> signal_curve_changed;
+
+ protected:
+ virtual void init(const Glib::ustring &title);
+diff -Naur btg-0.9.7.orig/external/plotmm/plot.cc btg-0.9.7/external/plotmm/plot.cc
+--- btg-0.9.7.orig/external/plotmm/plot.cc 2008-03-25 13:49:08.000000000 +0100
++++ btg-0.9.7/external/plotmm/plot.cc 2008-03-25 14:21:18.000000000 +0100
+@@ -322,7 +322,7 @@
+ connect(sigc::mem_fun(*this,&Plot::on_canvas_expose_event));
+ #else
+ canvas_.signal_expose_event().
+- connect(SigC::slot(*this,&Plot::on_canvas_expose_event));
++ connect(sigc::slot(*this,&Plot::on_canvas_expose_event));
+ #endif
+
+ show_all();
+@@ -406,19 +406,19 @@
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
++sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
+ {
+ return canvas_.signal_plot_mouse_press;
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
++sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
+ {
+ return canvas_.signal_plot_mouse_release;
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
++sigc::signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
+ {
+ return canvas_.signal_plot_mouse_move;
+ }
+diff -Naur btg-0.9.7.orig/external/plotmm/plot.h btg-0.9.7/external/plotmm/plot.h
+--- btg-0.9.7.orig/external/plotmm/plot.h 2008-03-25 13:49:08.000000000 +0100
++++ btg-0.9.7/external/plotmm/plot.h 2008-03-25 14:21:18.000000000 +0100
+@@ -79,9 +79,9 @@
+ virtual void clear();
+ virtual void end_replot();
+
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
+- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
++ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
+
+ protected:
+ virtual bool on_expose_event(GdkEventExpose* event);
+@@ -141,9 +141,9 @@
+ Scale *scale(PlotAxisID id) { return tickMark_[id]; }
+ PlotLabel *label(PlotAxisID id) { return axisLabel_[id]; }
+
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
+- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
++ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
+
+ void set_selection(const Rectangle &r);
+ Rectangle get_selection() { return select_; }
+diff -Naur btg-0.9.7.orig/external/plotmm/scale.h btg-0.9.7/external/plotmm/scale.h
+--- btg-0.9.7.orig/external/plotmm/scale.h 2008-03-25 13:49:08.000000000 +0100
++++ btg-0.9.7/external/plotmm/scale.h 2008-03-25 14:21:18.000000000 +0100
+@@ -133,7 +133,7 @@
+ /*! This signal is thrown whenever the scale is enabled or disabled
+ * \sa set_enabled, enabled
+ */
+- SigC::Signal1<void,bool> signal_enabled;
++ sigc::signal1<void,bool> signal_enabled;
+
+ protected:
+ virtual void on_realize();