summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-19 14:12:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-19 14:12:54 +0000
commit92cc222afe086362fe8d16fd55b18ab358f9677c (patch)
tree42c825f473f6d223b4444cc5fa365ffc72eb9f19
parentalpha/ia64/m68k/s390/sh/sparc stable wrt #397929 (diff)
downloadgentoo-2-92cc222afe086362fe8d16fd55b18ab358f9677c.tar.gz
gentoo-2-92cc222afe086362fe8d16fd55b18ab358f9677c.tar.bz2
gentoo-2-92cc222afe086362fe8d16fd55b18ab358f9677c.zip
version bump
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
-rw-r--r--media-libs/libv4l/ChangeLog7
-rw-r--r--media-libs/libv4l/libv4l-0.8.6.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/media-libs/libv4l/ChangeLog b/media-libs/libv4l/ChangeLog
index 32e16292463b..fef4e84b97e7 100644
--- a/media-libs/libv4l/ChangeLog
+++ b/media-libs/libv4l/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libv4l
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.62 2012/02/02 17:02:25 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.63 2012/02/19 14:12:54 aballier Exp $
+
+*libv4l-0.8.6 (19 Feb 2012)
+
+ 19 Feb 2012; Alexis Ballier <aballier@gentoo.org> +libv4l-0.8.6.ebuild:
+ version bump
*libv4l-0.8.5-r1 (02 Feb 2012)
diff --git a/media-libs/libv4l/libv4l-0.8.6.ebuild b/media-libs/libv4l/libv4l-0.8.6.ebuild
new file mode 100644
index 000000000000..9ea15803b122
--- /dev/null
+++ b/media-libs/libv4l/libv4l-0.8.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/libv4l-0.8.6.ebuild,v 1.1 2012/02/19 14:12:54 aballier Exp $
+
+EAPI=4
+inherit eutils linux-info multilib toolchain-funcs
+
+MY_P=v4l-utils-${PV}
+
+DESCRIPTION="Separate libraries ebuild from upstream v4l-utils package"
+HOMEPAGE="http://git.linuxtv.org/v4l-utils.git"
+SRC_URI="http://linuxtv.org/downloads/v4l-utils/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="virtual/jpeg"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.30-r1"
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="~SHMEM"
+
+src_prepare() {
+ sed -i \
+ -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
+ -e "/^LIBDIR =/s:/lib:/$(get_libdir):" \
+ -e "/^CFLAGS :=/d" \
+ Make.rules || die
+ tc-export CC
+}
+
+src_compile() {
+ emake -C lib
+}
+
+src_install() {
+ emake -C lib DESTDIR="${D}" install
+ dodoc ChangeLog README.lib* TODO
+}