summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-28 20:53:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-28 20:53:50 +0000
commit92325b84ec51bcc16bac99e687727c7826e31e8e (patch)
treeb917fda28635e31a2c3cbe735d95068e2dd749af
parentVersion bump. (diff)
downloadgentoo-2-92325b84ec51bcc16bac99e687727c7826e31e8e.tar.gz
gentoo-2-92325b84ec51bcc16bac99e687727c7826e31e8e.tar.bz2
gentoo-2-92325b84ec51bcc16bac99e687727c7826e31e8e.zip
use the higher quality videos (bug #317283)
(Portage version: 2.1.8.3/cvs/Linux i686)
-rw-r--r--games-strategy/warzone2100/ChangeLog6
-rw-r--r--games-strategy/warzone2100/warzone2100-2.3.0.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index 81ef6ceacac5..4e00984dd4c2 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.40 2010/04/25 22:36:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.41 2010/04/28 20:53:50 mr_bones_ Exp $
+
+ 28 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ warzone2100-2.3.0.ebuild:
+ use the higher quality videos (bug #317283)
*warzone2100-2.3.0 (25 Apr 2010)
diff --git a/games-strategy/warzone2100/warzone2100-2.3.0.ebuild b/games-strategy/warzone2100/warzone2100-2.3.0.ebuild
index 7c2ad5f5860c..749db80b0d9e 100644
--- a/games-strategy/warzone2100/warzone2100-2.3.0.ebuild
+++ b/games-strategy/warzone2100/warzone2100-2.3.0.ebuild
@@ -1,22 +1,22 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.3.0.ebuild,v 1.1 2010/04/25 22:36:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.3.0.ebuild,v 1.2 2010/04/28 20:53:50 mr_bones_ Exp $
EAPI=2
inherit versionator games
MY_PV=$(get_version_component_range -2)
-VIDEO_PV=2.2
+VIDEOS_P=${P}-videos.wz
DESCRIPTION="3D real-time strategy game"
HOMEPAGE="http://wz2100.net/"
SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.gz
- videos? ( http://download.gna.org/warzone/videos/sequences-${VIDEO_PV}.wz )"
+ videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/2.2/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
# upstream requested debug support
-IUSE="debug nls +videos"
+IUSE="debug nls videos"
RDEPEND="dev-db/sqlite:3
>=dev-games/physfs-2[zip]
@@ -56,7 +56,7 @@ src_install() {
rm -f "${D}"/usr/share/doc/${PF}/COPYING*
if use videos ; then
insinto "${GAMES_DATADIR}"/${PN}
- newins "${DISTDIR}"/sequences-${VIDEO_PV}.wz sequences.wz \
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz \
|| die "newins failed"
fi
prepgamesdirs